*SOLVED* Usb Splice Problem (Mayflash 2009 pcb)


#1

The original story was TL;DR so here is my problem: I have a Mayflash board with the cable that contains the wires for both Playstation and usb cut off before the splitter. The usb wires used in the Mayflash are non-standard (white, green, white, and black don’t work when connected to a fresh usb cable,) and I do not have the original usb cable that came with it to test with a multimeter.

This issue is fairly obscure, and as far as I know impossible to solve theoretically without brute forcing it, unless there is someone with the board and the usb who can test it for me.

This is the last step involved with completing my custom arcade stick, and it would mean a great deal to me if someone could help me solve this puzzle. If you require any information from me in order to help solve the problem please drop me a comment and I will find the info.

Thanks ahead of time for any help you can provide!

Drambit


#2

Do you still have the PS2 and USB ends that you cut off? You might want to example what color wires are in that USB end.

I Also fear that Mayflash might use non-standard colors for their USB.

Because if you still got that USB end, you can see what colors it uses, and with a multi-meter you can determine what colors go to what pins.
Then you know how to splice your NEW USB cord .


#3

Edit: After splicing the standard colours (white, red, green, black) my computer doesn’t detect any hardware whatsoever, definitely not standard.


#4

You don’t happen to own a mayflash do you?


#5

If I did I would have provided you with more assistance.
Worst case Scenario you are looking at a PCB replacement. I suggest one of Toodles boards. The MC Cthulhu does PS3 and PS2


#6

Can you post a few pictures of the board itself? Also, do you have a multimeter or other continuity tester?

ETA: Here’s another person’s board image. You should be able to work backward from your board using this.

http://desmond.imageshack.us/Himg88/scaled.php?server=88&filename=58924740.jpg&res=landing

Source: Mayflash PS2/USB + Paewang Revolution duelmod?


#7

Yes I have all the electronic gear one could probably ever hope for, lol. This picture should prove to be extremely helpful, I will update this post with results after.

Update: Completely ineffective.


#8

Completely ineffective, neither my computer nor my ps3 recognized the stick.

there may be something fundamentally wrong here that I’m not picking up on, but I twisted red with grey (supposed vcc,) green with white (supposed data -,) white with purple (supposed data +,) and black with black (Ground.) My computer is telling me it can’t recognize the device, and it is doing nothing while plugged into the ps3.


#9

Ok, try (if you’ve tried any/all of these, sorry for wasting your time);
0.) Go about an inch down the cable from the stick, cut, and re-strip the wires (seriously, a hair-thin wire caused me similar problems a while back)
1.) Confirming the pinout of your usb cable (I’ve seriously seen usb cables with weird stuff like green = VCC)
2.) Going down from the Mayflash and checking continuity from those pins to the end of the cable (in case the colors are different or there’s a break in the wire)
3.) Actually soldering the cable (usb is pretty finicky like that)
4.) Hooking it up to USB and making sure that you can measure VCC on everything you’re supposed to
5.) Check for shorts on the PS2 connector

Should all of that fail, I don’t know what to tell you. You could try desoldering the Mayflash wire and replacing it, but it’s likely in that case that the chip is toast.


#10

Try desoldering all of the OLD CABLE.
Solder to the PCB your new fresh USB cable.


#11

Fixed the problem. Want to know what it was? I had the data - and + colours mixed up thanks to a misleading google search.

It’s times like this I wish I just posted what I did in the hopes someone might notice what I did wrong.

Oh wait:

Actually though thanks to both of you it is now working perfectly.


#12

WELP. I feel dumb for not catching that. Anyway, glad to hear that your stick is working!


#13

Just finished soldering and heat shrinking the cable, a.k.a the cherry on top the project of finishing my arcade stick that has been very lazily in the works for over a year now (many multiple month breaks.)

I figure I should end this thread on a high note.