Some buttons give no response? Help please!


#1

So i just bought a Madcatz TE from someone (used), and everything worked, but the RT button was wired to LB instead. So i opened it up and tried to connect the RT wires to the RT button, but it didn’t work. And i know it’s not the button because i tried to plug in the LT wire to it as well, and that didn’t work. So in short, only the RT and LT wire’s aren’t giving me a response. Every other button works fine. Help please! thanks guys


#2

What model TE do you have and any pics you have of the internals are greatly appreciated


#3

The Triggers not working is a known problem with Xbox 360 TE.
There is no fix for it.

That is why your Seller switched the LT/RT and LB/RB positions.
So that he can play games in 6-button Layout.


#4

I’m not home right now, i could take pics as soon as i get home. But according to jdm714, either way it’s not fixable. :frowning:


#5

Oh alright i see. Well that’s pretty trash :confused: what’s the source of the problem though?


#6

Sometimes unplugging and replugging will make the Triggers work again.
But then the Triggers will just die eventually.
And replugging will do nothing.

http://shoryuken.com/forum/index.php?threads/149353/


#7

so theres absolutely no permanent fix? that really sucks :confused: well thank you guys!


#8

So now my RB was giving my problems. I would play for a while and it would function just fine, and then it would stop responding for a few seconds. After that, it would go back to normal :confused: any explanations?


#9

Button’s may be worn and need replacing.


#10

so is there more of a chance that it’s the button rather than the board or some other internal part?


#11

you think that bad I cant even work box


#12

No idea. Try troubleshooting. Switch buttons and wires around and see what changes.


#13

Hey toodles it’s nick on a new account. I switched the buttons around and still had the same problem, so it’s definitely not the button. RB is still giving me problems randomly, then starting to work again. But i also found that when it did stop working and i hit all 3 punches (X, Y, and RB) it worked again. Weird right? do you have any idea as to why that’s happening?


#14

help please, bump bump bump