Sparky Jr. + Ulia LED not working?


#1

I just installed a Sparky Jr. and Ulia LEDs in a Mad Catz Standard edition Fight stick and they dont light up. So I was wonder which is the ground for from the USB cable because I cut it and tapped into the black wire in the USB bundle, no luck and tired connecting to the outer silver wire and they still dont work.

Do you need to load software on the Sparky Jr. (From FocusAttack) before they light up or am I installing it wrong because I followed the video guide how to install the LEDs on a Mad Catz TE to the letter, triple checked and no luck.


#2

Did you provide power to the LED and LED Controller through the Red USB Wire?


#3

Yes, the Red (5v) power cable from the USB wire it connected to the red wire (Short one that goes to power no the long red one for the red LEDs) on the 5 wire harness on the Sparky. On the other larger harness the plain assorted wires are connected to the black wires on the corresponding Ulia LEDs. Such as Pink is connected to only low punch. and so forth. All the buttons work and I still am not getting any light from the leds.


#4
  1. did you check for power using a meter?
  2. have u tired to just supply power to the led without the sparky?
  3. have you tried to reset the sparky?
  4. did you check your ground and color wires to the sparky and led to make sure they arent incorrect?

#5

We need some pics to help a bit better


#6
  1. My multimeter broke so I wasn’t able to check
  2. How would go about doing that? Connect the Black wire from the Uila to the 5 volt and any of the RGB to the ground to see if it lights up?
  3. I’m not sure how to reset it, I don’t have a FTDI cable or Sparky breakout board
  4. Which is the ground in the USB cable? Is it the outer silver wires that encase the rest of the USB cable or is it inside the silver foil and is that black cable?

I would take pictures but the wiring is really messy and wont show well in a picture, but I followed this video to the letter [media=youtube]PRQCMiHqI6s[/media]


#7

Don’t be ashamed of your wires! I posted that video. I wasn’t scared to take it off and show.

You may want to look around your ScotchLock connections and make sure everything is tightly connected. I actually had a few problems with them not locking tightly enough that I (conveniently) edited out. maybe use some pliers to pop it closed until you see some goop come out. That is the hand moisturizer of Manly Men.

For number 2, yes. That’s how you connect.

For number 4, it is specifically the black wire that is inside of the cabling, not that silver wire stuff, and not that thick black wire, either. I didn’t mention it in the video, because if you cut into the cable, the thick black wire is gone.


#8

Nerrage beat me to it but i would start with #2 since your meter is broken.This will tell you if your leds even work. The purpose and order of my order is process of elimination. first you want to make sure your leds actually work, thats why i want you to just have straight power and ground to the led to ensure they work. since you don’t have a ftdi cable just skip number 3 for now. after you get your leds to work on just power and ground sources connect accordingly to the sparky and see if they work. if they dont then we can move forward to try and fix the problem. I know i have had my moments with led buttons and sometimes i have the power/signal and ground sources in reverse to the led controller but yeah. lmk the results of your test are and move from there bud. if it is a problem with pcb there is a thread for the FA sparky led controller and 32teeth may be able to assist further. just some info for later on in the road when we cross that bridge


#9

Thanks Nerrage, turns out the scotch lock on the power was slightly slanted and didn’t bit into the wire. Also the sparky only seems to work when I attach the ground to the outer silver wire not the black thin wire in the USB bundle.

Now I got some LEDs to work but I only see blue and green. And certain button combo make it shut off completely, and I went back and checked all the locks and they all are seated properly. I made a video to show my problem [media=youtube]V-ie64XHZYs[/media]


#10

did you mess up the daisy chain?


#11

That’s what I initially thought as well because at first I put as many wires as I could in one scotch lock which was 6 wires, and only used 3 scotch locks. But i went back and did a proper daisy chain where there was only 3 wires in each lock and same result.


#12

oh god scotch locks…
i never deal with those things

ever
i just find them unreliable


#13

@ mr.mortified You’re right, I found out the hard way all my problems were from the scotch locks, everything was hooked up correctly and I used all the scotch locks correctly but somehow they still failed.

@ everyone else thanks for the help I finished it and got everything to work

Here is a vid of the final product, [media=youtube]D8yQSVCcURs[/media] Thanks again you guys were really helpful


#14

Good stuff

General advice for anyone,

solder and don’t use scotch locks


#15

glad you got it working.