SSF4 AE for PC ---- horrible input delay


#1

I’m about to switch back to PSN for Christ sake.

I use a PS2 controller with an PS2 to USB adapter. It could be the adapter, but I’m not sure. I even used my PS3 controller connected and the input delay was still terrible.

So what is it guys? I tried turning off VSYNC and other stuff, fixed framerate all that but still no avail.

I’m sure Vanilla didn’t have this problem, and PSN sure as hell reads better inputs than this.

Has anyone found a solution to the input lag behind PC AE?


#2

I hate to be the douche that says it, but Get a better rig. If you’re PC can’t handle it, it can’t handle it. Although it could very well be your adapter so try it with other games to see if the same problem applies. If you happen to have Vanilla try that too.


#3

The patch update fixes allot, you tried to update?


#4

What patch? Where?

Also, my computer is pretty awesome dude. I run an i7 with the nvidia geforce 580


#5

What motherboard do you have?It could be that. Try updating usb drivers?

I havent experienced any input delays on PC.


#6

I have an Asus motherboard, it was one of the best one’s they sold at Fry’s couple months ago.

Are you sure?

Actually it’s not exactly an input delay. It’s more like the game doesn’t recognize/buffer a certain amount of inputs. In PS3 I was able to buffer combos and do moves ahead of time. but in PC AE, it has to be exact, and cannot be buffered so easily like in PS3. do you guys know?


#7

Connect a PS3 controller, install MotioninJoy drivers and select “Emulate xbox360 controller” in there. Problem solved. At least I play every game like this with no problems, of course also SFIVAE works perfectly in regards to inputs.


#8

I think I know what you mean and I noticed it too. I don’t think there is anything you can do about that. I suspect that since the framerate of the pc version can almost be twice as much or a lot more than 60 fps there is a difference from what you see and the input you put in. So the feeling of being exact is because the game is displaying its self more frame by frame on pc( because of higher frame rate) compared to the console.

I wish capcom would give you an option to lock fps at 60.
I use to playing pc games where you can set your own fps.
Anyways, my 2 cents on the matter.


#9

There is no hope for PC then…


#10

What are your PC specs? why hasn’t anyone asked that yet?


#11

I have an i7 and a less powerful GPU with 2 PS2 controllers connected via 2 USB adapters and have zero issues with it here.
Even running solidly at 60fps in Nvidia 3D Vision.
It works fine with a 360 controller emulator or without it as well.

I just choose to use the 360ce with it though because of the mod I made in my sig :wink:


#12

It might be a possibility that you don’t notice the input problems. I mean, in PS3 it’s soooo easy to buffer combos and plinking is ridiculously easy it’s not even muscle memory material on the PS3.

However on AE, I would buffer some combos and there is always that last hit/move that didn’t register and just goes neutral

If you wanna run a test and see the difference… Run the game and pick Sakura. Do this combo:

(jumping crossup) —> j.mk --> c.jab --> c.fierce --> ex tatsu --> ultra 1/2

Now the combo is easy to do in training mode but I can guarantee that online with that slight lag it’ll totally mess you up. However, on PS3 I was still able to link the combo like cake online. Compare the difficulty of this combo on PC and PS3. If not Sakura, then you can try Ryu’s plinking combos


#13

That combo is absolutely nothing to pull off online with lag or not, and idk why you’d need to plink it… But, you answered your own problem. You used to play on PS3, where there is 2 frames of inherent, additional input delay. You cannot plink and buffer as easily on the PC because there is NO delay, so you have to adjust (slow down) your timings appropriately. Using your PS3 memorized timings will not work well for you.


#14

So wait, you’re saying that the reason I’m feeling this input delay is because PC has no delay, and because the timings I’m doing is too fast?

I don’t think so man, because if that were really true, then it the same buffering or press buttons ahead of time thing would work. In PC, it doesn’t, and everything has to be more precise and exact. I would’ve adjusted by now. I don’t know what it is, but I don’t think what you said is right.


#15

The PC version already lock framerate at 60FPS, without vsync. Don’t trust me ? Download FRAPS and see for yourself.


#16

I have the exact same problem. And my rig is really good. Pushes 250+ FPS , no problem.
Also Vanilla doesn’t have the same input delay, so something’s definitely wrong with AE. It doesn’t get much attention though, so it’s unlikely to be fixed.


#17

I don’t think that’s true because if I disable vsync I get screen tearing.


#18

The problem for me was severely reduced once I switched from a PS2 USB adapted controller to a PS3 adapted controller.

The timings, comfort, and precision feels normal to me again. I apologize for the misconception. I’m really happy with it now.

Just so you guys know, PS3 controllers DO work on the SSF4 AE PC… and there is no need for “MotionJoy” or “XPadder” or any of those.