SSF4 AE on PC game runs too fast


#1

Hey everyone.
I recently bought AE for the pc and it’s running way faster than the console version. It’s almost unplayable and I wouldn’t want to get used to the non-standard.
I have vsync on and Fixed framerate and I’m getting about 140ish fps.
How can I cap the fps to 60?


#2

Turn off Vsync for a start or that’ll mess with your executes.

I’m not sure about the FPS issue, I had that happen a couple times way back with Vanilla, but it was kind of cool, it was like playing SFIV: Turbo. I think I tweaked a few things in the graphics settings and it sorted it out, but I honestly can’t remember what. Sorry :frowning:


#3

Force Vsync through ATI catalyst or Nvidia’s control panel.


#4

thanks for the advice.
Well if I turn Vsync off the fps jumps to about 220 which is pretty much unplayable.

[INDENT=1]I’m not sure what that means[/INDENT]


#5

Might seem like an obvious question, but just in case: you have checked in actual gameplay right? It’s normally fixed at 60 fps in games, the benchmark shows what it could go to.

What happens when you go online? Obviously one guy capped at 60 fps (the norm) and the other at 140 fps isn’t physically possible… I would imagine that it’d force you down to the 60 fps.


#6

Please make sure the game is patched and updated.

However, if it still runs too fast to be playable, you could always try a program to limit the fps, such as FPS_Limiter.


#7

yup I’ve checked the actual gameplay.It’s only faster in single player, multiplayer is fine. (unless it lags but that’s a different problem)

The game is up to date and everything. I’ve seen threads about the FPS_Limiter(haven’t tried it yet), I just wanted to know if there was a way to resolve this without using 3rd party software.

Thanks everyone for the advice!
Anyway it’s not that big of a deal.I can practice on xbox, and only use pc for online so it’s fine I guess. (or I could try the FPS_limiter as a last resort)


#8

Can anyone help?

I’m having the same problem it’s feel like I’m play ssf4 AE turbo edition. I know it’s not just me
because when I’m fighting other character online they are moving fast, fireball is super fast you can get you link in like nothing.It’s not fun facing a super tubro balrog,t-hawk and turbo sagat. Back to my ps3 until i figure it out what a waste off money.

I try turning off vsync and putting it on fixed plus disable steam option still same.

My ssf4 AE Benchmark is
A+
141 FPS

My PC
Intel Quad core 3.4
4 GB RAM
Nivdia 560 GTX

BTW I been snooping shoryuken for about 3yrs now and I finally decided to register to shoryuken, see if i can get help.

Thanks all


#9

Check out if the fps is in the fixed version. I don’t have any other idea.


#10

Do you have an ATI or NVidia card? Open up the control panel for whichever card you have, there should be an option in amongst the tabs to force Vsnyc to be off, select this (and also disable any pre-rendered buffering).

I did have the same problem as you in Vanilla and one switch of the graphics settings changed it, I can’t for the life of me remember what. If I get enough time later, I’ll try and recreate the problem and see if I can give you an answer.