SSFIV AE PC Version - VSync on causes input lag?


#55

No. His model includes sprites, and Intel’s gpus don’t like sprites, that’s all.

It won’t cause input lag, it’ll cause framerate problems.

Also I tried Radeonpro and Afterburner, neither of them do anything for fusion processors it seems. If anyone can help solve my problem, let me know.


#56

I play @ 720p with Model & Stage @ high settings while the rest are either low or off if possible, don’t really care about the rest of the settings and visually the game looks like the console version.

With those settings, the Oni vs E.Ryu benchmark gives me an average of 80fps, which is more than enough. I tried playing as E.Ryu vs Oni in various stages like Old Temple, Rog’s stage and Seth’s 2nd stage and they all ran without any issues at all, stable 60fps without any drops even during ultra animations or finishers.

My ASUS maximums mobo overclocks the CPU by default to 3.7ghz and the GPU runs at 1100 Mhz which is within specs of the HD3000, didn’t try any manual overclocking as I don’t have an aftermarket air cooler yet. RAM’s @ 1600 Mhz which I think affects a built in GPU’s performance.


#57

the input lag is in your head mate, no seriously i play it on the pc myself using an official PS3 controller with VSYNC on always and there isnt any input lag, it might feel like that though.


#58

There definitely is an issue with vsync at least for me. And it only happens for online matches. Green bar games feel like 1 red bar. Im using a 120Hz monitor so who knows. But it generally agreed upon that vsync fucks up performance for any game.


#59

there was actually another post about this. Someone was having issues with the PS2 controller and it went away when they switched to a PS3 one. I’m using a stick so whatever worked for you isn’t going to work for me. I can land Ryu’s cr.MP > cr.MP > cr.HK link 100% of the time on PS3, Arcade and Xbox360 (it’s not a very hard link) on the PC version the cr.HK doesn’t come out ON TIME.

Edit: Added ON TIME because it’s getting blocked every time on the PC version of the game.


#60

Not to state the obvious here, but if there are 4 systems on which you use the same visual timing for a combo and on one of them a move isn’t coming out (as in, you pressed too early), then that’s the system with the least amount of input lag.


#61

Fixed my post, I left out the words “on time”. Either way, I have not figured it out and I probably wont. I tried the vertical sync adjustments, plugging the stick directly into the motherboard, using one of the other three sticks I have to no avail. Went and played some people and the only responses I got where “I’m playing with the same penalty as you” which doesn’t help at all.


#62

I got a lot better since I turned vsync off, before that I couldnt even do 3 frame links online, let alone 2 and 1 frame links lol


#63

I had the same problem with an old 4870… vsync just make the game very laggy.

The solution is, turn off vsync in the game but force it in the drivers, then you have your vsync and no lag :smiley:

for 7xxx users (I am one of them now) Amd have a little micro shuttering, that is something related with the memory management of the drivers, and Amd is working on it so keep your drivers up to date.

I’m on i5 ivy with Amd 7870 and fighting on PC version perfectly with a Samsung S27A750D @ 120hz

Remember to edit config.ini in your documents/capcom folder to something like (120hz only if you have a 120hz monitor, if not you will play at 60hz):

[SYSTEM]
RenderingThread=ON
SystemSpeed=1.00000
SystemRank=A
Version=2
MultipleKeyboards=OFF
[DISPLAY]
Resolution=1920x1080
RefreshRate=120Hz
FullScreen=ON
VSync=OFF
FrameRate=VARIABLE
Aspect=AUTO
[GRAPHICS]
MSAA=4x
TextureFilter=2x
ModelQuality=HIGH
StageQuality=HIGH
SoftShadowQuality=EXTREME
SelfShadowQuality=HIGH
MotionBlurQuality=HIGH
ParticleQuality=HIGH
ExtraTouch=INK
Brightness=50
[BENCHMARK]
Type=BATTLE+DEMO
Loop=OFF
[GAME]
FPS=OFF


#64

On my laptop(with intel hd graphics 4000 and i7 3.0) that I use for work, I can easily run the game at the highest settings at 720P with no problems. TBH I can play a ton of games at medium-high with no problems at 720p.


#65

Thats why I like consoles, same conditions for everyone, no struggle with settings :P. But for my PC Version, I turn vsync off, always.


#66

Okay, been reading this thread for awhile after getting ae pc and have now carefully analyzed and figured out a few things.

There are two different scenarios of input lag on ae pc with v sync.

One is the normal amount of input delay inherent from v sync. It is probably around 1-3 frames tops and brings the PC version to exactly match the arcade and 360 versions.

The second is a very common bug on ae pc with many graphics cards and drivers (mostly amd from what I can tell) that causes the game to v sync at 50fps instead of 60fps. This causes a huge amount of input delay that is probably well over 10fps , screws up the game framerate obviously and is what most people here are experiencing when they are complaining of hugely different timings from arcade and 360. Those of you complaining about feeling like the game is playing underwater with v sync on are experiencing this bug. Unfortunately there is no way to natively verify this in the game as the benchmark turns vsync off regardless of your setting. The only way to test this is to run a frame counting program like fraps and start a battle with vsync on to see if the frame rate drops to 50 (menus might still run at 60fps with this bug).

Lastly, we have another problem in the fact that playing with v sync off makes the game actually respond faster than arcade and 360 while also possibly screwing up strict frame timings because of visual screen tearing and other issues because the game was not meant to be played with v sync off. Technically when u play online on PC the ideal setting would be everyone to have v sync on (without the bug) to play at the intended speed and input delay. The problem is that a huge amount of people play online with v sync off so they have a huge unfair advantage of reaction times faster than intended (even though it can mess their combos up). You can tell when this is happening if you encounter someone that consistently beats you in air to air attacks just because they always attack first.

While technically this is the best version of ae, you will encounter a vast number of players online with v sync off that have an unfair reaction time advantage and the only way you can fight that is by turning v sync off yourself in which case your 1-2 frame combos become unreliable as your not playing the game as intended.

For these reasons I have to unfortunately go with the Xbox version being the best for random online play since no one has buggy v sync and everyone is playing with it on as intended.


Ultra Street Fighter 4 General
#67

Does anyone run the game off of Steam?


#68

I do. And convinced a few friends to do the same during the Steam sales a week ago. No more MS Live tax.

The whole vsync problem was solved for us by setting vsync OFF ingame and ON in the graphic card properties. It feels exactly the same as 360 SF4 timings.
http://imgur.com/Wyq3DgG


#69

vsync will always add 1f input lag no matter where you turn it on. that’s just how vsync works. but yes Capcom PC games seem to have an especially big problem. not sure why their vsync is so bad but it makes it way laggier than the expected 1f.

if you can get used to screen tearing the least laggy experience is actually with no vsync on whatsoever


#70

Agreed. Though for tournament players, getting timings as close as possible to consoles versions is important. And it’s possible, I even got rid of screen tearing doing this.


#71

Hmm, I would have never really thought that forcing vsync through the drivers (over simply having it off in general) would have been the solution, but that just eliminated the ridiculous 1-3 seconds of input lag I was experiencing online. It went from completely unplayable at all, to feeling about like XBL when both parties have a decent connection.

Not sure that was actually his question since you don’t pay for XBL to play the PC version online anyway?


#72

I’ve tested between vsync completely off, vsync on in-game, and vsync off in-game but forced through Nvidia’s control panel (as well as triple buffering). At the absolute most, I would guess there’s a 1f difference, but even that I can’t be sure of. Nothing like the 8-10f lag some people are experiencing. All I know is I can do cr.MP -> cr.HK just fine on all three settings (off, on in-game, on via GPU).


#73

something i noticed with time is that the more you play, the better your execution is, the less lag input is problematic, i played at a friend house yesterday wich had in game Vsync on and then pc plugged to a big TV wich does not have any form of game mode, so the lag was pretty horrible, but i somehow adapted quickly and could combo most of the things , i would have preferred less lag input ofc, but thats what i though with my time experiencing lag input over different settings/monitors

am currently turning off ingame Vsync and using the Nvidia Vsync instead, i found it to be the best option so far, the worst being turning Vsync off everywhere as it cause some weird frame skeeping


#74

I had the same problem. I play with a friend from Canada and when we had the in-game VSync on, halfway through our matches we would de-sync. What I mean by de-sync is that we’d be playing two completely separate matches. Our inputs would either have 3-5 seconds of delay or they’d stop being read altogether. All of a sudden, I’d be hitting him with everything and landing big damage. I’d laugh and say he got wrekt, then he’d laugh and say I just got wrekt (over Skype). A couple seconds after the round ends, we both get the “Lost Connection to Opponent” popup and have to restart the set.

Turning off the in-game VSync and specifying my nVidia card to turn VSync on for SSF4 solved the problem.