Strange dual modded TE PC compatibility problem


#1

I bought a madcatz TE sfxt VS stick and had the guys at EVO dual mod it. It’s a 360 stick originally and works completely fine for that console.

The problem is when I plug it into the PC via USB the guide button flashes full circle green for about a half second and then nothing responds. The LED inside the stick light up and when I check what devices are connected my PC finds a PS3 controller. It seems abnormal that my 360 stick is recognized as ps3 and won’t work. I tried getting the latest 360 controller drivers from microsoft to no avail.

Any ideas? thanks!


#2

It is supposed to show up as PlayStation 3 on PC by default.
But it does not work?

Tell me on what day you had it modded.
I only worked on V.S. Edition on Sunday.
Gummo did V.S. on Friday and Saturday.


#3

I think it was Saturday but I’m not 100% sure. It was a white guy who took care of it.


#4

If it is a ChImp board installed inside, hold down 1k, 2p, 3k to force 360 mode
if it is a cerberous board, hold X


#5

What do you mean by it won’t work? “my 360 stick is recognized as ps3 and won’t work”.
It will default as a ps3 stick when plugged into a PC unless you brute force it to be recognized as a 360 stick by holding 1k,2p,3k while plugging it in. The stick should work fine regardless of which system mode it is in.


#6

When plugged in on ps3 mode the xbox guide symbol will flash momentarily and then the stick dies; it fails to respond to any commands. Could this mean there might be an issue when I use it on a ps3? I don’t currently own one to test it on.

But anyways, thanks for the responses. Using 1k 2p 3k to start the stick up works perfectly!


#7

You probably didn’t configure it to take a generic controller rather than a microsoft controller
Check game controllers and see if ChImp PC/PS3 Controller shows up in the game controllers settings.


#8

What commands does it fail to do on the PC? Its probably failing because the controls for the program need to be remapped.


#9

What does it show up as when you plug it into a PC in the game controller’s applet? (Start->Run->“control joy.cpl”) We need that to know what’s in it, and that’ll make it easier to understand the setup and problem.


#10

Its a chimp smd


#11

For all intents and purposes the stick is ‘dead’. Not a single button responds.

It says ChImp PC/PS3 Controller status: OK


#12

In the same game controllers applet, can you go to its properties and see if it shows button inputs?


#13

Thanks for the help. You guys are very smart dudes. I am an idiot and I totally didn’t even look at my control mappings for ps3 mode.


#14

glad things were fine.


#15

this thread was better when the stick didnt work.