Strange Dualmod Issue


#1

I have just recently finished another dualmod setup, now the strange thing is everything works fine on PC (while testing), both PS3 and 360 mode. However when I plug it in the 360 console it won’t recognize or pick it up. I tried on PS3 console and everything works as per usual. I have done dualmods before but have never encountered this problem. Can anyone shed any light on this please?


#2

what are you useing for the dual mod and pics of the dual mod will help a lot with wiring issues.


#3

I dualmodded a PS3 TE using a IMP and QanBa 360 PCB. I have checked wiring, everything seems OK. Works on PC but can’t get it workin on 360 console.


#4

I’m not familiar with the quanba pcb but maybe you wired the data lines incorrectly? both pcb’s powered and grounded the issue would be in the data lines no?
just thinking common sense imp isnt autodetect so when you tried to switch over to 360 arent you supposed to hold down a button?
just throwing some things out there for you so maybe you might be able to catch the error from someone elses perspective. hope you find out what the problem is.


#5

The thing that befuddlez me is that PS3 works normally and while testing on PC, both PS3 and X360 work normally. I setup so RS would be to switch to 360 mode.


#6

I’d say it’s the IMP if all other things are correct. Seems like the Imp has an issue switching some PCBs. Although it’s strange because it’s just data lines connected to the IMP. Try using a manual dpdt switch in place of the IMP. Seen it on some cases. It’s strange because it may not work on that set up, but if you try it on another dual mod, using different pcbs, the IMP will switch fine. Just did this on a VLX the other day. No luck with the VLX, but used the IMP on a TE board and it worked fine.


#7

Pure speculation on my part, but I think that the IMP does the switching using diodes/transistors which imply a voltage loss whereas there’s none with a DPDT. I know I had this kind of issue regarding voltage drops that made bencao’s dualmod method fail on me (using optocouplers). Now why would that make the dualmod work on PC but not 360 due to this, I have no idea…


#8

But if it was the IMP, wouldn’t it not switch at all? I’m able to switch from PS3 to 360 fine while testing on PC. The real strange thing was that I only rewired my crappy wiring and soldering. As before it would sometimes dc while using stick (I knew this was due to my wiring skills, or lack of!). I don’t know if this would help, but I have used the setup (QanBa 360 PCB, IMP and PS3 TE) for dualmods atleast 5 times before with no issues.


#9

try a different usb cable it wont hurt


#10

I had the same problem a few weeks back. Remember when I msg’d you for the IMPs on Ozhadou (but didn’t end up purchasing them cos I fixed the issue)?

I eventually just purchased a DPDT switch and did the switching that way.

It took me a total of 40 man hours spent on that particular dual mod as I re-wired/resoldered everthing three times over. I tried two imps and it gave me the same results, tried switching the imps around, although mine problem was it would be recognised on 360, but not on PS3, but on the PC it would be recognised as the two different PCBS.

Try getting a DPDT switch from jaycar


#11

Ok, I’ll give it a go. Just strange though, seeing that it was all ok to a certain degree before I decided to rewire and resolder everything. I got one switch lying around. Never used a DPDT switch for dualmods before. Guess I’ll have to give it a try. Still, as I said before I don’t understand how or why it would work every other time with the same setup but only this time something plays up?


#12

hmm, that is interesting. As I changed the USB cable to another one (I used the USB cable Madcatz sent me). That is the only difference. You really think the USB cable itself is the problem?


#13

Yeah I know its really strange, and it really is.

I’ve done over 30 dual mods with Imps, and worked every single time, then this one particular time, it just got baffled, it even got toodles baffled.

All forms of trouble shooting was done:

  • tested the pcb on its own, and it worked.
  • tested every single point for continuity on the multimeter, and there was definitely continuity
  • tested new Imps and different D+/- slots.
  • used different points etc…
  • changed usb cables
  • changed gauge of wires, I went from normal 30awg that i use and tried solid core cat6e cables.

You name it, I tested it and everything was working as it should’ve on the computer, but then the moment i plugged it in on the ps3, the mofo just wouldn’t work, and it seems like thats the exact same problem you’re having but with the 360.

The moment I changed to a dpdt switch… everything worked fine…

using a dpdt switch is relatively easy, you place the USB +/- into the centre of the switch, then the +/- of each pcb on each other end of the stick.

this is the dpdt switch i purchased:

IP65 Rated Round Rocker Switches DPDT 250VAC 6A - Jaycar Electronics

I changed the cable 4 times with my issue and it didn’t do jack. That being said, there was one dual mod which suddenly died after one year and I found that the USB end lost continuity.


#14

This is really worrying me now, not for myself but more the fact that I was always comfortable selling dualmod packs to people. I will play around with it more on the weekend and see what happens…fingers crossed


#15

Just make sure to plug it into a 360 console and PS3 to ensure everything is switching correctly. So I used one of the Imps that didn’t work with my VLX, but sure enough worked with my MC Cthulhu set up on the TE. I was reading some people install diodes in the signal lines when the IMP doesn’t pull the correct voltage. You might want to give that a shot. It’s in Toodles Imp thread.