Sudden problem with reading/burning dvds


#1

I’ve been burning and watching dvds on my dvd roms/burners for quite a while now, but recently it had just stopped. And the strange thing is, even if I switch dvd roms and burners, the problem persists, which makes me think it has nothing to do with the hardware at all.

When I put a dvd to read, the device just refuses to flash and says there is nothing in there. Cds work fine though. And it is not the actual dvd itself that is the problem, since I’ve tried many of them and none work (even though they worked fine at a friend’s house).

So, what could possibly be the problem? I don’t want to reformat…


#2

What do you mean by switching?
Putting a totally different optical drive in your system?


#3

It means I took out my previous dvd rom/burner, and put in another one. I’ve tried about three so far. These all used to work before, now none of them work.


#4

OK, at first I was thinking your drive might be worn out.

Do you have disc emulation software running?
I had this once and that kind of software,
removing them all helped me.


#5

You should check the settings of the transfer mode of the IDE channel. When windows detects a certain number of read errors from an optical drive it will automatically decrease the transfer mode (in hopes of reducing the chance of read errors), until it ends up at PIO (which is polling mode, and sucks A LOT). To check this open up the device manager and select the IDE channel your drive is on. If the transfer mode is set to anything other than your drives highest rated setting you’re going to need to remove the IDE channel and let windows redetect/install it so get it back into a DMA mode.

You can read more about this here.


#6

How do I check what IDE channel my drive is on? Btw, it says my secondary IDE channel is PIO, but the other one (Primary) is Ultra DMA Mode 5.


#7

The fastest way is to check the first page in the BIOS setup (most of the time).