Sudden tearing on AE pc


#1

It wasn’t an issue before. My motherboard died and I got it replaced. Nothing has changed but the game has some bad screen tearing now, while running 60fps on a 60hz monitor. How is that?


#2

Vsync off ?


#3

Yes.

AA off or at 8x makes no difference the game is playing at full frame rate with no input delay. Vsync causes input delay sometimes.


#4

But vsync on will fix your tearing problem.


#5

Vsync on will make the inputs majorly delayed. The problem is I didnt have this issue before with Vsync off. Did the game update or something?

Ok just figured something out. For some reason my screen doesnt fit properly at native res ONLY while playing AE. My native res is 1440 x 900 but the screen is too tall? Its set to 1440 x 900 too. Basically the GFWL pop up is showing only half into the screen. My monitor is completely adjusted properly. So I’m wondering if this is the cause.

Fixed this problem but its of its own. It was a bad aspect ratio. Changed it to 16:10 in the config.ini and its as it should be. It didnt solve the other problem.


#6

It’s possible that windows automatic updates altered a driver that introduced an issue, or then possibly just reset its configurations. Maybe vsync was forced on in your graphics adaptor settings. I’ve thought that I had noticed a subtle change in responsiveness when having vsync forced on but not in the game versus switched on in the game, but I can’t say for certain that I have. Also downgrading my nvidia drivers improved the game’s performance for me.


#7

Vsync and all types of buffer are off and always have been. I was thinking it could be a driver issue so im going to reinstall my drivers soon. I can play seemingly fine ignoring it for now so I will just uninstall, sweep, and reinstall later.

I have a 6850, and I know performance has increased a bit since it came out driver wise. I play a lot more than SF so im not gonna downgrade when the game is running at perfect frame rate. I guess I rather have tearing over frame lag/input lag.


#8

Updated to the latest drivers and still no go. Maybe its always done this and I had not noticed? I swear it didnt though because its very bad now. Tried removing the OC on my card and its all the same too. Maybe my monitor is just dying :frowning:


#9

Turn off in game vsync. It is also possible that the game is running higher than 60 fps. Run the benchmark and see how much actual fps you get because i get 113 fps but the game stays at 60 during actual gameplay.

Instead i recommend using D3DOverrider, it basically forces in game vysnc and enables triple buffering without the shitty performance loss


#10

I tried Vsync in CCC and it doesnt work on AE. I tried updating my drivers but it caused a massive performance loss in several games. I did find something useful. I was messing around in my monitors options, and I found the ABOUT and it reports the monitor usiong a 59hz refresh. I dont know why this happened and I cannot seem to change it. But CCC and windows say its running at 60hz. No idea, but im gonna get a new monitor and solve the issue the easy way as this thing is 6 or 7 years old. Its an LCD but its just too old.

will try d3d later but for now im going to bed. Thanks for the input thus far. You wouldnt believe how steam forum users lack the ability to read.