Super Joy Box 5


#1

http://www.play-asia.com/paOS-13-71-6m-49-en-15-super%2Bjoy%2Bbox%2B5-70-qc4.html

Anyone have one of these? I got it on Saturday and used it with MAME32 with 2 players and it worked fine. The next day I plugged it in and Windows recognized 2 controllers plugged in but MAME wouldn’t recognize either.

It only works if I use one controller, which is pointless because this is meant for 4. Although Windows recognizes multiple controllers, for some reason the 1st one is always in “turbo-fire” mode under Game Controllers - Properties. Like if I hold anything down, even a direction on the stick, it will register as being pushed very quickly instead of held.

I downloaded the drivers and those didn’t do anything. I read many reviews saying this thing worked great but now it has me wishing I kept the cheap rip-off I bought on EBay. Any help is greatly appreciated, thanks.


#2

a couple quick questions, then a note…

Q0: What version of Windows are you running?

Q1: What version of MAME are you using?

Q2: Do you have any other USB gaming devices hooked up to your PC?

Q3: Under Windows Gaming Options (in the control panel), what are the IDs listed for this adapter (with the controllers plugged in)?

Q4: Are all your controllers plugged into the adapter before connecting it to the USB port?

Note: Windows gives the option to change the IDs associated with your USB gaming devices, however certain versions of MAME do not care about this, and use the physical order device listing instead. This means you must go into MAME and change the joystick IDs to use any device beyond ID4. Even if you set that device in Windows to be ID1.


#3

Q0: XP
Q1: MAME32 v.113
Q2: No
Q3: They show up as Tiger Gaming something or other, and the ID numbers are correct (ID1 through ID4).
Q4: Yes the controllers are plugged in before the adapter is.

Actually I was playing around with it after initially posting, and MAME recognizes the controllers (as in they work fine playing the games) but the problem is within setting the buttons. If I try to configure the buttons with a controller other than an official Sony dualshock, pressing any button immediately configues it to “None.”

Also, when setting Player 2 controls, it would always say “J2 Button 1 not J1 Button 1” instead of just saying “J2 Button 1” like it normally would. And this leads to the next problem…

So I set all the buttons for all 4 ports using the Sony Dualshock. Players 3 and 4 worked perfectly, but players 1 and 2 somehow were both controlled by the 2nd controller, and the 1st controller didn’t do anything. Plus both players had the “turbo-fire” problem, where if I hold forward on the stick instead of walking smoothly forward they would keep tapping forward like I was trying to dash.

I don’t know if this matters but here are the controllers I was using:

Player 1 - HRAP2
Player 2 - Generic Dualshock
Player 3 - Sony Dualshock
Player 4 - Same as 2


#4

Hmmm, that is odd. I have a couple of these adapters lying around. I’ll test them out and see if I run into similar issues.


#5

I played around with it and found that it’s just my HRAP2 that has problems. If I use it by itself the adaptor works fine, but with any other controllers plugged in the HRAP2 goes into the turbo mode. All my other controllers work fine with it. Guess it’s going on EBay.


#6

Hey guys I was wondering how to change the ID for each controller because when I configure it, whenever I press a button on the 1st controller it also presses that button on the 2nd controller, and so on. Also, another problem when I connect more than 1 controller is it works fine with 1 controller (with analog), however when I connect a second one (non analog), the above happens, but also, when I press a button on the 2nd controller it is as if it were on rapid fire when it isn’t…

Thanks


#7

in mame config it will let you change the ids of the controllers, and i got one of those but the blue ones, and i had 4 ps controllers hooked up before to play SUnset riders 4 players and it works fine:wgrin:


#8

hmm still can’t get it to work… could you explain please?:wonder:


#9

Game controllers on the pc are a pain in the ass, I gave up expecting games/emulators to support them properly a long time ago.

save yourself tons of hassle, use Joy2key, it’s free software that converts button presses to keyboard inputs.
http://www.electracode.com/4/joy2key/JoyToKey%20English%20Version.htm

Had no probs since I started using it.
Just dont use ctrl, shift, alt, or any of the F keys as these will mess with emulators.

The super joybox 5 is great btw, I use it with two cordless action pads for everything I play, still got two ports left for custom sticks too.


#10

aww i still can’t get it to work even with that program… what happens is when i set it up, the first player works, but when i press a button on the 1st player it also presses the same button for the 2nd controller, 3rd controller, etc. and when i press a button on controller 2 it presses the same button on 3rd, 4th, etc. its like all the controllers are connected to each other some how… could someone explain how to make them as separate controllers?

thanks


#11

Sounds very strange…

are you seeing this behaviour in windows game controller setup?
(start/settings/control panel/game controllers [select a pad & click properties])

If you are then it looks like your super joy box is defective.
To give it one last test - completely unplug joybox (all pads and from pc) remove the joybox software (“Tigergame ps/ps2 game controller” from control panel/add or remove programs/). then plug everthing back in and re-install.

If that does not work then I would get it replaced.


#12

in the game controller setup it detects more than 1 controller, but they all have the same name. when i open the properties of the second controller and press buttons on the 1st controller i can see the buttons light up. its weird though because when i hold a button on either controller the button flashes like its on auto-fire… but for the properties of my first controller everything seems to be fine.


#13

They are all supposed to have the same name (uses the same driver for each joypad).

Your joybox sounds knackered with the other weird behaviour though.

You have tried a reinstall as broken down above - right?
Also, have you tried it with different variations of pads plugged in (just try 2) as it could be just one of your pads knackering it up like the guy who started the thread (your probs sound similar)

Other than that I can’t help you.


#14

yeah i’ve tried it with just 2 controllers… does it matter if i have 1 ps2 controller and 1 psx controller? i don’t think it should matter cause it supports both.


#15

well i just tried unplugging, uninstalling then replugging it in and installing it but still the same problem… does anyone else know how to solve this problem


#16

Is everyone here pretty much using XP? I primarily use 2000, and I don’t remember ever having any issues with any of my controllers/sticks. And I have used four at once before. I’ll run a couple tests this weekend when I have access to an XP machine. I’ll let you know if the OS makes a difference.

P.S. You guys are sure the adapters aren’t in DDR mode right…


#17

how do i know if its in DDR mode or not?
thanks xorcist


#18

Normally you can tell if the directional pad comes up as buttons rather than actual joystick axis. The controllers are put into DDR mode by pressing START+SELECT+UP for like 3 seconds or you can set it through the driver in the joystick config window (pending you have the drivers installed).

Just a quick side note, it’s always good practice to hookup all the controllers to the adapter, before plugging the adapter into the USB port. I’ve found that nine times out of ten that will fix most weird issues that occur when another controller is just plugged in.


#19

yeah i always plug in the controllers before plugging the usb into my pc but i still get this problem…by the way i can’t see any option in the config to change it to DDR mode? which config are you talking about is it the one in control panel>game controllers


#20

nevermind, i see it now its not on DDR mode. thanks