Switch-less USB selector for PS3+360 "Imp": Re-Design Underway, Input appreciated

As far as my wretched brain will have me to understand it, yes.

Try it and see…

Gahrling is right, the outgoing USB cable needs to be connected to those spots. If the impv2.pdf was unclear on this, I’d welcome any suggestions to improve it.

I solved my initial problem by using an Imp v1.1 with an old 4066N chip on it, switching worked perfectly when the guide button is held, I made the default the 360 as the person I modded for rarely used the PS3 (was a ps3 vlx)

I also had the same problem with the same Imp v2.1 on another stick I modded (this time it was an MC Cthuhlu and the madcatz fightpad - wired as per instructions), it just wouldn’t for the life of it want to switch to the 360, it would work fine for the ps3, but just wouldn’t change for the 360. Tested for continuity and there was definitely continuity between all points, confirmed that A and C jumpers were shortened.

I fixed that problem by using another Imp v2.1 I had as a spare.

I’ve now got two uselss imp v1.1’s and 1 imp v2.1’s :frowning:

[S]I just want to confirm that I’m wiring the imp v2.1’s correct (hahah i’d be funny if this wasn’t the case).[/S]

[S]I’ve only had 2 experiences with the Imp v2’s and both times they were with an MC Cthuhlu, I wired it as per the welcome sheet ie. all the corresponding letters from the imp to the mc cthuhlu.[/S]

[S]I also wired the USB cable to the 4 holes on the bottom left of the IMP under the USB section (unlike Nytemare_Raven who doesn’t appear to have any points wired to the USB section)[/S]

[S]I’m guessing that’s correct because it worked out for both mods and it auto switches great.[/S]

edit: nevermind, I did read the welcome sheet correctly and Toodles confirmed as I posted :slight_smile:

@Toodles, I think people skip the first page of the welcome sheet (I know I did and went straight to the wiring section, I only re-read it because I was wondering how it would work when there was no outgoing USB, so I re-read it again and noticed the

[INDENT=1]"If you are installing an Imp into a production arcade stick that already includes a built in USB cable, there are four holes labeled D-, D+, G, and V in the USB jack area, along with the colors of these wires in a standard USB cable. You can solder the end wires of your dedicated USB cable directly to these four holes"[/INDENT]

I think if you add another 4 rows in the wiring section to put something like “outgoing USB cable” it might make it clearer? (Just a suggestion, it’s pretty clear if you read both pages though :D)

That’s a good point Mr Caesar. I’ll see what I can do to get that info on the second page.

If using 360 pad pcb mode with impv2, do i have to splice the joystick directions along with all the buttons such as lp, mp, hp etc to my ps3 wiring? I ask this because i tried to switch modes, and the 360 reads it as controller found so i know it switches fine but the problem is nothing works as far as movements or button inputs. I did try hooking it up to my PC to test inputs and it only works in VX (ps3) mode, and not Fightpad (360) mode.

Yup.

This is good news, thanks. I just encountered this issue yesterday at a tournament, I’ll be sure to tell them there’s a firmware update coming soon that will enable S+S=G for PS3 mode.

Was already done in the 2.3 firmware for MC.

I couldn’t find any way I liked to add info to the second page. I highlighted the outgoing USB info on the first page in red, hope that helps.

Shows what I know. :stuck_out_tongue:

I’ll get it to him immediately, thanks!

Will the Imp v2 in a Hori VX SA + MC Cthulhu auto-detect correctly? TEs seem fine from the look of things…

As long as its a Cthulhu/MC it should work fine.

DISREGARD WHAT’S BELOW THE LINE, I think I’ve found the culprit.
I read a bit through the thread and saw someone mention that they couldn’t get proper functionality with a very long cable. I think I saw the same issue, when I replaced the 15ft HitBox USB cable with a 6ft one I had lying around, everything started working perfectly from the start. If I plugged that 6ft USB cable into a 2ft USB extension cable (which could well be a POS, I only use it to connect my USB keyboard to my PS3), I get the same “blinks, never stays on” problem. Same with plugging the HitBox cable into that 2ft cable.

I have a 10ft USB cable somewhere around here, if that works through the Imp I’ll recommend to my customer that he buy one of those and just deal with not having the extra 5 ft.

I guess I did have stuff shorted before, but it was probably after I hooked everything up (with the 15ft cable) and started redoing the wiring with the soldering iron I have, which was dying and has a crummy tip… going O/T here but I am probably gonna just bite the bullet soon and buy an expensive Weller or something.


Having a bit of an issue here. I am modding a production Hitbox stick for a customer, which has a Cthulhu+ with firmware on it that makes Up+Down=Up and Left+Right=Neutral.

I dual-modded it with a 360 MC Fightpad, and using each USB cable on its own, both 360 and PS3 worked fine.

I wired up an Imp V2 according to the Cthulhu+ directions, and I’m seeing the following behavior:
-Plugging it into a 360, the controller’s LEDs light up for a split second, then turn off. The controller never connects to the 360.
-Plugging it into my PC, the Hitbox Cthulhu+ shows up in my Game Controllers like normal. Everything seems to work as before. The 360 controller’s LEDs never turn on.

Quick help is appreciated, [S]as I was hoping to have this done before the weekend is over.[/S] edit: my customer is OK with giving me more time, and told me that if we really need, we can have 2 USB cables coming out of the Hitbox. I’d really like to solve this with the Imp though, and within the next day or two.

I’m going to solder the USB cable back to the 360 PCB and make sure that all works well on its own, as a way of further troubleshooting. Meanwhile, I did some testing by removing Solder Jumper 2 and moving the wire previously on Cthulhu+ Column F over to Guide/Home, but that still isn’t making the 360 PCB become active.

edit: after taking some time away from the project (this seriously helps and I need to just do it every time I hit a blocking point), I did some continutity testing and didn’t need to wire up the USB cable back to the 360 pad because of those results. Additionally… it looks like I shorted E and F together on the Cthulhu+ somehow :confused: probably due to surface soldering on the through holes or something (the Cthuhlu+ is fixed to the inside of a HitBox with a ton of glue so you can’t remove it or really poke wires into the through-holes).

Currently warming up my iron, I think I might’ve cracked this nut.

edit: well my primary soldering iron bit the dust. Used a spare to redo the wiring on the Cthulhu+, used my multimeter to check and nothing should be shorted, but it won’t connect to a 360 still. I tried holding down Guide, and also LKMPHP, and on the 360 the PCB will blink but not stay on.

I tried LKMPHK on my PC just now, and I think the 360 PCB is coming alive that way. My computer pops up a “Device Not Recognized” message, and it always gave that message before for the fightpad plugged in on its own. When I don’t hold down that combination, it pops up as a HitBox Edition Cthulhu+.

I’m sort of at the end of my rope for tonight. Everything looks like it’s connected properly (I even checked that I’m using the correct wires for the 360 pad’s D- and D+, and I am) but it’s not wanting to connect.

Help would be greatly appreciated.

First off, test on a PC first. There are two things you should be checking for testing; first is the game controller’s applet in the control panel. Either controller should show up listed there. You should also be looking in the device manager to see if any ‘unknown devices’ or any other weirdness shows up. Knowing any of the error messages that may pop up would be helpful as well.

The Hitbox Cthulhu should work fine using the Cthulhu+ wiring setup. I’d recommend you go back to that fully. I cannot think of any reason you would need to use the basic wiring setup. Put it back as described for the Cthulhu+ setup and double check your work, then test it on a PC to verify the Hitbox Cthulhu shows up as it should.

Once it’s showing up as a Hitbox again with the Cthulhu+ wiring, first thing to do is make sure you know the proper keys to force Xbox360 mode. It should be Short+Strong+Roundhouse (1K+2P+3K). If not, then it’s the Home button. Unplug the stick, hold down the keys, and plug it in. When you know which one of the two does NOT show up as the hitbox in the game controller’s panel, you’ve found the right combination. It’s a bit of a stickler, so do not hold down any keys except the ones specified.

If all works well, the madcatz pad should show up in the game controller’s applet. If not, it should pop up an error message and possibly show an unknown device in device manager. Test it out and report what you find.

Yeah, when I wired it back up to the Cthulhu+ setup and used the 6 foot cable, everything works as you said above. I guess between the long cable (voltage drop) and the fact that 3 PCBs (Cthulhu+, FightPad, ImpV2) are getting powered by a single USB port on the 360, there’s not enough juice to power the setup reliably.

If I could find a 10 ft cable (mine has disappeared) and confirm that it works with the above setup, my customer and I could call it good. I guess we two will figure that out on our own, my best idea is to buy a 10’ USB cable with a thicker-than-normal wire gauge and see if that works, but if it doesn’t we’re back to square one.

Toodles, thanks for replying btw. I know you’re really busy around here and I even saw you giving your $.02 on N-G.com, just know that when I am posing questions to “the community” I don’t outright expect any replies, much less from a guy like you who’s done enough as it is, so it really is awesome that you yourself are helpful to so many people like this.

Heh, I’ll throw people who want to dual mod their PS3 Hitboxes your way, you mod 'em, make money and buy Imps, and we’re all happy. All breaks down if we can’t get it to work :slight_smile:

Hey Dan, and Toodles. I am having this exact same problem. The MCC works fine, boots up on pc with no problems, but the plugging into pc in xbox mode brings up unknown device, (the fightpad showed up as Madcatz fightpad origiinaly) as the pad will blink once (occasionally twice) and then go dead. Like i said, all buttons have been tested on MCC mode through the pc, and it works flawless…my cable however is only 7’…and im at wits end on what to do.

any help would be appreciated.

Hey Toodles,
After reading through the welcome sheet carefully I think I have an idea how the Imp works. But before I made my order I like to confirm something.

  1. If I use the Guide/Home button as my system selection will the Home/Guide function still works on PS3/Xbox?
  2. And all I have to do for auto detection is hold down the Home/Guide button while plugging in the usb cable?
  3. What happen if I or some idiot forget to press the guide button while plugging in the USB cable on a non default console?
  4. Your products are too godlike!

So the switching works, the MC works…I dont know what to tell you except to check and recheck the USB wires between the 360 board and the Imp.

  1. Yes. Just remember to follow the ‘Basic’ column, and not the ‘Basic SSG’ column, if you have a real dedicated Home button. Follow the ‘Basic SSG’ column only if you do not have a dedicated Home button and need to have Start+Select activate Home.
  2. There is no autodetection unless its used with a Cthulhu, following the ‘MC Cthulhu’ column or the ‘Cthulhu+’ column. Using the ‘Basic’ or ‘Basic SSG’, the Imp will remember if you’re in PS3 or Xbox360 mode, and stay there. Unplug and replug as much as you like, and it’ll stay in that mode. You only want to hold down the button if you want to switch the modes; if the stick is in PS3 mode and you want to play on an Xbox360, hold Home when plugging in and it’ll switch over to Xbox360. Plug and replug as much as you like, and it’ll stay in Xbox360 mode, untill you plug it in with Home held down again. That’ll switch it to PS3 mode, and stay in PS3 mode until you plug it in with Home held down again, etc.
  3. Nothing bad or damaging if that’s what you’re worried about. The stick wont work of course, and you’ll likely see a ‘invalid device plugged in’ type of message, but just replug with Home held and you’re fine.
  1. Yeah I understand the part about using just Guide and not SSG. Now on your V2 I notice the lay out a bit different than the old one. I was reading the welcome sheet for the older Imp lol and for some reason I can’t open the V2 pdf is it down?
  2. Understood. I thought I have to hold down guide every single time I plug it in something lol.
  3. Great I don’t want to have any “oops” and fry my stick because someone plugs it in the wrong system. 3 ImpV2 order coming soon =D