TE 360 stick Dissconnect problems

Ok so I’m starting this thead so that hopfully some one out there has the anwer to this problem so that i and others can that might have the same thing canget it sovled :). I have searched the net and found nothing of this:

TE SF4 Stick disconnects from the 360 when the stick is in the upright or left position. And only when the lever is pulled from the up to upleft or upright if the lever is moves from left to leftup it works. and everything else works fine o.O so its a bit strange!

If eny one knows like is it the PCB can i change it to get it to work?
Or is it a conecctiont problemfrom the stick to the pcb?

Heres a link to a youtube vidoe where i show the problem.

[media=youtube]u8U7IplXfh0[/media]

Open up the stick, and take pictures of the inside…

Have you done any modding? The stick ‘disconnects’ if you short power to ground, and the case is metal, so it could be happening elsewhere in the stick.

Does the problem happen if you disconnect the stick (simple plug) and move it around?

have you tried swapping the micro switch board on the joystick?

I got the Stick from used and new on amazon so i fear somone else has done somthing on it but all things inside are still glued so most things most be untuched. (and no I havent done eny modding) And no i havent tried to change the switch board(I have no spare parts atm) you think i would work?

[media=youtube]4dUNla77sKw[/media]

the Images were to big fix them soon.

[quote=“nomet, post:4, topic:98179”]

I got the Stick from used and new on amazon so i fear somone else has done somthing on it but all things inside are still glued so most things most be untuched. (and no I havent done eny modding) And no i havent tried to change the switch board(I have no spare parts atm) you think i would work?

[quote]

Thanks for the video. It does look original inside.

I strongly doubt it’s the joystick switch board, shorting it would just cause direction input. Even connecting it to the case shouldn’t do anything since that should either be floating or grounded. Basically, there’s got to be a problem with the power cable, the board board the power cable attaches to or the area where the home button or the cable between that is in order to have the symptoms that you’ve got.

I’d be inclined to try making sure the power cable and the cables to the ‘home’ area are all well clear of the stick when I put it back (or even try to replicate the problem with the faceplate detached, but the controller on) and seeing if either of those affect the problem.

Thanks for the quick answers!

I havent had a stick before but i’m some what experienced in fixing stuff and finding errors :stuck_out_tongue: . And i should prob have told you that ive tried to use the stick when it is off the box and the results are the same… so its not tuching enything(it was my first test). other test I could make to secure what part I eventelly replace or fix?

I will post if i can find enything else out! :slight_smile:

Thanks for the video. It does look original inside.

I strongly doubt it’s the joystick switch board, shorting it would just cause direction input. Even connecting it to the case shouldn’t do anything since that should either be floating or grounded. Basically, there’s got to be a problem with the power cable, the board board the power cable attaches to or the area where the home button or the cable between that is in order to have the symptoms that you’ve got.

I’d be inclined to try making sure the power cable and the cables to the ‘home’ area are all well clear of the stick when I put it back (or even try to replicate the problem with the faceplate detached, but the controller on) and seeing if either of those affect the problem.

[media=youtube]vOiaZSIK6Xw[/media]

I also tried to disconnect the dashboard with no results.

I’m going to start pointing my finger at the chip.

The pcb chip or the Stick ship?

Something bad in the logic - might be as simple as a bad component somewhere, but I’m out of ideas.

So dose eny one have a tip for where one can find a similer pcb component?

Does Madcatz cover used items?

Besides another stick or a pad, no. Where are you, geographically speaking?

I have the same problem, just disconnects at certain angles when going up-left or up-right.

This seams to be a pcb problem I’m talking to a madcatz tech about it and going to try fixing it! If I found out the problem I will post the answer here!

CHeers!


poblem solved

Ok For all you out there wondering how it went i found the problem! it was the stick that was broken i tried using my friends stick and it works fine so prob the card for the stick is broken. So if any other people have the same problem this could be the case!

Cheers!