TE Button issue (SOLVED)


#1

Hi. A couple weeks ago my TE round 2 took a solid smash to the ground (large enough to snap the cord door in 3 pieces). I reassembled the sides that fell off, and it was pretty much good as new again. Problem being a button didn’t work (square). I have tried replacing the wires/QDs holding onto the button and barrier strip, but that didn’t solve the problem. I posted on the absolute newbie thread, and someone said to just solder a new wire onto the small circuit board under the home and turbo panel. I ran into a few problems along the way.

First problem being: I’m not an excellent solderer. Problem two: The place I need to solder is in the middle of the ribbon cable, which quite obviously is stuck together, and then glued down. Here’s where I need some help: Should I just solder a wire under the ribbon cable on square (the actual solder points themselves) directly to the button, or should I desolder the wire on the ribbon cable and replace it? I’ve done this on my mayflash once (it wasn’t a ribbon cable though), and it’s pretty easy. AFAIK you heat up the solder point and pull out the wire and shove a new one in, but on a ribbon cable this task proves to be difficult, and I would probably have to desolder the rest of the ribbon cable and then replace it after, which in my opinion is probably higher risk than just using the solder point (worried about frying the board).

Thanks for any input. If necessary I could go into further detail but it’s a royal pain in the ass getting a photo so that isn’t an option.

Connor


#2

If you look at the button terminal board, you see that its held down by 2 screws, unscrew them. Then left the whole button distribution terminal out of place.
**Underneath **the board you should see solder points for each button Signal and ground in large easy to solder points.

Leave the ribbon cables alone, unless your top notch with soldering you will ruin a ribbon cable.

Although this photo is showing a completely different mod. Here is an example of the button distribution terminal being removed from its place and wiring being soldered to it.


#3

So What you’re saying is just pop out the barrier strip and get a signal out of there? Also, would I need to put a new ground? Also Also, I’m assuming the problem is being caused by a damaged ribbon cable (although the tab on the strip for the button is loose as hell), how would this help?


#4

If you have a multimeter you can check the continuity on the ribbon cable before you assume that’s at fault. And also you can check if it has voltage at that button power side. The button is a ground switch so there should be a constant voltage on the power side of that barrier strip until you press the button to ground it.


#5

Did you try plugging in the cables to a different button first? I know that might sound too simple, but you didn’t mention it. I’m an advocate of trying the easy stuff before the difficult bits. :wink:
Just for 5 mins, plugging it in to r2 might save you a lot of trouble.


#6

Yeah I was going to suggest that.

If nothing works you do have two extra buttons that you could use in the mean time. Just no Square.


#7

Yes


#8

I always forget to do that thanks.


#9

As in, worth your

http://www.ourtravelexperiment.com/wp-content/uploads/2011/03/sriracha_550.jpeg

?


#10

Oh hey, forgot to post this 2 days ago, but fixed the problem thanks to Darksakul, I guess it was just a broken terminal.