TE FightStick headset woes


#1

Well I modded my TE fightstick with a Cthulhu and IMP and everything works excellent EXCEPT the xbox 360 headset. Apparently it transmits garbled noise as loud as my voice constantly.

I tried opening the stick back up and disconnected the MIC wire from the headset harness and the noise persisted (which leads me to believe that something is wrong on or after the madcatz board… sucks cause I didn’t test it before the mod (bought and modded the stick for TvC and got an xbox yesterday).

Anyone else have this issue or a magic solution I would be delighted to hear it.


#2

you have to give the 360 pcb power first, then the cthulu.

if 360 is your default will work


#3

I am a bit unclear of what you are saying.

I wired it up as seen here:

The Cthulhu gets power from the usb cable and the xbox board sees the voltage after the diode; so they should be seeing power at the same time. So I need to change the power routing?


#4

I usually have the VCC on the Imp board split to go to both boards than try to have the xbox 360 pcb get the voltage from the point on the Cthulhu.

Not sure if that will fix your mic problem though.


#5

Ive got an RJ45 cable that comes into the MC Cthulhu (except for the d+ and d- which go straight to the IMP. The power from the Cthulhu splits to the IMP and the madcatz board.

Thinking about it though I really don’t see how the power routing should have anything to do with the audio. I searched the forums for an hour or so and found a few instances of other people having the same issue but no responses.

I wouldn’t be against getting a wireless headset but I have read bad things about them and already have two wired headsets that work perfectly in my normal controllers.


#6

the guy who does wiring on my sticks dual modded sticks and had audio loss/static on the mic. he set mine up so xbox power was routed first and it works crystal clear. he fixed his own this way and it worked perfectly.

it’s power routing. i don’t know why it’s this way, but it is this way.

my imp setup is

360… RS switch = PS3.


#7

Damn… I tried changing the power routing to no avail.
I finally caved and got a wireless headset :bluu:

Thanks for the help regardless!