TE Home button panel not working (URGENT)


#1

Hi, earlier this week I posted a thread about one of my TE buttons not working (PS3 version btw). In order to fix it i had to pop out the little panel under my home/turbo/etc buttons. So I was just playing tekken, and ended up having to switch from dpad to left analog, so i go to do that, and the little lever goes all the way in. I opened up my TE and the circuit board looks fine, although when i reinsert the circuit board into its plastic casing, it looks perfectly fitting, but the lever remains jammed (although it’s just find on the board) and the home and turbo buttons not only don’t work, but press really far in. I can understand if noone can understand and if necessary i can get a picture, but from the looks of it the circuit board (in the casing) looks just fine. It’s an urgent problem because I’m going on vacation on sunday and don’t have much time.

Thanks,
Connor


#2

It really just sounds like it’s not going in all the way, pictures will be needed.


#3

Okay…well I was about to go take a picture but I guess I already packed up my camera…damn. Well anyway I found some glue stuck to one of the capacitors and peeled it off, that didn’t help, and both sides of the board are inside, and the board looks like it’s lying flat but there’s something pushing it up in the middle, because the switch for the dpad and sticks looks fine until the black case is on in which it’s like flat with the surface and doesn’t stick out.


#4

Did it by any chance not pop in all the way to the Turbo panel?


#5

Well I can’t tell that’s my issue. When I look at the big side (where the jlf harness goes) its flat against the plastic, and on both sides it is snapped in place fine, but there’s probably something sticking it up in the middle but I have no clue what.


#6

I recommend unscrewing the PCB from the plastic part that holds it, checking it out, and putting it back together. If it still doesn’t work, you could take some pictures. Definitely have to be careful with the PCB, by the way.


#7

Are the turbo LED’s flush with the panel?


#8

Tried tat, didn’t work. I’ll take pics when i get back to canada


#9

yes


#10

It really amazes me how it is this difficult. Here’s some pics. I apologize for the awful quality I’m no expert photographer.

First, some pics of the pcb and panel:

http://i857.photobucket.com/albums/ab133/drambit/DSCF3058.jpg

http://i857.photobucket.com/albums/ab133/drambit/DSCF3061.jpg

not a flat surface so the buttons are just falling out.

http://i857.photobucket.com/albums/ab133/drambit/DSCF3060.jpg

http://i857.photobucket.com/albums/ab133/drambit/DSCF3059.jpg

Now the pictures of the buttons being pressed and the top panel. Shitty picture i know, just note how the turbo button goes in too far and how the dp/ls/rs switcher is flush.

http://i857.photobucket.com/albums/ab133/drambit/DSCF3085.jpg

http://i857.photobucket.com/albums/ab133/drambit/DSCF3069.jpg

http://i857.photobucket.com/albums/ab133/drambit/DSCF3103.jpg


#11

Bump


#12

You know that there’s a small piece of plastic that’s supposed to be between the DP/LS/RS switch on the PCB and the top panel, right?


#13

ummm no.


#14

I put my TE back together and it turns out my home and turbo buttons worked all along i just didn’t figure it out, and i guess I’m missing a small piece of plastic which is no biggy. Thread over.