TE problem driving me CRAZY! Please help!


#1

I modded my TE stick to make it a lefty stick. Originally, I bought a panel with the buttons on the left and stick on the right from Art’s Hobbies, and it worked great, but I raged and broke it. I played the stick upside down for months, and then I was able to get another panel custom made.

After I got the stick set up for lefty again, a strange thing started to happen: when playing UMvC3, I would get X-factors at random. At first, I thought I was just hitting ABCS and not realizing it, after it happened about 5 times I realized something was wrong. The problem is intermittent–I cannot duplicate it at will. I have noticed that it happens when I am doing something that involves two attack buttons–I always use A and X for wavedashing, supers and such. I tried changing out those buttons with the wires, but the problem persists.

It seemed like it was only happening online, but after playing for a LONG time in training mode I finally got it to happen–twice. The first time I checked the input display and it showed LMHS, even though I know I only hit the A and X buttons. The letters LMHS weren’t stacked like they normally are when I activate X-factor in training mode, they were one after the other. The second time it only showed HL (stacked) in the input display.

I examined the PCB that all the button wires are connected to, as well as the other (main?) PCB, and as far as I could tell, there weren’t any crossed contacts or anything. I am out of ideas, and this is driving me absolutely nuts. Does anybody have any idea what could be the problem?


Well isn't this a fine kettle of fish?
#2

I think I have another joystick around here somewhere, so I was thinking to swap the sticks out. Just grasping at straws here.


#3

Swapping the joystick (assuming you mean the JLF or what have you and not the TE) isn’t likely to solve issues with the buttons.

I’m far from an expert but it definitely sounds like things are shorting out. Post some pictures and if that’s the case, someone will notice it.


#4

Yeah, I agree that swapping the JLF isn’t likely to solve the problem, I just don’t know what to try, and the X-factor usually happens when I am trying to do a super, which means that I am pressing buttons and moving the joystick at the same time.

If pictures will help, here they are:

http://img36.imageshack.us/img36/7121/buttonsyl.jpg

http://img515.imageshack.us/img515/5842/mainpcb2.jpg

http://img853.imageshack.us/img853/6907/mainpcb1.jpg

http://img580.imageshack.us/img580/4483/turbon.jpg


#5

Its unmodded, so it shouldn’t be a problem. Can you see if you have a button that hits all 3 at the same time that’s shorted?


#6

Exactly! The only modification I made is installing a new panel along with some rather garish cuts to the lower plastics so that the bottom of the joystick would have clearance on the right side. I haven’t touched any electronics, which is why this is making me so crazy!

I don’t have any additional buttons set. I tried disconnecting LB and RB entirely since I am not using them, but that didn’t help either.


#7

I don’t know why I didn’t think of it before, but now I’m thinking it could be the cord maybe? Could something be crossed inside it? From reading other threads, it seems that replacing USB cords is simpler than I would have thought. Oh, but I forgot, Xbox 360 cables have two pieces, so I if I wanted to do an exact replacement I could just use an old USB extension cable. Why do the cords have two pieces anyway?


#8

So, I got this thought to rearrange the buttons–since I’ve been saying that X-factor usually happens when I’m pressing A+X, why don’t I switch it so when I’m doing a super I’m pressing A+Y? And before this last panel change, the buttons were in a totally different configuration. I don’t remember exactly what, but it was different. So I swapped the X and Y button positions, and then changed my controller settings in UMvC3. I played for more than an hour with no unwanted X-factor! So maybe my TE-S had this problem all along and I hadn’t noticed it because I wasn’t hitting that A+X combination very often. Now I guess I’d be hitting it to collect evidence as PW, nothing else comes to mind at the moment.


#9

You sure all your buttons are in good working condition? When a switch wears out it can do some pretty random stuff. All the wiring in your stick looks completely stock so I’m guessing you need new buttons.


#10

While playing this afternoon I got another random X-factor. I only got one in at least 1 and a half hours of play, which was better than before, but still frustrating. So…replace all the buttons? Yeah, I could try that. I just happen to have some Sanwa buttons lying around…