TE Repair Help


#1

Hello stick specialists.

The Issue: “B” button(AKA Medium Kick) works when it feels like it.

I’ve called madcatz several times and I get the same standard answers but nothing is working. I’ve even sent it in too them for it too be repaired despite the expensive shipping and long wait time. I will say that it worked like a dream for a week or two but the problem resurfaced.

Things I’ve Tried: [LIST]
[]Unplugging and plug back in the controller
[
] Switching the break away cable
[] Switching the buttons
[
] Unplugging and replugging the cables to the quick disconnects
[]Connecting the cables to different buttons
[
] Hammerfisting the bottom of it (makes it work 4 a few minutes)
[/LIST]
I thought it was a pcb issue, but the tech support guy said that if it was the button would never work. This isn’t heartbreaking since I have a modded SE. It’s disappointing since I paid good money and have exhausted a lot of options. Any help/input would be appreciated.

Side note: It’s strange since most say the SE is the one to stay away from. I’ve double hammerfisted my SE in rage countless times and dropped it on prupose and only had 1 problem that only required a button swap to fix.


#2

Does hammerfisting consistently help?


#3

That’s…what…she…said…


#4

Round 1 TE Sticks are having problems to my knowledge, Just buy a new ‘‘b’’ button it’s only 2 something dollars for a new sanwa button.


#5

Not gonna lie, the advice you give in threads is pretty fucking horrid.


#6

I’ve done that already.

And I can pretty much count on it working for at least a fight after a good whack.


#7

So did Madcatz say what they fixed with your stick?

I’m confused by what the tech support fellow said…weren’t there numerous cases of PCB failure causing buttons to not work? Or was that because of faulty wiring?

If it isn’t the button then it has to be wiring or PCB so you should try the multimeter test and check solder points or just call madcatz and make them send you a new PCB.


#8

I do a pcb multimeter check like mentioned above. If that is the general problem then I wouldn’t see why they wont just replace the stick entirely. But if they aren’t doing anything to help you. I would just gut the thing then mod it myself. Which in terms takes time & money, but i’m sure you’ll find a way around.


#9

I’m going to try switching a different cable from one of my unused buttons. If that doesn’t work then it mucst be the PCB