TE "S" SSFIV Stick Problem in Toronto


#1

Hey guys, I just picked up Marvel vs Capcom 3 this morning and decided to use this stick to play it. I’ve had it ever since SSFIV came out and it worked fine. I went to play it again just now and moved the stick to the right. The character did not move at all when I was doing this. I tried moving the stick to the right at the home screen on my PS3 and sometimes it wouldn’t work and sometimes it would. The stick would let me move right on the character select screen in MvC3 but doesn’t let me move the character to the right during a match. Is this a serious problem and is there any way troubleshoot it?

If not, do you guys know somewhere in Toronto, Canada where I can check it and get it repaired?

Thanks.


#2

First question is have you opened up your stick at all yet?
Second question is is it only the stick that is having problems or are the buttons also funky?

Test these out on PC and see what happens first.


#3
  1. Haven’t opened the stick up yet.

2)I tested it again, and all directions but the right direction work fine. The buttons work fine. The right direction works fine but if I dash by tapping the stick to the right twice, walking right won’t work after that. Dashing by holding the two attack buttons and right still works but I cannot walk forward.


#4

now there can be three things wrong here

1 the pcb is dead when it comes to directions (not likely but possible)
2 the microswitches are dead inside the joystick (more likely possible than 1)
3 the wire harness between the joystick and the pcb is faulty.

if its option 1 then you’re gonna have to replace the PCB
if its option 2 then you’re just going to have to replace the TP MA assembly inside the JLF

To test whether its option 1 or option 2, plug your stick into your PC and take one wire and touch it to any ground point on your PCB. Take the other end of your wire and touch it to the directional points on your pcb. Test all directions and see if there is a response from your computer. If there is a response from all the directions, then you can interpret one of two things which is option 2 and option 3. At this point, have your ground wire ready and touch it to the solder points on the JLF pcb assembly. If you register directions there, then it is your microswitch assembly that is faulty. If that is the case then you can order one from lizardlick. However if it is your pcb, then you have to order yourself a new controller board like the Cthulhu.


#5

Thanks for the information. I’ll try it out when I have less assignments and exams to worry about and I will get back to you. Also, although I don’t use it, I tested the Turbo function and it does not light up anymore.


#6

if it does need to be fixed there are people who can help u out at Hero’s World. located in the plaza at Highway 7 & Warden.


#7

lol I go there you know…


#8

Thanks for letting me know phan_X. Will definitely head there when I’m free.