TE stick continuously 'firing' down signal, help please


#1

Sorry for creating another help thread, but I could not find anything related to my problem using search tool.

My recently purchased SF4 Round 2 PS3 TE Stick seems as if it’s continuously ‘pressing’ down. When I plug my stick into the PS3, the menu selection scrolls to the bottom. In the character select screen, it keeps looping through the characters, downward. I can’t input any other directions when this happens. I’ve tried opening up the stick and unplugging the cable which connects the PCB to the joystick, and it still exhibits the problem. I suspect there’s something wrong with the main PCB. Could someone give me tips on what they would do to diagnose the problem?

Only the directions are affected, all the other buttons work fine. My joystick is in the default position, when this happens. Thanks.


#2

Wait, so you’re saying that it constantly registers down even with the harness unplugged from the stick? If that’s the case then it very likely IS the PCB, and down is obviously grounded somehow.


#3

Yes, that’s what I’m thinking also, but I don’t see anything from looking at the solder points. Do you know any other points on the board that could cause this?


#4

it could be
a) microswitch
b) JLF PCB
c) TE PCB

Try to see on the TE PCB if there is a solder bridge by the main chip (that giant black thing) or see if there are solder bridges by the pins where its connected to.

If its recently purchased, try to get that warranty


#5

I don’t know what is the trick with the Madcatz, but as for Logitech, just hold down R1+R2+L1+L2 and then plug in the stick into USB. This will reset the pad positions and all will be fine. Worked for me a couple of times.
If you are unsure what are those buttons, just hold all 8 buttons and plug in the USB - then wait 2-3 sec and release the buttons.