TE Stick not working on the 360?


#1

I just got a 360 and I’m unable to get it to work on my 360. It just powers on for about a second and shut off. I’ve tried it in the PC and PS3 and it works perfectly fine. Any ideas on what to do?


#2

Get a Xbox-360 TE stick?


#3

It is Xbox.


#4

Hmm…


#5

It’s modded…


#6

Since it works on PS3 I guess you or someone else have dual modded the stick? Sine it works on PS3 the problem should be with the 360 pcb or the connections to it I guess. That would make sense to me at least. Open it up and try to locate where it has gone wrong.


#7

Yeah, someone modded it for me.


#8

I’m not sure if I can help unfortunately, since I’m not very knowledgeable about this kind of stuff. But I think details about how it is modded or pictures of the wiring inside would increase the odds that someone will be able to help you.

EDIT:
Or I guess you could always contact whoever modded the stick for you and ask him/her about it.


#9

its could be any but sounds like bad wiring…Post pictures of the inside so we can look at the wiring and also take a multimeter and test the connection


#10

If it was a imp ver1 dual mod, depending on how it was wired, you might have to hold guide/home on plug in or maybe the slider switch must be set to RS on plugin. Holding down turbo or back on plugin is another possibility, or holding the stick to the right.


#11

I wouldn’t think it would be the slider switch for random causes of power disconnection.


#12

I’ve modded a 360 TE stick to with an imp Version 1 to where if it was set to RS on plug in, it would work on Xbox 360, then once it detects, you put it back to DP. I’ve done it twice actually. The newer imp v2 and ChImp SMD and newest dual strike auto dectection has made this obsolete, but a lot of older sticks where wired like this.


#13

Ahh ok, I didn’t know that. I never worked with the first one only the imp v2. Thanks for the insight on that rtdzign.


#14

The guy said it worked in his machine before he gave it to me (last year). He said I should hold home, or start when I plug it in. Tried both, neither worked. Haven’t heard anything else from him.

http://img834.imageshack.us/img834/4720/dscf5229u.jpg

http://img809.imageshack.us/img809/858/dscf5230.jpg

http://img834.imageshack.us/img834/7795/dscf5231r.jpg

http://img828.imageshack.us/img828/9947/dscf5232.jpg


#15

It appears to be a dual strike board. I believe you must hold the joystick to the right on plugin. I am unsure it this is true, but the dual strike might have problems with L2, and R2 in Umvc3.


#16

So I just turn the Xbox on, plug in the stick and then push the stick to the right? Also L2 and R2 problems? :frowning: Oh no, I was thinking about jumping onto UMvC3 soon, since I have a stick and I only use it for SF.


#17

you should press/hold before you plug the usb in.
also, i usually watch the rings on the 360. i try to wait until a new spot lights up when i plug my stick in.


#18

So far I’ve tried holding home/start/joystick to the right, for at least 10 seconds, and holding before plugging it in. Nothing. It flashes for a second and goes off.

Edit: After holding MK before plugin about 15 times in a row, I managed to get it to work. Thanks for the help guys.


#19

Not sure what version of dualstrike that it is, You might want see if a firmware upgrade is possible.