TE stick problem.


#1

Alright. So I ordered the BlazBlue limited edition TE stick from Amazon. I just received it. Popped it on the PS3 and everything was fine and dandy, but my stick couldn’t read movements in the right direction. I popped open the TE, and started clicking the stick’s Micro Switches, and it seems like there might be a short in the micro switch that moves right is there anyway to fix this problem, or do I have to go through the trouble of sending it back?

So it seems like the problem lies within the micro switch itself rather than input settings


#2

Check that the top switch on the Turbo Panel is set to DP and the lower switch is set to ‘unlock’.

If the problem persists, open it up and turn the joystick loom plug upside down.

If still failing to operate correctly, return that disgrace back to the store you got it from and ponder why it was given to you in that condition. Replacing the relevant parts yourself at your cost should not be your responsibility.


#3

The sad thing is that most likeley, shipping it back at cost might be more expensive than fixing it yourself. Most likeley it is a problem with the joystick connector not seating well.

If it is a Microswitch Problem this will likeley fix it.
Sanwa TP-MA PCB Assembly

If it is a harness problem this will fix it.
JLF-TE Harness for MadCatz FightSticks

Either way, I agree, it is not acceptable that you receive a new stick in non working condition.

If I had to guess the second pin from the top is not mating correctly with the wireharness and you might want to carefully and slightly bend the pin with needle nose pliers.


#4

Is my wiring supposed to look like that, on the Sanwa side? because my wires are not the same colors as those. they’re all black (the pin wires for the JLF)

I tried swapping the plug upside down, and only down and diagnoal down-left were being read. I guess I’ll just be ordering new parts, because I honestly don’t want to have to go through the trouble of sending it back and waiting for it to return ( I got 1day shipping on the thing because I didn’t wanna wait too long to use it.) would I beable to take the wire harness out of my Xbox’s T6 hori stick? from what I understand is that it’s a Sanwa stick, just uses different microswitches and obviously hori buttons.


#5

That’s because the madcatz harness is not an official JLF harness, and that’s why it has problems. The wires are all black, but there might be some goop in the connector preventing a good connection, or it just might not be on all the way. Your pins are the top left corner version. If you can make a good connection between the harness and the pins, it should work fine if it’s a connector problem. Like rtdzign said, that second pin down might be having a problem (because if you look at the guide, the second pin down is the green wire, which is the right direction). If it’s a connector problem, then the lizardlick connector is a much better fit to the JLF. Just unplug the stock connector and plug in the new one (to both the PCB and joystick).

If it’s a microswitch problem, then you’ll have to get a TP-MA PCB, and replace yours. About the only way to tell is after you try all you can to get a good connector connection is that it still doesn’t work, then replace the TP-MA.


#6

If you have a stick which uses an official JLF wiring harness, change them out and test what happens. If it works, it’s either goop blocking the connection, or a bad wire. If that doesnt work and you get the same effect, like Nerrage said, it’s probably the microswitch itself.


#7

If the stick is defective, then can’t you tell the company you purchased it from to refund your shipping costs both ways?

The problem with trying to repair it yourself is that you have no idea what the problem is. Could be a simple microswitch replacement, harness fix, or it could be a permanent motherboard fault. And I don’t like the thought of you buying random, expensive parts which don’t fix the problem.

rtdzign’s suggestion of checking the harness pins should be your next step, regardless. Strange that only one direction input should not be reading properly…


#8

Just opened up my Xbox T6 stick, and the wire harness on that isn’t even compatible. QQ. This bites. Everything on the stick is 100%, but that doesn’t mean anything if I can’t do DPs and hadoukens facing right.

I can certainly do that. I left a review on Amazon’s page saying that it where it was defective at, but it’s excellent everywhere else.

As far as buying extra parts go, I don’t mind it actually, I was planning on changing out the stick for perhaps a longer one regardless if my current one is working or not.

As far as only one direction being messed up, I don’t know much about this stuff, so I can’t say if it can be common or not, but the problem may lie within the wiring, the pin, or just plain the micro switch. There was a lot of “goop” in the connectors when I opened it up, and I had to pull some of it off in order to detach the wiring from the main motherboard. I honestly think the large amounts of glue they used might be a major part of the problem.

Update: I don’t know what I did, but the stick seems to be playable at this point. but there are still random misfires coming from the right direction, but I can now throw supers and ultras while facing right. I’ll definitely be getting replacement wires and a new assembly

Update 2: No more misfires. looks like the switch needed to be “broken in”