TE2+ owners?


Anyone having problems with it so far?

I just received my te2+ from amazon today and some of the buttons already stopped working out of nowhere. The connections look fine, could it be the wires are already worn out? From the looks of it, it seems the wires wore out from the way the wires are tied together causing too much stress on them.


So I just unplugged the wires from the pcb and plugged it back in. Now everything seems to work fine for now should I still return it just incase? It’s a pretty Damn responsive stick like everyone is saying, not sure if I should risk keeping it. As I can just return it and buy the universal Brooks pcb and mod my old hori stick for much cheaper.


Yep i would definitely send it back and order a brook pcb for your hori. If you only need ps4/pc and know how to solder you could be save yourself alot of money by going with their ps3/4 board for 40$


Nah I’d keep it. The TE2+ is awesome and it sounds like it may have just gotten rumpled around in shipping or something. Keep it, mod it, enjoy it.


Faulty PCB issues strike again


Wonder how many that is now… there’s been a few threads recently that I’ve read the TE2+ having a dodgy pcb…


This is really getting out of hand, the faulty PCB issues at least… Yea just mod that Hori stick if it’s an HRAP stick.


What’s with the faulty PCB’s? Bad soldering jobs?


Yes I have 2 old hrap sticks. 1 is the old ps2 tekken 5 Stick for ps2 and the other is an HRAP3SA for ps3.

As of right now, the stick is working just fine. My guess is that the connections just get loose from opening and closing it or just gets loose during shipping.

And everyone knows how shipping goes, people just toss things around in order to get their work done fast.

I’m deciding to keep it and see how long it will last. If any problems start to suffice u bet your ass this will be the first and last stick I ever buy from madcatz, and I will let everyone know if it ends up breaking. Because my hori sticks have been working for well over 5 years without any problems.

My plan is to do a ds4 mod with the tekken 5 stick. Brooks universal with my hrap3sa in the future, which currently is using a seimitsu ls-56 specifically used for games like KOF and the madcatz stick for sf.


It depends on what you mean by “connections getting loose”. If its just connectors from buttons etc to the pcb getting loose it should be as simple as checking connections with a multimeter and replugging or fixing said connectors. However that doesnt seem to be the case in most of these reported issues. Offcourse itcould be bad soldering on the pcb itself but thats pretty nasty for the average user to try to fix himself imo.


Thought this would be the most appropriate place to post this. From my post on reddit:

So before, I advised folks to add a resistor from VCC to the button in question in order to pull up the signal. This will work for the signals in question that are not part of the aux panel, and if you decide to keep the stick stock, this is OK for the aux panel as well. For the problematic signals that are on the aux panel, such as lock, ps3/4, R3/L3, etc., I have found the issue carries over when remodding and utilizing the signals with an EZ Mod from Jasen’s Customs, and possibly with a @Gummo EZPZ mod, and possibly even with whatever PCB you incorporate that may use those signals without a helper board.

I was able to fix this issue today in a TE2+ that was remodded with a Jasen EZ Mod by reflowing the signal (R3) from the button itself, the pin that carries the signal to the main PCB, and the associated resistors inline with said signal. I was able to troubleshoot this by disconnecting the J4 harness from the EZ Mod (the 4 pin cable that carries TPKey, L3, R3 and GND) from the UFB to make sure it wasn’t the UFB. Originally I thought there was a bridge between R3 and GND but I was wrong. I then traced it back to the EZ Mod and then determined it was caused by the aux panel (with help from @“Jasen Hicks” himself).

I then removed the turbo panel, and while it was plugged in to my laptop (try at your own risk), I heated up the components I mentioned earlier until button 12, which is the offending R3 signal) went dark. After many attempts, since R3 would stay lit after pressing it again, I was able to successfully reflow the signal and it was no longer showing as held down, and operated the way it should.



can you give the link to the reddit thread?



Hey I came across this post when googling my own issue. I’m a laymen but I believe we had a similar issue except my ‘phantom’ button is button 7. The stick registers button 7 as active even when it’s unplugged. It looks like this in windows controller.


Any thoughts/suggestions? Thanks.


do what I said to do but do it on LT on the main PCB

use a multimeter to test all of the components from the button leading back to the chip and heat them up


The R3 button on my TE2+ wouldn’t deactivate. It worked fine when I first got the stick, I checked all the buttons on my pc but I haven’t played on it for a couple months. Tried to play some games the other day and noticed the issue. Sending it in to madcatz

TE2+ Fault Query Work in PS4 OS stops working in game

Or you could do what I mentioned above… lol


I wouldn’t send it back to MC


I would of if the stick was out of warranty but I was still covered and I’m in Cali so the shipping wasn’t too bad. I will be doing this fix if it ever goes bad again


I was able to create a pull up resistor for my te2+. In my case it was the square button signal that was the culprit.