The official Cthulhu and ChImp thread - Try our new Dreamcast flavor!

It be on godlikecontrolls.com

Thanks

unfortanally not…maybe I dont find it

Opps I forget the links are kind of hidden, this is copy and pasted from page 1 of this thread.

MC Cthulhu newest firmware: http://www.godlikecontrols.com/download/cthulhu/MCCthulhu23.zip

MC Cthulhu Variations firmwares: http://www.godlikecontrols.com/download/cthulhu/MC_Variations.zip

As of right now v 2.3 is the newest firmware.

For the MC Cthulhu they are part if the flash update, the 10 ms file is only if you have stability issues with the 1ms version.
It is detailed in the read me txt file.

Slightly off topic but I say it just for everyones benefit
Keep in mind the PS3/PC version of the board is not reflashable, only the MC Cthlhu version.
You will need the MC Cthulhu Upgrade Kit $12 to upgrade a Cthulhu to a MC Cthulhu

edit, ignore

Would there be any way to wire the cable from a Dreamcast controller to the PCB?

So I was looking on Focus Attack for a new PCB and found this:

http://www.focusattack.com/toodles-cthulhu-multi-console-pcb/

In the description, it says it supports Smash Bros with a special mode. I can’t find any information on this mode, though. Any one know what exactly “Smash mode” is? What does it do the the controls that is so different from normal controls?

I have the MC Toodles in a HRAP3 that has worked perfectly fine for a few years up until a few weeks ago. Suddenly when firing up 3s OE (PS3) it had long delay when moving the stick up, up back and up left. I thought the stick was broken and replaced it with a new Sanwa JLF and now it only responds to moving it up (only tried this on the PC through FightCade).

Anyone recognize this? Or do I simply have to buy a new PCB?

Where to buy it in europe?

I believe it was referring to Wii’s support for games that allow game cube controller support.

No, it’s referring to alternate controls on the cthulhu for how it handles inputs on gamecube

Smallcab.net for instance. You can even buy some ready-made RJ45 console cables (not Neutrik though)

So I went ahead and bought the PCB just to try the smash mode out. It works to some degree, but it has a some problems. I’ve tried sending an email to Marcus, but with no response. Does anyone have another way of getting in contact with him other than "marcus@marcuspost.com"?

twitter @toodlesSRK

Okay, here’s an odd issue. I’m going to ask on the Absolute Question and Answer thread and the official Cthulhu thread.

This is a rather odd one. I thought I’d seen it all. With the 1ms firmware, when I have my Cthulhu powered stick plugged into my computer, my PC won’t boot. It hangs at the BIOS screen. With the 10ms firmware, there is no issue, but I’d rather use the 1ms firmware.

If I plug it in after booting, it works flawlessly on everything. I just can’t turn the PC on with the damn thing plugged in.

happened to me too, must be a motherboard thing
change your boot devices

hey guys where can i grab the latest firmware for this PCB. im had it in storage for awhile and have a good use for it… couldnt find it on toodles site.

First page of this thread? Unless there’s newer FW’s than that.

i’m having a problem with my PS3/PC Cthulhu v1.4 accessing HOME while pressing start+select on PS3. it doesn’t seem to work. anyone experience this?

Probably accidentally disabled it, try plugging into the ps3 with start+2k+3k held down.