The official Cthulhu and ChImp thread - Try our new Dreamcast flavor!

Does it work on 360 though? and those 2 VCC slots are the same thing doesn’t matter which one you use. Check your wirings and soldering. make sure nothing is lose or bridged. Post up some picture if you can.

Toodles, any chance of you adding a force ps3/pc button combination to your chimp? Sometimes I need to test ps3 and chimps think that my PC is a XBOX360. It would be great to be able to bypass your autodetection. Perhaps the inversion of force 360 mode (1P+2K+3P) or something?

It doesnt work on the 360 anymore. i dont get a player indicator light anymore. I’ve redone the wiring about five times now, but i’ll do it again and post a pic

Rewired again and still not working on 360. Led shows green on the pcb, but no player indicator light.Here’s the pic.
http://www.flickr.com/photos/68786973@N06/6254220376

Also when setting it the 360 mode on pc, it get usb device not recognized

Hey Toodles what up, do you know when the MC Cthulhu is gonna be in stock again?

Any chance of add 360 support?

just order straight from Toodles paypal account
http://www.godlikecontrols.com/order.html

Are you able to provide an eBay link for that? I’ve tried searching but to no avail, so unless they’ve been called by another name…

Hey toodles, was there ever a solution made for customizing the USB names string for MCC firmware? I’d like to leave a present with this dual mod I did
<edit> Or rather, the tool that you linked to in The official Cthulhu and ChImp thread - Try our new Dreamcast flavor! is no longer active

Should be doable, yeah.

http://www.godlikecontrols.com/download/cthulhu/cthulhu_eepromwrite.zip

Once the green light goes on, the Chimp is entirely out of the picture. Either something got knocked loose between the chimp and 360 pcb, or the 360 pcb died. You can wire the 360 pcb directly to the outgoing cable to see if the 360 pcb is working or not.

Thanks for that last tip. I thought i was out of options I really hope the pcb didnt die. I haven’t even touched it all weekend. Its only three months old. Gonna test it now.

Wired the 360 pcb to the outgoing cable and i’m still getting the same thing. Guide light turns on for one sec then goes off. If the 360 pcb is dead, why im i still able to used the buttons and joystick in ps3 mode? I have them wired solderlessy and they both connect to the 360 pcb via ribbon cable.

Thanks for the reupload Toodles, cygwin is recognizing the executable, but anytime I go to run it I get “No matching device found…” so I’m guessing that i’m not activating the correct mode? The instructions to hold right on the stick don’t seem to boot it to an alternative mode. MC Cthulhu using firmware 2.3.

Hi, I sent a message on lizard lick but now see that the MC upgrade chips will be available soon. I would like to see a dance pad mode for this product, what would have to be done to make this happen?

If the 360 board doesnt work when directly using the outgoing USB cable, it’s not going to work through a Chimp.

Plug the stick in with Right pressed, and then check the device in device manager. The PID for it should show as 0x101f, the PID the program is looking for. If that’s the case, then it’s likely a libusb setup problem in cygwin.

I’ll get MC Upgrade kits added to the godlikecontrols order page asap.
As it is, I dont know if the MC would be a good choice for a dance mat. I have no idea how the dance directions are sent over PS3, and the SOCD cleaning may prevent it from working properly via PS2.

If older DDR games are any indication, during gameplay, the Triangle-Square-X-Circle buttons also serve as Up-Left-Down-Right functions respectively, so SOCD shouldn’t be an issue there. In the menus, however, you’ll need the regular directions, though, and the face buttons serve their purpose as confirm/cancel.

Depending on the version of DDR, sometimes you NEED SOCD to work in the menus, on the d-pad inputs – holding both directions simultaneously gets you certain options. I think the console versions have an alternate way to get those menus, but many people building pads want to go for an arcade-style experience. If one can’t turn SOCD cleaning off, the Cthulhu isn’t the right choice for this purpose. It’d be a simple fix in firmware, though.

Wiring up a Mad Catz Fight Pad PCB + Imp v2 + MC Cthulhu for a dual mod and the Xbox 360 side of the project isn’t responding when plugged into a Xbox 360.
The Cthulhu responds when plugged into a PC or PS3.

I am starting to think I soldered up the Xbox 360’s USB wiring incorrectly.
Any ways here the pics of the wiring

http://i21.photobucket.com/albums/b261/darksakul/2011-10-19112009.jpg

http://i21.photobucket.com/albums/b261/darksakul/2011-10-19112042.jpg

http://i21.photobucket.com/albums/b261/darksakul/2011-10-19112024.jpg

http://i21.photobucket.com/albums/b261/darksakul/2011-10-19112032.jpg

For those who can’t see the RJ45 Vcol is soldered to the 3rd V point
XB Green is soldered to XD+ point on the imp and XB white (used black wire) is soldered to the XD- point.

The carry over of inputs on both boards work, both boards get power . But the Mad Catz PCB will not stay lit when plugged into a 360.

If you need more closer detailed photos, just ask. This was done quickly on a Cell phone Camera. I can retake pics later with a better camera.

Yes this dual-mod going into a project box where I am going to include a FG Widget converter.
Hence why no buttons are wired up.

USB from left to right
VCC -D +D Gnd SGnd

Okay, that is what I though. So I didn’t mis-wired anything on the Xbox 360 PCB side.
Note I used black wire on the Xbox 360’s Data - because I didn’t have white wire.

Did you update the MC Cthulhu firmware? If not, it needs this to recognise the IMPv2.

Son-of-va …

I guess I have to check that out later on …

I recently got this from Toodles too so I though it was updated.

[Edit]
Nope Gahrling, that didn’t work. The update works, the idea for the ifx didnt for the Xbox 360 side.

I have to later solder a USB directly to the Xbox 360 PCB again just to make sure that the PCB works.