The official Cthulhu and ChImp thread - Try our new Dreamcast flavor!

Smallcab.net for instance. You can even buy some ready-made RJ45 console cables (not Neutrik though)

So I went ahead and bought the PCB just to try the smash mode out. It works to some degree, but it has a some problems. I’ve tried sending an email to Marcus, but with no response. Does anyone have another way of getting in contact with him other than "marcus@marcuspost.com"?

twitter @toodlesSRK

Okay, here’s an odd issue. I’m going to ask on the Absolute Question and Answer thread and the official Cthulhu thread.

This is a rather odd one. I thought I’d seen it all. With the 1ms firmware, when I have my Cthulhu powered stick plugged into my computer, my PC won’t boot. It hangs at the BIOS screen. With the 10ms firmware, there is no issue, but I’d rather use the 1ms firmware.

If I plug it in after booting, it works flawlessly on everything. I just can’t turn the PC on with the damn thing plugged in.

happened to me too, must be a motherboard thing
change your boot devices

hey guys where can i grab the latest firmware for this PCB. im had it in storage for awhile and have a good use for it… couldnt find it on toodles site.

First page of this thread? Unless there’s newer FW’s than that.

i’m having a problem with my PS3/PC Cthulhu v1.4 accessing HOME while pressing start+select on PS3. it doesn’t seem to work. anyone experience this?

Probably accidentally disabled it, try plugging into the ps3 with start+2k+3k held down.

didn’t work for me :{
thanks anyways.

My friend has a xbox 360 stick with a cthulhu board installed (dual mod) and is trying to get his pc to recognize his stick as xbox360 instead of cthulhu ps3. He doesn’t have the a hard switch, its the auto-recognition type. I thought there was a button combination to hold to force it to boot as xbox360, but I’m not sure. Sorry if this is the wrong place to ask.

It depends on how is it dual modded. The Cthulhu it self doesn’t lend it self to dual-mods other than having alternate points for button inputs.
You need a switch of some sort, if your friend’s stick lacks a physical switch (a DPDT) switch then it uses a IMP board as it’s switch.
The original version of the IMP does not auto detect, and switching is taken care of holding a button in as you plug in the controller.
Typically its the Home/guide button, but this can be wired to almost any input.

To force 360 mode, hold LK MP HK when plugging in.

Has anyone else noticed a problem with MC Cthulhu on Soul Calibur 2 for OG Xbox? The MCC works just fine on other Xbox games, emulators, XBMC, etc… it’s only in SC2 that it does not work.

This is the 3rd time I’ve seen an issue with this, kitty and ps360+ not working for xbox SC2. I think it’s time to move on lol

Just curious what the actual issue is since I’ve not heard anything besides “doesn’t work”

No input recognized. I actually don’t think it recognizes the controller at all, but I’d have to go into versus mode (or something) with another controller and see if it kicks me out.

Hello,

I’ve been using the MC Cthulhu on my PC with no problems for years now… Recently, I upgraded my computer, changed my Motherboard, CPU, and had to reinstall my Windows 7.

Now when I plug my stick in, my computer doesn’t recognize it anymore and says it’s just an unidentified USB device. I’ve been scrounging around this thread and Internet for a while and can’t find the answers. I’m sorry I’m not resourceful enough to find it, but anyone who knows the solution, point me in the right direction? Thanks a ton guys!

are you dual modded? how long is your usb cord? have you tried a powered hub or a usb repeater?

Hi,

No I am not dual modded… I just use the one Cthulhu board as mentioned in the post; my USB cord is about 8 ft. long, and no I have not tried a hub or USB repeater.

Do you have a shorter cable that you could try?