The Official TE2, TE2+, TES+, PANTHERA EZ MOD Thread


#77

The flat ribbon cable (FFC) is for Touchpad. Watch the VLX version of the EZ MOD install, it talks about it.


#78

@“Jasen Hicks” Hey would you happen to have any spare TE2 button wiring harnesses for sale? Looking for an intact harness for the 8 buttons.


#79

Same. I can make my own harness if someone can tell me the specific part name/desk for the 16pin connector.

Any ideas?


#80

I don’t sell the harnesses, sorry. They are JST RA connectors.


#81

Positive news today :slight_smile: I finally have the TES+ EZ MOD all squared away and tested. Not a huge problem really since its a reimagining of the TE2+ EZ MOD (same essential setup inside the stick. Here’s the pictures in chronological order of the install:

I mounted everything to the bottom of the stick using sticky feet standoffs. Lots of metal down here, no desire to short anything out! Used right angle headers on the 20P section of the UFB for clearance purposes. USB cable that comes from MCZ is a pain and since you can’t get a replacement in without cutting the end, I created the little adapter board there and used a custom USB cable I created to connect it to the USB B connector on the Brook. I ended up replacing the MCZ cable because the blue coating on the D- wire sucks and is a pain to get off without hot tweezers.

https://scontent-lax3-1.xx.fbcdn.net/v/t1.0-9/15940424_2187154601510550_5297786541711995582_n.jpg?oh=9a21070d20ecb18e400e7f1ba96add90&oe=590F8943

Next, I bolted the base back onto the stick and pulled the wires up. You will notice I completely removed the top to make it easier to work and not damage the cables inside.

https://scontent-lax3-1.xx.fbcdn.net/v/t1.0-9/15965799_2187154604843883_604110661049784507_n.jpg?oh=7b565d95aa019a98f248118c0d292f8f&oe=58D6C3D7

Installed the EZ MOD board in the stock PCB location and connected everything up. Used the stock button board to connect to the 20P custom cable. so no need to rewire those :slight_smile:

https://scontent-lax3-1.xx.fbcdn.net/v/t1.0-9/15965501_2187154628177214_1732654276606630424_n.jpg?oh=819bbaa35c2dd37dc370fcc4a28f6dc9&oe=591E5FC8

Buttoned up with some Purple Fight Stick Jewelry and tested it on Windows 10. Works great!

https://scontent-lax3-1.xx.fbcdn.net/v/t1.0-9/15966059_2187154631510547_2516558710529207949_n.jpg?oh=8cefe27cd1d5aaf14800157fc4b6aa2f&oe=59147224


#82

How soon can we expect the TES+ Ezmod?


#83

Mid-Late February. Need to get things manufactured for anything retail ready.


#84

Hi Jasen,

I’m planning on installing the TE2+ EZmod but have an issue. My USB connector is broken so I’m looking for advice on what to replace it with. I’m thinking of a USB extender that I cut up. Will this work. I stripped all wires and bundled some of the shielding wire to make it a ground connection. See this image: https://m.flickr.com/#/photos/57018498@N00/31708674133/

The connector on the left is the standard one that came with the TE2+ and the one on the right is the USB extender I’m planning to use. What do you think?


#85

That should work fine. It wont be super elegant, but it will do the trick.


#86

Hello Jasen,
I got one of the TE2+ ez brook universal board mod packages from arcade shock and the screw terminals on the EZ board are faulty. No matter how tight I screw them, the wires for the USB connection constantly come out.

I was wondering if I am still able to use the USB port from the brook board to power the setup instead of the screw terminals on the EZ board.

If not, do you have any suggestions or should I contact arcade shock for a exchange?


#87

I think you are getting the wire in the wrong spot. It happens to me as well. If the little metal sheild isn’t fully “up” when the screws are loosened… the wires get above them and they come out.


#88

Hmmm ok I’ll try disconnecting everything and unmounting the board and try again.


#89

Beatrush,

I just got mine today as well. I noticed that it came with the USB connector screws all the way to the top. You need to loosen it so that the catch would lower. Once the catch is lowered, you can then insert your wires into the catch. Then you tighten it back up. I hope that helps.


#90

Hi Jasen,

I got my EZmod w/ Brook UFB today for the TE2+ and have installed it but am running into an issue. The controller auto detects and works fine on the PS3 and PS4 but I can’t get it to work on the Wii U, Xbox 360, or Xbox One. When I plug it in, the player indicator LEDs would light up for a brief second, at the same time, the DP LED stays lit. However, it just does not work on those systems. I’ve upgraded the firmware to 1.8 as well. Note that I am using a Mac. Here are pictures of my install:

Note: that there’s a blinking green LED in addition to the solid green LED.

Note: UFB LED is constantly on.

Also not sure what these cables are for, should they be used at all? If so, where?


#91

Those two extra cables connect between the tow unused connectors on the TE2+ EZ MOD and the Brook UFB. One is for future touchpad support (if they implement) and the other is the DP/RS/LS connector.

It sounds like the EZ MOD is working fine, but the Brook UFB is not. My board routes signals only and doesn’t touch the USB lines whatsoever. That blinking light on the EZ MOD is a “heartbeat” that shows the code is executing in the EZ MOD that handles all of the Player LEDs, etc. Things that need some sort of processing to work with the Brook basically. All inputs like start, home, select, DULR, and the P1-K4, are simply passed right to the Brook. So if its not autodetecting, its an issue I can’t fix.

Try using the USB output on the Brook UFB with a USB cable and see if the situation is the same.


#92

Hi Jasen,

I tried your suggestion and connected a USB cable straight to the Brook, but it does not make a difference. Still not detecting my XBox and Wii U.

Btw, the connector for the LS/DP/RS is too thick and doesn’t fit the Brook connector. I think I need a slimmer cable, like the one for the USB (J6-1).


#93

That connector on the Brook isn’t the correct one for the EZ MOD; it’s not what I include at least with the kits. That’s probably why it doesn’t fit. Did you get the board in an EZ MOD kit or did you buy it from somewhere other than ArcadeShock?

Other than that, I suspect there is something else wrong with the UFB. If it has been updated to the current FW; I’m at a loss as to why it’s not working with 360/wii u/One. @GOGO.Zippy - thoughts?


#94

Got it as a kit from ArcadeShock: https://arcadeshock.com/products/ez-mod-for-te2-plus-version-w-brook-ufb-soldered-headers-package. Where can I get a slimmer cable connector, like the one you include for the USB/J6-1 connection? Would Fry’s have something like that? I think that will fit the presoldered LS/DP/RS connector on the Brook.

Yeah. I updated to the latest firmware via my Mac. Basically:

  1. I downloaded the firmware (1.8),
  2. opened it,
  3. pressed PS and Share button while plugging in the controller (as instructed by firmware installation instructions)
  4. updated firmware
  5. clicked on “done”/“complete” button after the firmware updated
  6. unplugged the controller

Tried it across my systems and it only works on the playstations.


#95

Typically yes, though you just need something from Harwin via digikey thats 1x4 .100" connectors.


#96

One thing to try… the legs on the connector should face UP for the Stick Selector switch. Are the pins bent down a bit? It might just take a little manual manipulation to make it fit since Molex does make a “naked” version of the KK connector as well that mates with the cables included.