Torrent client screwing things up even when not downloading


#1

This problem came out of the blue today.
When I have a torrent client opened (utorrent and bitorrent), it lags my ustream/Justin.tv to hell. I know you’re going to tell me to stop downloading zoophiliac midget porn but thing is it slows up jtv and ustream (for every computer on the network) even when there are no torrents in it.
Anyone seen anything like this?
Someone suggested a port conflict but Utorrent seems to be configured to use 50191 and ustream and Jtv are on 1935.
Even if I close the client, the problem will right until I reset modem/router.
Anyone have any idea what could be causing this?


#2

Something is forcing the ports to stay open. My initial impression would be some sort of spyware or malware. Download Hijackthis, run a scan, and then post the log here, please.

HijackThis - Trend Micro USA


#3

here’s what I got:

log

Spoiler

Logfile of Trend Micro HijackThis v2.0.4
Scan saved at 10:01:08 PM, on 12/4/2010
Platform: Windows XP SP3 (WinNT 5.01.2600)
MSIE: Internet Explorer v8.00 (8.00.6001.18702)
Boot mode: Normal

Running processes:
D:\WINDOWS\System32\smss.exe
D:\WINDOWS\system32\winlogon.exe
D:\WINDOWS\system32\services.exe
D:\WINDOWS\system32\lsass.exe
D:\WINDOWS\system32\Ati2evxx.exe
D:\WINDOWS\system32\svchost.exe
D:\WINDOWS\System32\svchost.exe
D:\WINDOWS\system32\Ati2evxx.exe
D:\WINDOWS\system32\spoolsv.exe
D:\Program Files\Common Files\Apple\Mobile Device Support\AppleMobileDeviceService.exe
D:\Program Files\Bonjour\mDNSResponder.exe
D:\Program Files\Java\jre6\bin\jqs.exe
D:\WINDOWS\system32\svchost.exe
D:\Program Files\Linksys Wireless-G PCI Wireless Network Monitor\WLService.exe
D:\WINDOWS\Explorer.EXE
D:\Program Files\Sandio Tech\3D Input Device\S3dmcplsti.exe
D:\WINDOWS\RTHDCPL.EXE
D:\Program Files\Razer\Arctosa\razerhid.exe
D:\Program Files\ATI Technologies\ATI.ACE\Core-Static\MOM.exe
D:\Program Files\CyberLink\PowerDVD9\PDVD9Serv.exe
D:\WINDOWS\system32\wscntfy.exe
D:\Program Files\Cyberlink\Shared Files\brs.exe
D:\Program Files\Razer\Arctosa\razertra.exe
D:\Program Files\iTunes\iTunesHelper.exe
D:\Program Files\Common Files\Java\Java Update\jusched.exe
D:\Program Files\Windows Live\Messenger\msnmsgr.exe
D:\WINDOWS\system32\ctfmon.exe
D:\Program Files\DAEMON Tools Lite\DTLite.exe
D:\Program Files\Rainmeter\Rainmeter.exe
D:\Program Files\iPod\bin\iPodService.exe
D:\Program Files\ATI Technologies\ATI.ACE\Core-Static\ccc.exe
D:\Program Files\Linksys Wireless-G PCI Wireless Network Monitor\WMP54Gv4.exe
D:\Program Files\Windows Live\Contacts\wlcomm.exe
D:\Program Files\mIRC\mirc.exe
D:\Program Files\Opera\opera.exe
D:\WINDOWS\system32\msiexec.exe
D:\Program Files\Trend Micro\HiJackThis\HiJackThis.exe

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = DAEMON-Search.com :: STARTPAGE
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = MSN.com
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = Bing
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = Bing
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = MSN.com
R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyOverride = *.local
O2 - BHO: AcroIEHelperStub - {18DF081C-E8AD-4283-A596-FA578C2EBDC3} - D:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelperShim.dll
O2 - BHO: (no name) - {5C255C8A-E604-49b4-9D64-90988571CECB} - (no file)
O2 - BHO: Windows Live Sign-in Helper - {9030D464-4C02-4ABF-8ECC-5164760863C6} - D:\Program Files\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll
O2 - BHO: Java™ Plug-In 2 SSV Helper - {DBC80044-A445-435b-BC74-9C25C1C588A9} - D:\Program Files\Java\jre6\bin\jp2ssv.dll
O2 - BHO: JQSIEStartDetectorImpl - {E7E6F031-17CE-4C07-BC86-EABFE594F69C} - D:\Program Files\Java\jre6\lib\deploy\jqs\ie\jqs_plugin.dll
O3 - Toolbar: DAEMON Tools Toolbar - {32099AAC-C132-4136-9E9A-4E364A424E17} - D:\Program Files\DAEMON Tools Toolbar\DTToolbar.dll
O4 - HKLM…\Run: [S3DIDSTI] %ProgramFiles%\Sandio Tech\3D Input Device\S3dmcplsti.exe
O4 - HKLM…\Run: [RTHDCPL] RTHDCPL.EXE
O4 - HKLM…\Run: [Alcmtr] ALCMTR.EXE
O4 - HKLM…\Run: [StartCCC] “D:\Program Files\ATI Technologies\ATI.ACE\Core-Static\CLIStart.exe” MSRun
O4 - HKLM…\Run: [Arctosa] "D:\Program Files\Razer\Arctosa\razerhid.exe"
O4 - HKLM…\Run: [RemoteControl9] "D:\Program Files\CyberLink\PowerDVD9\PDVD9Serv.exe"
O4 - HKLM…\Run: [PDVD9LanguageShortcut] "D:\Program Files\CyberLink\PowerDVD9\Language\Language.exe"
O4 - HKLM…\Run: [BDRegion] D:\Program Files\Cyberlink\Shared Files\brs.exe
O4 - HKLM…\Run: [AdobeAAMUpdater-1.0] "D:\Program Files\Common Files\Adobe\OOBE\PDApp\UWA\UpdaterStartupUtility.exe"
O4 - HKLM…\Run: [SwitchBoard] D:\Program Files\Common Files\Adobe\SwitchBoard\SwitchBoard.exe
O4 - HKLM…\Run: [AdobeCS5ServiceManager] “D:\Program Files\Common Files\Adobe\CS5ServiceManager\CS5ServiceManager.exe” -launchedbylogin
O4 - HKLM…\Run: [QuickTime Task] “D:\Program Files\QuickTime\QTTask.exe” -atboottime
O4 - HKLM…\Run: [iTunesHelper] "D:\Program Files\iTunes\iTunesHelper.exe"
O4 - HKLM…\Run: [Adobe Reader Speed Launcher] "D:\Program Files\Adobe\Reader 9.0\Reader\Reader_sl.exe"
O4 - HKLM…\Run: [Adobe ARM] "D:\Program Files\Common Files\Adobe\ARM\1.0\AdobeARM.exe"
O4 - HKLM…\Run: [SunJavaUpdateSched] "D:\Program Files\Common Files\Java\Java Update\jusched.exe"
O4 - HKCU…\Run: [msnmsgr] “D:\Program Files\Windows Live\Messenger\msnmsgr.exe” /background
O4 - HKCU…\Run: [ctfmon.exe] D:\WINDOWS\system32\ctfmon.exe
O4 - HKCU…\Run: [ISUSPM] “D:\Program Files\Common Files\InstallShield\UpdateService\ISUSPM.exe” -scheduler
O4 - HKCU…\Run: [DAEMON Tools Lite] “D:\Program Files\DAEMON Tools Lite\DTLite.exe” -autorun
O4 - Global Startup: Rainmeter.lnk = D:\Program Files\Rainmeter\Rainmeter.exe
O8 - Extra context menu item: E&xport to Microsoft Excel - res://D:\PROGRA~1\MICROS~3\Office12\EXCEL.EXE/3000
O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - D:\PROGRA~1\MICROS~3\Office12\REFIEBAR.DLL
O9 - Extra button: (no name) - {e2e2dd38-d088-4134-82b7-f2ba38496583} - D:\WINDOWS\Network Diagnostic\xpnetdiag.exe
O9 - Extra ‘Tools’ menuitem: @xpsp3res.dll,-20001 - {e2e2dd38-d088-4134-82b7-f2ba38496583} - D:\WINDOWS\Network Diagnostic\xpnetdiag.exe
O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - D:\Program Files\Messenger\msmsgs.exe
O9 - Extra ‘Tools’ menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - D:\Program Files\Messenger\msmsgs.exe
O10 - Unknown file in Winsock LSP: d:\windows\system32\iavlsp.dll
O10 - Unknown file in Winsock LSP: d:\windows\system32\iavlsp.dll
O10 - Unknown file in Winsock LSP: d:\windows\system32\iavlsp.dll
O16 - DPF: {40F576AD-8680-4F9E-9490-99D069CD665F} - http://srtest-cdn.systemrequirementslab.com.s3.amazonaws.com/bin/sysreqlabdetect.cab
O16 - DPF: {6E32070A-766D-4EE6-879C-DC1FA91D2FC3} (MUWebControl Class) - http://www.update.microsoft.com/microsoftupdate/v6/V5Controls/en/x86/client/muweb_site.cab?1262542202046
O16 - DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} (Shockwave Flash Object) - http://fpdownload2.macromedia.com/get/shockwave/cabs/flash/swflash.cab
O16 - DPF: {E77F23EB-E7AB-4502-8F37-247DBAF1A147} (Windows Live Hotmail Photo Upload Tool) - http://gfx1.hotmail.com/mail/w4/pr01/photouploadcontrol/MSNPUpld.cab
O17 - HKLM\System\CCS\Services\Tcpip…{554AE581-6EC5-419B-80FC-70FC22421A2A}: NameServer = 8.8.8.8,8.8.4.4
O22 - SharedTaskScheduler: Browseui preloader - {438755C2-A8BA-11D1-B96B-00A0C90312E1} - D:\WINDOWS\system32\browseui.dll
O22 - SharedTaskScheduler: Component Categories cache daemon - {8C7461EF-2B13-11d2-BE35-3078302C2030} - D:\WINDOWS\system32\browseui.dll
O23 - Service: Apple Mobile Device - Apple Inc. - D:\Program Files\Common Files\Apple\Mobile Device Support\AppleMobileDeviceService.exe
O23 - Service: Ati HotKey Poller - ATI Technologies Inc. - D:\WINDOWS\system32\Ati2evxx.exe
O23 - Service: ATI Smart - Unknown owner - D:\WINDOWS\system32\ati2sgag.exe
O23 - Service: Bonjour Service - Apple Inc. - D:\Program Files\Bonjour\mDNSResponder.exe
O23 - Service: InstallDriver Table Manager (IDriverT) - Macrovision Corporation - D:\Program Files\Common Files\InstallShield\Driver\1050\Intel 32\IDriverT.exe
O23 - Service: iPod Service - Apple Inc. - D:\Program Files\iPod\bin\iPodService.exe
O23 - Service: Java Quick Starter (JavaQuickStarterService) - Sun Microsystems, Inc. - D:\Program Files\Java\jre6\bin\jqs.exe
O23 - Service: Adobe SwitchBoard (SwitchBoard) - Adobe Systems Incorporated - D:\Program Files\Common Files\Adobe\SwitchBoard\SwitchBoard.exe
O23 - Service: WMP54Gv4SVC - GEMTEKS - D:\Program Files\Linksys Wireless-G PCI Wireless Network Monitor\WLService.exe


End of file - 8165 bytes


#4

Well, that checks out fine.

I was thinking about how the issue won’t resolve until you reset your router, and I’m assuming that it starts happening again after running the torrent client. What router do you use, and do you have uPnP enabled?


#5

The router I use is actually a modem/router combo. It’s a 2wire it seems (although I never heard the name).
I’m trying to find in the settings where uPnP is listed but I can’t find it.


#6

Must be your router. I use utorrent all the time and never have had issues like this before. Under bandwith setting, how many max connections do you have listed? If i set mine to 500+ it kills my modem for a minute and it has to reset, I lowered it to 300 max connections per torrent and I havent had issues since.


#7

I’ve heard of 2wire before but I couldn’t tell you anything about the UI. UPnP could be under Port Forwards, as it does the same thing but it’s more automatic. If you find it, try clearing the UPnP entries.

Anyway, what seems to be going on here is that your router is not closing the ports that your torrent clients use after they’re done with it, and information is still getting through. The question here is “why it isn’t closing?”


#8

global number of connections: 200
DRD: did you mean uPnP in utorrent or router settings?

edit: 2wire has the worst fucking interface EVER.

edit2: I’ve gone through the whole settings, nowhere is uPnP listed.


#9

I just did some research and a lot of 2wire stuff doesn’t support UPnP. Normally that’s not a good thing but in this case it means it’s one less thing to rule out.

I know this is for when uTorrent is running, but try this out: http://forum.utorrent.com/viewtopic.php?id=15992#p258231

A few of the procedures in there look like they would not open as many connections, meaning that your problems would be alleviated somewhat until we can figure out a better solution.


#10

Tried all of those already :confused: I’ve been at this for a few hours now.


#11

I used to use uTorrent until it did the same thing, it would slow my internet to a crawl.

Do yourself a favor and switch to Vuze, you won’t have make yourself crazy tracking down specifics.


#12

I’ve had it happen before, and sadly the only thing I found that works is exactly what you are already doing, that is resetting the router.

My hypothesis for the whole situation is that on smaller, cheaper consumer routers, there isn’t enough memory on board the router to handle the heavy flow of bandwidth and traffic that torrents provide (e.g. the seeding/leeching, uploads/downloads between a large amount of connections) and just…overheats and causes problems with bandwidth even after finishing a torrent.

My other hypothesis is malware designed to specifically attack the router itself and not the computer. Both could be wrong, but if the former is right, only thing aside from upgrading to a new router is the reset, allowing a little time for it cool down. You might also try pointing a small fan on the router to see if that helps slightly.

If the latter is correct, check for updated firmware from your router manufacturer.


#13

Phreak: I downloaded vuze. Still does the same damn thing.


#14

I use a different torrent client, different OS, different router, and I have a similar issue. I’m not looking to solve my problem, but I did want to mention this in case it helps in some manner.

If the problem persists across many variables maybe it’s a specific issue with ISP? How about the old static IP your console and drop it in the DMZ? That never worked for me, but has for others with many different problems.


#15

Switching torrent clients wont solve this issue if it’s a factor that can be caused by all clients.

Is your PC running with a static IP address? Ports forwarded for your torrent client on this static IP? Try DMZ on the static IP? MTU of 1492?


#16

Tried all of those.


#17

I’m 100% confident it’s his router/modem combo.

I was talking with Val over IM last night, and he’s got a 2wire 2701hg-g, which is locked down pretty tight by his ISP with a password so we can’t get to any of the good stuff. My advice is to buy a different modem/router combo so he can mess with all the fun bits himself. It might also save him on his bill, since companies usually charge an equipment fee for things like that.

Just one bit of caution, though: call first and see if they allow that, because I’ve actually seen some ISPs that won’t give you phone support unless you’re using equipment that they approve.


#18

You serious? That’s pretty brutal.

I know with Verizon when I did support for them, we would give support to the fullest extent of our capability, but if a customer called in with a non-Linksys router, we would have to transfer them to their manufacturer to finish up things inside the router. Stupid (especially since I could almost walk blindly through whatever router, doubly so if it was a Netgear, but because the company wasn’t trained on anything but Linksys, as far as they were concerned, I was not supposed to do or handle that), but it’s at least better than “Sorry, not going to help you at all, you’re stuck.”


#19

Yep. They’d tell you to call the manufacturer. I’ve seen two ISPs that did this: Vista III Media (now bought out by Metrocast), and AT&T on certain occasions.

Hey Val, I’ve been looking through that manual for the 2701HG. Try out the stuff listed on page 38 where it tells you how to set up application profiles. This is the closest thing to port forwarding that I can find that the modem supports. That may help.