Tri-Mod (360TE+Kitty+DS4 w/ImpV2) Not powering; 1P,2P,1K,2K,3K & 4K Not functioning :'( **RESOLVED**


#1

The title says it all. I’ve just completed the soldering/wiring of this mod, and can not yield ANY response via the Imp V2’s RJ45 mount to the console. I don’t have a 360 or PS4 (only PS3), but holding the Home/Guide button (which was chosen act as the Imp “switch”) does nothing. I’ve plugged it into a PC… still nothing.

However the stick DOES recognize my PS3 with zero issues via the stock USB ONLY; from the cable compartment. I’m not sure what that says about the mod and narrowing the cause of the issue.

I tried to include photos of the more key areas, e.g. through hole soldering of the Imp, through hole soldering of the Kitty etc. The DS4 padhack was done by SRK member EJM, so I would almost eliminate that completely as an issue. But again, the 360/PS3 side of things aren’t working either (via the Imp only).

Here are said photos; I’m open to any & all suggestions.

Thanks

http://i.imgur.com/B6z6a0w.jpg

http://i.imgur.com/NmzvYVk.jpg

http://i.imgur.com/yO4tN18.jpg

http://i.imgur.com/KG1PgYn.jpg

http://i.imgur.com/sYeSITO.jpg


#2

rj45 goes to imp, D/E goes to kitty, and xd-/xd+ going to ds4?


#3

You need to solder power to the RJ45’s VCOL, in the first pic.


#4

Yes, the RJ45 cable (not pictured) is running from the Imp (& not the Kitty) to the Nuetrik mount (pictured).

And the XD-, XD+, V, & A lines of the Imp run to the “OUT” though-hole lines of the Kitty, while the E, D, G, & VCC lines of the Imp run to the 4 southern most screw down terminals of the DS4 padhack that are, from left to right, D+, D-,GND, & 5+ respectively. All the wires running from the Imp are colored to represent their respective USB lines, save for the sole blue cable that is the “switch” of the Imp, running to “Home” of the DS4 padhack.

…VCOL?


#5

It’s labeled underneath the RJ45 port on the Imp in the first picture. You need to solder a powered VCC to that spot.


#6

Ohhhh… that; you’re kidding. I was completely oblivious to that! I’m near absolutely positive that wasn’t covered in Toodle’s .pdf covering the installation of the Imp V2. I really had no idea. Soooo… does it matter where the VCC line is coming from? Whether it’d be the Kitty board or DS4 padhack??


#7

Any active VCC, since all boards are sharing the same VCC, if properly connected.


#8

Thank you!!! That was EXACTLY my issue. Everything now power’s up as intended. The fact that this detail wasn’t covered at all in Toodles .pdf on the Imp, I’m not sure how, if ever, I would have came to that conclusion on my own. Thanks again; I truly appreciate it.

http://i.imgur.com/iVr1oFi.jpg


#9

Hmmm. Interesting.
I’ve never used an ImpV2 in a non-MCCthulhu setup, so I’d have never known that.
I double-checked the documentation, and it indeed says that the VCOL solder point should be “N/C” in the Basic Setup (ie, 2 arbitrary USB devices).
Interestingly enough, the documentation does mention to solder to the VCOL point only in the standard MC Cthulhu setup.


#10

Precisely.


#11

Wooooooo!


#12

It doesn’t mention it should be wired up in a basic setup because it’s not expecting the rj45 connection to be used.


#13

That is a fair enough point. And now you have me asking if another detail on that documentation is perhaps misleading, considering such a setup; the "jumper"s. The jumper demands of the Basic Setup detail that “A” & “C” be soldered over, whilst leaving “B” alone. But in the same column that it details that the VCOL solder point should be used, it also states that ALL jumpers be left open. Should I mimic that for this setup as well? Leaving all jumpers open? I ask because since gaining power to the boards via RoyalFlushTZ’s advice, I immediately learned that when testing on DS4/PS4 side of things, 1P, 2P, 1K, 2K, 3K, & 4K are all nonfunctioning. This was tested via “Game Controls” on PC, since I don’t have access to a PS4. Now mind you everything else functions normally (e.g: Turbo(Touchscreen Button), Guide(Home), Select(Share), Start(Options), 3P, 4P, U,D,L,R), save for those 6. Curiously the 8 pushbutton LEDs of the TE’s control panel all light up when corresponding button is activated (as per characteristic of the “Kitty”), even those of the buttons that are not working; the control panel doesn’t discriminate.

While everything is wired as it’s seen in the image above in my last post, I took a single loose pushbutton and attached one lead to the GND of the DS4’s ground terminal, and simply went down the line of the terminals checking the terminals belonging to the nonfunctioning pushbuttons (1P, 2P, 1K, 2K, 3K & 4K), and they all fired up via “Game Controls” on PC. I’m not sure if that helps isolate the issue here.

I can’t imagine that there are half a dozen bad soldered connections underneath the Kitty board, especially when those identical buttons are functioning normally via PS3, but after looking at where all 6 leads reside on the Kitty… is it merely coincidental that they are in 2 groups of 3? And nothing more than a coincidence? Or could this have greater significance as to why exactly those 6 buttons highlighted below, are not functioning. Here’s a picture of the underside of the Kitty before the 26 gauge leads were then soldered to, going out to the terminals of the DS4:

http://i.imgur.com/YMENVDm.jpg

So since the Imp, as far as I know, doesn’t have a firmware of any kind that could cause an issue, I went straight to those “jumpers” after reading what you said Gummo, pointing out that the directions aren’t exactly future proof.

I don’t know what those jumpers control or release exactly. But could that be the issue here?


#14

I came back to this thread to share some information on such a mod for posterity. If anyone attempts to add a DS4 padhack to a 360 TE + Kitty w/Imp v2, you may very well run into this identical problem. First… here is the problem in question I asked myself a month ago (as I took a sabbatical from completing this frustrating mod :# ) after resolving the power issue (thanks to @RoyalFlushTZ):

Here is the answer:

Yes, there was significance there. And no, it was not merely a coincidence that they were in clusters. The picture will become clearer as you read on further.

Okay, assuming your padhack is 100% good-to-go, and you’re attempting to solder from the Dualshock 4 (or even 3rd party PS4 padhack for that matter) to the Kitty setup, you will need to know this invaluable piece of information to have your Tri-mod fully functional, which iswhen soldering the 8 top panel pushbuttons of your joystick, you must not solder to the underneath solder joints of the TE Kitty pcb.

The reason being that, thanks to @EJM, I learned that evidently diodes can sometimes (& in this case will) impede a signal. I couldn’t tell you as to why, but I can tell you that on this pcb… on specifically those connections… that they most certainly will.

Pictured just below is the underneath of the TE Kitty pcb, thankfully all the necessary contacts that need to be made for this tri-mod are all conveniently on this column of connections (though ‘Start’ & ‘Select’ are cropped out from above), but to reiterate you cannot simply use any of those contact points pictured within the pair of yellow boxes (Left side belonging to ribbons from the case & Right side belonging to ribbons from the Madcatz TE pcb, though it does not matter which side you choose as they are identical from left to right as far as establishing a connection).

http://i.imgur.com/lIfJMUO.jpg

What needs to done here, for 6 of the 8 pushbuttons to function (I know I said 8 earlier but that was just for convenience & continuity sake; stay with me), those 6 being 1P, 2P, 1K, 2K, 3K, & 4K, is that the connection coming from the padhack to the Kitty must instead be soldered to the resistors, and not the column of solder joints; they otherwise won’t function. Not only must these 6 contacts instead be soldered to the resistors, but the right-side contact joint (& only the right-side contact joint) of those very resistors. Those contact points of the resistors in question are marked above in green. Again, this is for 1P, 2P, 1K, 2K, 3K, & 4K only, with labels R6, R5, R10, R9, R8 & R7 being their respective resistor. Additionally, you could just very well choose to solder 1P & 2P (jab & strong) to their respective resistor for continuity; it will make no difference here whether you choose the the column of ribbon solder joints or resistors for those 2 buttons specifically, that’s up to you. And for clarification, all other contacts coming from the padhack can be soldered to the underside of the ribbon mount’s column of solder joints without issue.

Okay… that’s all. Hopefully that’ll help someone in the future from losing their head. And thanks to @RoyalFlushTZ & @Gummo again, for bringing clarity to the earlier aforementioned issue.


#15

I didn’t solder to those points and all my buttons work fine. Any reason you soldered there and not to the points where the actual ribbons from the distro block go?


#16

Right!! I think I know the very mod of yours that is maybe leaving you scratching your head as to why I went through the trouble (of soldering to resistors) if in fact, on yours… you did not. Just very recently as a matter of fact, I was searching around for documentation on such a mod (TE Kitty+DS4 padhack+Imp) and though I didn’t come up with any information on the identical mod, I did see a mod done by you that I happened upon via google images. I believe it was a Fightstick Pro which had a TE Kitty with a XB1/Crossbone & Imp? Is this the one? [details=Spoiler]

[/details]
I saw that your name was attached to the this mod, and I even told myself to pm you at some point, if for nothing more than my very own edification on how exactly you got the XB1 padhack to function with the TE, and whether or not you came upon the very issues I did with a DS4 padhack.

Oh, and to answer your question as to why I didn’t just “solder to the points where the actual ribbons were”… was because that didn’t work; I tried that. I detailed all of this, the problem and ultimately the solution, in my very last post that I imagined you read. I couldn’t tell you as to why they didn’t function when the DS4 padhack attempted to piggy-back from those very joints; they simply didn’t. Now I will tell you that the other 10 out of 16 contacts were absolutely fine when piggy-backing off those very solder joints (again, I detailed this point as well up above) with absolutely no issue. Why your mod, involving the XB1 pad, did work, sans issue? I was hoping you could tell me as to why that is. But perhaps therein lies the answer? For whatever reason a XB1 padhack can be soldered to those contacts joints, whereas for whatever reason a DS4 padhack cannot be (without instead soldering said 6 leads to the resistors).

Again, I can’t tell you as to why, but with absolute confidence I can tell you that soldering those very specific 6 buttons to the column of solder joints will result in those very 6 buttons not functioning. Meanwhile, those 6 buttons were all operational via PS3, and their respective control panel LEDs just as well fired up just fine. But going back to the PS4 side of things, I then didn’t find it so strange that the only working pushbutton’s respective solder joints on the ‘Kitty’ just so happened to be found at the very top of the column, and at the very bottom of the column respectively. Maybe that’s indicative of the reason as to why the then sandwiched connections wouldn’t allow themselves to be leeched from. A disruption of some hierarchal continuity? I know shit about electronics, so I don’t know. shrug What I do know, is that the moment I ran those 6 leads off those ribbon solder joints, and to the right side of their respective contact’s resistors, that they for the very first time were all 100% operational; they never have been up until that point.


#17

Very weird indeed


#18

Agreed. nods


#19

So I just came back to this post, sorry for the res (insert darksakul meme below).

You tried to solder to the turbo panel lights for the face buttons. You need to solder to the pins that have the buttons coming from the terminal strip.

Not sure how I didn’t notice that before haha.


#20

Oh, no no, that wasn’t an attempt on my part to get the face buttons to light up the LEDs of the control panel. That’s just the nature of the Kitty board; it does that by default. It’s simply a bonus feature.