Tried to replace cherry micro switch from IL/happ stick, and failed. Soldering?


#1

I was playing with my Mas systems stick today as usual. It was modded with a new IL stick bought from lizard lick, as well as new sanwa buttons on it. I also modded it to support both xbox 360 and ps3 with auto detect. I was playing some ssf4 in the morning and noticed that sometimes when I tried doing crouching moves, 50% of the time the stick wouldnt detect my crouching input, and so I would be doing a standing attack. I thought the problem was lag and I left it there. Now I came to play some games online, and god the problem was worse and I got owned the first fight. I then thought that the culprit was the cherry microswitch that wasnt working properly so I decided to switch it with another one. Now heres the thing. I have quick disconnects in all the switches BUT … one part of the switch IS soldered to a cable that runs all around the 4 directional switches. I never have soldered stuff in my life, but I was desperate to find a solution so I just took the switch off the stick, and replace it with a spare one I was previously using for a button ( using the switches for buttons or for the actual stick should be interchangeable right? ). I put the new switch in place, and the quick disconnects where they should be, and as for the soldered part, I just put a portion of the naked cable through the hole of the switch and holded it in place by twisting it around it. Now I tested the direction inputs, and all of them work well except for that one switch. What is going on? Do I need no matter what to solder it? If so, then how is that the stick is working ok, EXCEPT for that direction switch ( the down press ). Maybe Im using the incorrect switch for the stick since Im using one that was used for one of the buttons?
Help please! =(


#2

With the stick plugged in, take the QD from the Down switch. Touch the metal part of the QD with the ground wire (the wire that’s soldered to all of the switches)

If Down doesn’t register in game, then that indicates that the wiring for the QD is bad (the ground wire should be fine since everything else that wire is connected to is still working fine). Investigate and look for a break, take some pictures if you want more help. Soldering may not be necessary for a repair depending on what exactly is wrong with it.

If Down does register… then I honestly don’t know, that makes no sense at all.


#3

Thanks man for the help, I really appreciate it. Im a total noob when it comes to stick modding, so what did you mean by QD?
Im going to try to upload some pictures of it too.


#4

Ok here are the pics:

The black wire is the one that goes around all the switches and is soldered to the lonely end of them ( not to any of the ones that come on pairs ). I took the cover away from the micro switch so you can see that everything looks as it should.


#5

according to your pictures, your signal is the gray wires connected to the middle pin of your switches. the blue QD (quick disconnect)is the daisy in your ground loop that looks like it came lose from your Down direction switch. what you need to do is reconnect the black wire in the last pic to that ground loop with the blue QD on the bottom of the switch then move it back to the top where your ground loop is.


#6

QD is the Quick Disconnect the part you plug and unplug. The black wire is the ground it should touch all the switches only once. I see you have it connected twice in the pictures above.


#7

Thanks for the help. Im getting confused here so bare my ignorance please =/.
Where do I reconnect the black wire? I know that the upper pin is where it used to be. Do I take it and put it in the lower pin, then the switch will recognize the connection, then I move it back to the upper one? I really didnt understand. =(


#8

Thanks man for ur feedback. What do u mean I have it connected “twice”? I see the black wire connected to the upper pin so thats not one connection? lol I dont know anything.


#9

Black on the outside and grey on the one closest to it take the other on off just 2 wires per switch


#10

On the bottom picture you have the switch open and 3 wires connected to it


#11

I took out the blue QD and left just the black wire on top with the gray one to the middle one … and now the stick doesnt work at all. =(
I dont remember well if all the wires were connected, or if one of them was lose.
EDIT: If I leave the black wire on top and the blue one at the bottom, the stick works perfect except that I cant press on that directional input ( down ). I then try to insert the gray wire into the switch and nothing happens, Like its not recognizing it or something. I was messing with the connections some time ago and I managed to get the down input work, but couldnt replicate it because I dont know exactly what I did.


#12

Ok so thats because you don’t have the ground connected anymore. You need to have the ground connected for them to work


#13

Man, can u please explain it to me step by step what should I be doing? Take the last picture as my start point.
What wire do I take out first, which one should I then put in, etc …
I thought this was just going to be a quick take out - put new easy job.


#14

I was wonder why you not come to me first.
Laugh.

All VOLTECH did was made the MAS holes fit Sanwa Buttons?


#15

Sorry for the double post but I dont know what this means. I just switched positions between the black naked wire with the blue wire ( now the latter is on top, and the black one on the bottom pin of the switch ), and the stick is now working as normal!
The thing is that this setup wasnt the one it has ( 100% sure ), so I dont know what effects this may cause overall in the whole stick.
EDIT: When I touch the blue one to any of the gray wires, the direction for that input works.
Im getting crazy here o.O


#16

I sent u an email before I posted here. To the jj.socalmodding one.


#17

I got it after you made the Thread. :sad:


#18

It should be but you cut a wire it looks like. The Switch was not the problem the New IL stick has small corners so its not as easy to find them. If you can move up down left and right then all the switches are working.

Make sure the black wire touches every switch but only once on the outside connection. The grey wires should all plug onto the one closest to it.


#19

Combine the loose black wire with the Blue Quick Disconnect.
Connect the Blue Quick Disconnect to the COM Terminal (the outer bent one) of Microswitch.

Connect the Gray Wire to the NO Terminal (middle prong) of Microswitch.

Done.


#20

I always have had problems with the diagonals, but it wasnt till today that I started having worse problems because of it. It just doesnt make sense to me, unless its regular wear and tear … which also doesnt make sense since I just bought the stick brand new late november 2010. I guess maybe if the switch I was going to replace would have been a “regular one” I wouldnt have had any problems, but since it was the “one with the blue wire”, Im getting completely ignorant as to how to fix it.
And yeah, all the other directions are working good.