Trouble with my Brooks Board

My Stick and Brooks board was working fine until a few days ago. When i plug in the USB my screen tells me that there’s too many usb connected devices and usb require more power than USB can supply. I have a Kaimana Khameleon attached for my LED Lights and am including pictures. Any help will be greatly appreciated.


Well, it sounds like there are too many USB devices connected.
And probably has nothing to do with what’s actually inside your stick.

Questions for details that haven’t been brought up:

  1. What platform are you plugging this in on?
  2. On that platform, has there been any recent change in the USB devices that are connected?
1 Like

It’s been connected to my pS4 which no longer recognizes it and my PC which is where i receive the error message.

Was the Khameleon added and then you started getting the message?

Mainly asking because there shouldn’t be any reason for the messaging to come up if it was working before and if there’s been no change in the setup the whole time.

I’ve seen similar messages/symptoms appear before, but that’s only when adding/changing the devices to the platform. I tried to have 4 arcade sticks (two of them were dual-modded) connected to a PS4 once, and things started crapping out.

The Khameleon was on the Brooks from the beginning and I have tried to remove it and just use the Brooks board and it still has the same error.

Mail]( for Windows 10

there may be an issue with the UFB circuit board itself, as my first attempt at modifying my Obsidian was met with a similar message. Try putting the UFB into update mode by holding the PS button and I believe Share after checking all of the connections. If it won’t go into update mode, there’s a chance the UFB is gone and a replacement will need to be purchased.