Turbo Functionality Issue


#1

Before I start, I’d like to say that I tried searching my issue, but with no luck, I’ve even tried calling Madcatz, but they were closed. Anyway, on topic.

I recently purchased Madcatz’s Soul Calibur 5 Arcade Fightstick: Soul Edition, and I’ve been using it for most of my fighting games since I got it (it’s a wonderful stick). It’s had no issues up until today. I was playing in the quick battle section of SC5 when my stick became unresponsive. For some odd reason, six of the 8 turbo lights are lit up and blinking and none of the buttons are working. I’ve tried un-plugging it, resetting my system, holding the turbo button in like the instructions say, holding in the turbo button and pressing the buttons I want to cancel turbo on, and calling Madcatz. Nothing I’ve done worked. I’m honestly lost at this point on what to do. I don’t want to resort to opening it, because it’s still under warranty. It’s a playstation 3 fightstick, and as it is currently, it’s working, but the buttons are not. If anyone else has had this problem and knows how to fix it, please reply. Thanks in advance to anyone who helps.


#2

If it’s like that on plugin without anything pressed, it’s fubared and you should contact madcatz about it. The only ‘fix’ we could help with is swapping out the brains for something else, but for a brand new stick, dont even think about it. Make MadCatz do it.


#3

That’s depressing to hear. I’ve only had the thing for about two weeks and it’s already messed up. Is this a common thing with MadCatz sticks?