Universal PCB (eventually) thread

I dont want to deal with the UPCB, I simply dont have the time, and wont be taking any questions on it.

Got it built easily in MPLAB and started modifying the xbox module for my project. THANKS! :slight_smile:

when i wanna built the file. found tat pcusb.c and pcusb.h is missing.

u have ths problem?
i am using MPLAB too~

if i programme the pic18f4550 with the hex file from the output folder.
i plug into my pc and it detects nothing >_<


pcusb.c and pcusb.h were missing for me also. It seems like PC USB may not be supported with the files Toodles provided. However, I don’t need any device support except for the original xbox so I removed the files from the project, and after setting some paths I was able to build it successfully. I never tried to program my PIC with my build or the pre-packed output, though. After that I started to modify the code so I can’t really help much, as I’m not using UPCB in its original form.

i wish to build 1 to be used in PC >_<

btw…i don get how to interface the connection with USB~~

is it the area number 5?
how to link tat to usb?

i wish to use in PC and PS 3


I believe a MC Cthulhu will do what you want (interface with PC and PS3). You should verify this though. I’d suggest you buy one - here’s the thread with information:

And here’s where to buy one:


You can save yourself a lot of time for $35. Hope this helps.

short heads up.I`ve left 15 pcbs for last batch of UPCB pcb. DIY kits goes for 35€

DIY kits of upcb in stock for 25Euro + 10Euro shipping please contact me at klaus@wolfsoft.de

I understand that toodles is not supporting this board anymore so I am just posting in the slight hope that someone else has some knowledge here. a kind friend (superking) gave me a universal PCB 1.0 he bought ages ago but never put to use. Apparently it is one of the first PCB’s toodle’s shipped out.

anyway it seemed to work right off the bat on pcb and on ps3 it would work with a few small issues. So I decided to update the firmware to get it working properly on ps3, I managed to get bootloader drivers working on windows 7 after some googling (the included drivers did not work in win7) and got the software to load and backup the .hex file on the eeprom or whatever. after backing up I tried to program the new one on there following the instructables guide but I got this error.


I decided to try it anyway and the PS3 support did indeed update and work properly and pressing start + select now functions as a home button, so that’s awesome I assumed it worked out regardless of the error. I then decided to make a ps2 cord and carefully followed the instructions, but alas it did not work, double and triple checking the wiring it still does not respond so I am thinking it may be due to the firmware not updating properly. To clarify I made the button select psx cable.

also in the assembly instructable I noticed this quote

I can’t seem to find this solution referenced here in the installation instructable. This could be part of my problem but I am not sure.

thanks alot anyone who can help with any of the above.

the thing still works great for my ps3 and PC so it’s still awesome to have, but it would be amazing if I could get more support out of it.

Here’s a little bit from earlier in the thread regarding that last issue… (starting from Universal PCB (eventually) thread )

and for the error during programming:

from Universal PCB (eventually) thread

oh wow I skimmed the thread and missed alot of this, really sorry man, you are awesome for hooking me up with all these references! thanks alot.

I guess my ps2 cable must still be off somehow then, damn :frowning: I will try another console and then go back to it.

No worries! I knew they were there because I ran into them myself :slight_smile:


Can someone upload the gerber files ?
This link : http://www.marcuspost.com/downloads/upcb/Rev2.1.zip is broken, and i cannot find the files anywhere :confused:

Any help would be appreciated :slight_smile:

Code and gerber links corrected.

Thanks !

Are there any unassembled UPCBs floating around looking for a home? I could get by with just a bare PCB with no parts, I have a couple of spare ICs and a nearby electronics store _b Even with all these new boards being produced, I still really like the functionality of the UPCB. My Rev1 board still goes strong…

Would require shipping to New Zealand.


I actually happen to have two blank 2.1 boards sitting around that I never got around to putting in my namcos. I live in Wellington. :tup:

Has anyone here created a Saturn cable for the UPCB? I’ve made many other console cables and not encountered any problems, but my Saturn cable results in the controller constantly pressing the LK button (A). This means it mashes through menus, and repeatedly light kicks in-game (sfa2). When I pressed other buttons it was possible to get the corresponding input if mashed well enough (e.g. mashing LP will occasionally get an in-game LP in between the flurry of LKs). The directional pad DB position actually forced a start button press.

I’m thinking this probably means some of the Data or Select lines are not correctly configured, but I have checked and re-checked my cable and am pretty confident it is correct.

I’ve tried it with two different sticks w/UPCBs in them, and even two different saturn controller cables, so it’s certainly not the UPCB itself. Surely it must be the cable, or the programming. I have a pal saturn, so I’m wondering if that has any bearing as well.

So, has anyone else made a working Saturn cable using the instructions in the UPCB v2.5 zip?

edit: after reading through this entire thread again, I notice in the past couple of pages some other people mentioning problems with the Saturn code, although not as bad problems as I’m encountering. All good, I guess it just isn’t 100% stable support, especially with PAL saturns. I can use the saturn pads as project boxes and use the neo geo cables instead.

Well damn, as a hunch I just pulled out my piggybacked 360 pcb and now the saturn support works perfectly.

Somehow it’s interfering (power draw?). Will try to come up with a solution.