Unresponsive Arcade Stick on SSF4 AE PC


#1

Hi guys, just got SSF4 on Steam through Bootcamp and it runs beautifully, however, I do have one major issue- although my computer recognizes my stick and its inputs when I go to Devices, the stick doesn’t work at all when I start the game up. I tried DS3, and it doesn’t recognize my device through there, so I tried BetterDS3, which recognized my inputs on the device, but I couldn’t seem to register it on to the program. The game runs at about 80 FPS when I tested on benchmark, if that helps.

Here are some specifics:
Game: SSF4 on Steam
Stick: PS3 Hori V3 Fighting Stick
OS: Windows 7 Ultimate 64 Bit through BootCamp
Computer: 2013 Macbook Pro
Graphics Card: Intel 4000
Ram: 8GB

Thanks in advanced guys!


#2

Do the buttons work but not the joystick??


#3

Try changing the USB its pluged into, my SF4AE on PC bugs out if I put it in my left USB for some reason, there will be large delay and shit. But the right side works fine. Anyways something to try.


#4

Thanks for the replies, guys. So I’m doubtful that it’s a problem with the USB as my computer registers it. As for the joystick, yes, the joystick movements are also recognized. The joystick in a sense, “works” as it’s recognized by the computer and the inputs are recognized as well. However, when put to the test in SSF4 AE, it doesn’t seem to work despite the fact that my computer picks up these inputs on DS3.

I’m starting to think that it’s because it’s not registered in the DS3. When I go to the software itself, my controller doesn’t show under the connected list, but when I click on the control panel button, it shows that my controller is recognized. Is there anyway that I can make that show up under the “connected DS3 controller” list?

Here’s a SS so you guys get what I’m saying.
http://betterds3.ciebiera.net/bds3wp/wp-content/themes/responsive-child-theme/images/featured-image.pngimage.png%3Bhttp%3A%2F%2Fbetterds3.ciebiera.net%2F%3B440%3B300


#5

I have a Mayflash and HRAP3 and they both work. But the Hori stick acts funny if I leave the joystick in the Dpad mode, so you have to use the Left Joystick mode for your joystick. There is a switch on the panel.

http://www.hori.jp/us/Products/PS3/ps3_fsv3/image/layout.jpg

Did you even move the switch?


#6

That’s exactly what I was thinking the problem might be. Let us know if that was it @Fuhrer .


#7

So I just moved the switch hoping that it would solve the problem, but it still doesn’t work, it seems- did you still have to register it under DS3 or was it just plug and play [I looked around and it seems that Horis are plug and plays]? If it requires DS3, is there any tutorial on how to register an arcade stick to DS3? Because I looked and it seems that all the tutorials are in regards to dualshocks. :confused:


#8

It’s plug and play. I don’t know what’s going on with your stick or your computer but you should at least be able to configure the controller in the options menu.


#9

That’s the strange part, although my computer recognizes it, when I got to the options and button config on SSF4, the only configurations that show up are keyboard 1 and keyboard 2. The strange thing is, I have two V3s and both of them are acting this way…


#10

Just figured it out! I had to turn on my computer with the controller plugged in for some reason. Works great now!
Thanks a bunch SRK!


#11

I’d rather think you have to plug the stick before launching SSF4.


#12

Crazy thing is , i can set my stick up in the menu, but when im trying to use it in game , it jumps and moves fine and all the punches work but the start and kick buttons dont work in ssf4 ae. ALl buttons and input work when i caliberate it etc. Just not all the buttons seem to work. Any ideas?


#13

I seem to have run into the same issue as @Fuhrer.

My HRAP 3 gets detected and works when I test it in the USB game controller test screen. It also gets detected in-game (or at least I can see it in the button config menu), but no inputs are registering.

I tried turning off the PC and plugging in before booting. That got the stick working perfectly until I rebooted again. Now it doesn’t work in-game no matter what I do.

Any suggestions on how to get it working?


#14

That’s weird. My HRAP 3 works just fine with Ultra.

Are you plugging in the stick before or after you launch the game?


#15

Hi,

I’ve tried plugging in after launching the game, and also before launching the game. Neither option worked. I’ve also tried deleting the drivers, and rebooting, but still the same issue: The stick gets detected just fine, but the inputs don’t work when using SSF4AE/USF4.

Bit of an update, but I’ve just tried an HRAP v4 and a Logitech Gamepad. Both work when tested in the Windows game controller test utility and when running other apps, just not with USF4. :frowning:

System:

Windows 8.1 Home
MSI GP60
USF4 retail version.

EDIT:

Did a bit more googling and managed to fix it! Really weird though. Apparently alt+tabbing out of the game and alt tabbing back in fixes the issue.