Up is up and down is up. . . wiring help


#1

so. . .image for reference

so my problem is that when I connect the wiring harness on the JLF, suddenly pressing down will result in an up command, and all other buttons work fine. When my wiring harness is unplugged, all buttons work as expected.

those 4 buttons in the middle are a dpad and I’m using a fightpad for the pad.

I have it set up such that all buttons have the common ground, and then (because I ran out of quick disconnects) I have each signal on PCB -> each respective button -> respective wiring harness button.

TLDR:

everything works sans joystick
once joystick is connected, up is up, down is up, everything else works.

any ideas what I should be looking for to fix?


#2

Probably a good start would be posting a picture of the actual wiring. Double check that the ribbon isn’t plugged in backwards to the stick as well, though it doesn’t sound like thats necessarily the problem, always good to make sure.


#3

so update: I just took the ground off of all of the button and tried the joystick, got the same results.

so then I took the ground wire and just touched it to the PCB mounts on the joystick microswitches and it still gave the same result.

that should lead me to believe that there could be a short on the JLF board?

update:

so I fixed it, for about 20 minutes but now it’s acting the same way.

if it helps, I just discovered that if I hold down then press up while down is still held then the up will happen, but if I’m not holding down then both up and down will be registered as down. I’m guessing this means that there is indeed a short and it is happening somewhere in my up and down wiring?


#4

yeah I pretty much just confirmed that it’s simply a shitty wiring job. . . I’ll have to strip it down and do it right :_(