USB device not recognized


Hello SRK forums,

I recently bought a modded Xbox 360 MadCatz SE fightstick online in hopes of using it to play AE on PC. This is also my first fightstick, so I was pretty excited. My PC uses Windows 7, and on the first day of use, it installed the drivers immediately after being plugged in, and worked perfectly. Second day, it’s also working perfectly. On the third day, I booted up AE and realized the buttons suddenly weren’t working despite the light being on. “No biggie” I say, and simply unplug it and plug it back in. After plugging it back in, I get “USB device not recognized” on the screen. This continued after several tries of unplugging/plugging it back in. I tried uninstalling and re-installing the driver, system restore to an earlier time, various other drivers, plugging it into the other USB ports, researching for hours and all for nothing. I start thinking that maybe the stick is faulty, but before assuming so I tried plugging it into my dads laptop, which runs Windows XP, and it worked just fine. The stick isn’t the problem so it has to be something with either my PC’s USB ports, or Windows 7. All the other related stories I read about were people attempting to use their fightstick or 360 controller on Windows 7/Vista as well. After some more experimenting, I find out that I can simply unplug/plug it back in until it works.This obviously isn’t the best solution considering I was sitting there unplugging/plugging it in for at least 2 minutes before it finally worked on the last try. I was wondering if anyone else has, or had this problem, and what might be a good fix for it.




i bought a faulty x360 TE stick off ebay for £50, with the intention of wacking in a PSOne dualshock,

before i did that i thought i might aswell check on pc just incase its actually working and some dumbass sold it as faulty because maybe he had set dp to ls or whatever

plugged it in, and usb device not recognised

opened it up and everything seems to be in order, so i just ripped the piece of shit pcb out and replaced it with a PSOne dualshock, Xbox1 emus are where its at


It could be the USB cable, if one of the 4 wires inside is broke, the whole controller will not be detected on the PC.
Since you are getting power to the stick I assume it is the white or green wires.


Your cable might be broken or your Windows DRIVERS might be outdated. Try updating them and disable fast boot. I was facing this problem with my Windows 10 laptop but now I’ve fixed this problem. An article helped me for doing this device descriptor request failed


Why are you going around bumping old threads


Yes, please stop it.


Less than a day joined. Nearly four necro’d threads resurrected. Four shameless plugs to the same dumb link.

Homie is posting like he’s OG.

Welcome to SRK Tech Talk, @sachin_bharmoria
Do yourself (and the rest of us) a favor…



He probability a bot.