USB encoder directions reversed?


#1

My TvC stick with a USB adapter was no longer working, so I installed a USB encoder (this one specifically: http://www.ebay.com/itm/New-Zero-Delay-Arcade-USB-Encoder-PC-to-Joystick-for-5pin-Sanwa-Type-Push-button-/171060862728?pt=LH_DefaultDomain_0&hash=item27d4059f08). Got all of the face buttons and the stick working again, but when I checked the device’s Properties, all of the directions were reversed. Up was down, left was right, etc. My joystick certainly isn’t upside-down, but it seemed to think it was. Opened USFIV, tried to bind them in reverse, had no effect. Up and Down would either be reversed, or would simply not respond. Unscrewed the joystick, flipped it upside down, plugged it back in, all directions are now correct in Properties. Open up USFIV, try to bind controls. Left and right function properly, but up and down are still broken. Either unresponsive or reversed now matter how I bind them. What could this possibly be?


#2

Take clear pictures of your stick’s internals.
It’s pretty hard to diagnose with just a text description.


#3

@PresidentCamacho‌ - Sounds like OP needs to swap some wires in his 5-pin JST, huh?


#4

The stick stopped responding after a few seconds with the stock 5pin, so I switched it for the one that came with the encoder. Started responding, but reversed. And Windows show proper movement after flipping it, but Street Fighter is being difficult.

Just tested it with KOFXIII and some 2D games, they had no problems with the inputs at all. So the problem is exclusive to Ultra.


#5

Ok…that’s weird.


#6

Yeah, so now this is less Tech Talk and more What the Hell Is Wrong With Ultra.


#7

Capcom.


#8

I figured it out. I wasn’t saving the controls properly. That was dumb. Tear apart the stick and connect all these goddamn wires with no problem, and then I can’t even figure out a menu.
Still doesn’t explain why the encoder thought the stick was upside-down.


#9

Yeah, that’s what it sounds like. I responded in the Q&A thread, was busy camping (with no wireless coverage) for the last couple days. I’ve has to re-arrange the pins on both of my USB/PS3/PS2 ZD’s, this is the first instance I’ve heard of the USB only version having that issue.


#10

From the sounds of it that may not have been the issue since it only happens on Ultra…


#11

I thought the op meant he was able to re-map the directions in other games without problems.


#12

Me no know???


#13

I fixed it for Ultra, it was just the way confirming changes to the controls in the PC version works that was messing it up. After I flipped it upside-down.


#14

SFIV on PC has known to have spotty support for certain controllers.


#15

Way I see it SFIV on PC been spotty in general, only thing the PC got over the console version is maybe the net code.