Very unusual wiring-related problem


#1

Hello, Tech Talk!

I recently finished building my first arcade stick, encountering and tackling only a few small problems (with help from you guys!) along the way. It certainly isn’t as great as some of the stuff that I’ve seen around these forums, but I am quite pleased with the way that it turned out. I have, however, run into a very odd wiring problem. A friend of mine helped with the soldering; he regularly does random soldering projects and has even gone so far as reconstructing a few old arcade cabinets, so he was the obvious person to ask for help.

Upon completing the first round of soldering, using a Madcatz Fightpad PCB, we had a problem involving RB (FP) not working, so we re-soldered it, at which point B (MK) stopped working. After re-soldering again, everything worked fine for about an hour of play, at which point Up on the stick stopped working.

Basically, it became a game of re-solder one button and another one would stop working. We looked over the PCB very closely to see if any loose solder-bits had attached themselves to a strange location and found nothing unusual. After hours of messing with the wires to make sure nothing was wrong there, everything magically worked… until the next day when the guide button decided to start activating on its own. Since it is the guide button and not required, I just cut the wires running from the PCB to the button and left it alone; however, the button continued to activate on its own volition at increasing rapidity, eventually activating so quickly on its own that it was like i was sitting and spamming the button as rapidly as i could. At this point I deemed the stick unusable until that problem was fixed.

A couple of days ago, I decided to plug the stick in just for the hell of it, and it worked. It worked totally fine for two entire days with no mishaps whatsoever. Everything was cool, aside from the guide button no longer being connected. Today I gave it a shot, and it worked, so I decided that it was time to reattach the guide button. Upon doing so, everything worked. I screwed the bottom plate on it and, as soon as I plugged it back in, the Right directional input no longer worked.

I have no idea how to handle this situation, as my experience with such things is quite limited. Have any of you ever experienced similar problems? It seems like a pretty unique case and googling/searching the forums has not really given me the answers that I am looking for.


#2

Wow, you are the victor of odd problems, I think. And you are only using one PCB? Because if you did a dual mod without properly connecting everything, then that could cause some wacky.


#3

Indeed, it is just a single PCB. My friend is convinced that a sacrifice of some kind is in order if we ever hope for it to work.


#4

How much clearance between the bottom plate and other stuff is there when you close it?


#5

There is roughly 1-1.5 inches of clearance between the PCB and the bottom plate. No movement happens when I attach the bottom panel aside from a slight (and I mean super, super slight) shift of the power cord towards the PCB.


#6

high res pictures of the pcb would help

edit: oh yeah and playing with a multimeter could also help you find out more about whats going on with your pcb too


#7

I am currently uploading the pictures to post. We used a multimeter and everything checked out after every soldering attempt, even after the buttons stopped working on the xbox.


#8

Here are two pictures:

If these aren’t good enough, I can take more. I tried to get as much of the detail in as possible without risking pulling a random wire loose (that certainly wouldn’t help matters :o )


#9

Ok, so what happens if you plug it in and fiddle with the cord?


#10

At the moment, the bottom panel is removed and the power cord is completely out of the way and everything still functions normally, save the right directional input.

And thanks for all of the replies. This has been a very frustrating problem, I really appreciate all of the help :D!


#11

wow! that really looks like my first attempt at a padhack.

kk… first thing is first. remember that this is a common ground pcb you are using. you dont need so many ground points. you can ground two and daisy chain the ground to the rest of the points on your pushbuttons and directionals. that will help clear the clutter. what I am thinking is happening since you ran a multimeter and it checked out good is that when you are placing the cover panel back on you are crushing the wires in the case so your causing some wires to randomly touch causing a short.
I would re-wire the pad a small bit to see if that would correct it. take the grounds out and choose two to help chain the pushbutton grounds. that will give your pcb wires a little more breathing room when you close the stick up. since your multi checked good to go I’m sure thats the cause of your mystery shorts. if you arent using the top trigger buttons on your set up it would be a good idea to take those out as well since it could accidentally engage if the pcb is moved in your case. good luck with the fix hope all works out well!


#12

i saw the pic. you made soldered each ground separately.i would only use one ground. an use wire meant for computer electronics. that looks like speaker wire. you’re probably shorting


#13

Wow, thank you, Blind!

I will give these suggestions a shot this weekend and see if it works!


#14

Update:

We redid all of the wiring with shorter bits of wire (to keep them from moving when the bottom panel is attached), we used two grounding wires (which are colored green in the pictures below), we removed the shoulder buttons, and we looked over everything very, very closely with a magnifying glass to make sure that no unintended solder made its way on to any areas of the PCB.

We used a multimeter again to make sure all of the connections were good, and they were. We had no interference from button to button, either. Upon plugging the stick into the xbox, everything worked for a short period of time, but we left shortly thereafter to get something to eat, so we only did some quick training mode tests in SSF4, but everything checked out fine.

A couple of hours later, we went to try the stick again and were able to navigate menus with no problems; that is, we were able to use A (LK) and B (MK) to select training mode, characters and to select or deselect anything from any menus (guide menu included). Once in the game itself, every kick button refused to work. If we unplugged the controller and plugged it back in, all three kicks would activate one time on their own, and then stop working completely UNLESS navigating a menu. So kicks work to get into the game, but once in the game they stop working.

It is very confusing and we have no idea how to change something to make it stop doing this. Here are a few new pictures of the wiring:


#15

Last time that happened to me, the KKK button was stuck down. Check that line for shorts etc.


#16

Well, the KKK button isn’t even connected. It is a six button setup and we removed the shoulder button bits from the pcb. I can see how that would cause these results, but i don’t know how it could be happening when the button doesn’t exist.


#17

Can you unmap the ‘KKK’ button to test this hypothesis?
Is the shoulder trigger analog?


#18

wait… take a pic of the connections to the buttons please.


#19

Here is the picture that you requested, Blind:

Rufus, unmapping the KKK button seems to have fixed the problem! Is there any way that I can avoid having to unmap that every time that I play on an xbox that isn’t my own?


#20

Since you don’t seem to have the same issue with PPP, I’m guessing that you’ve got analog triggers, and you haven’t removed them from the other side of the PCB yet. If that’s the case, you can probably twist the knob on the pot that corresponds to KKK so that KKK is not on by default. If it’s analog, and you’ve removed the pot, you can fake it with resistors - I don’t know the correct values off hand.

You might get some insight from this thread:
http://shoryuken.com/f177/how-padhack-08-09-madcatz-4716-common-ground-xbox-360-pad-197388/