Vsync on lags but read this


#1

I’ll get lag from vsync, but if I hit alt+tab for the steam overlay to pop up and then close it, the lag goes away.

I turned off vsync and had no problems, but I would like to wonder why is opening steam overlay fixing it and if there’s a way to fix this problem I would like vsync on(no screen tearing)

I know it’s not laggy, because of my computer specs, cause I can fix it by shift+shift(steam overlay) then closing it and bam, game goes to 60 fps.

I just hate having to do that like 80% of the time I play, so I turned it off until I find a solution.

Can anyone explain why shit+tabbing fixes my problem? Is there another way to fix so I don’t have to do this?


#2

with lag do you mean in offline mode or online warping?


#3

By “lag” do you mean the game lagging behind in fps, or lagging inputs? Big difference. Other than that, the game isn’t optimized at all and uses a ton of stock default options with little to no customization to the engine, so it shouldn’t surprise anyone that stupid stuff goes on like this.


#4

Had the same problem
Using a Nvidia card? change this v sync setting to ‘adaptive’ or ‘off’ http://i.imgur.com/xEKSjDH.png . Totally fixed it for me, no more alt tabbing.

Some discussion/fixes also here https://www.reddit.com/r/StreetFighter/comments/4ad17i/pc_framerate_fix/