Wierd issue with my SE Fightstick


#1

Anyone else having an issue with your buttons not firing 100% of the time?

My y (Medium Punch) button won’t fire 100% of the time, more like 30%…

I figured it was a faulty button at first so i switched it with one of the other buttons, now it still has the same problem… I took the LT (Triple Kick) button and moved it to the Y button location and now that button has the same issue, I tried switching that buttons wires from the medium punch and just putting the LT button in the Y button socket and then remapping the LT (Which at this point is in the Y button location) to medium punch… STILL THE SAME PROBLEM!! its like my SE stick refuses to want a button in the Y button socket… :wow: :lame:

so its like my SE stick will only accept this layout

O X O O
O O O O

Any suggestions other than buying a new stick? I do have 8 Sanwa buttons coming, hope that they’ll fix the issue.

Edit: After trying the method of button maintenance Socratic suggested the issue cleared up.

Thanks for everyone’s help!


#2

Jsut switch your quick disconnects with the button that’s not doing it.

So it’s like

O O O X
O O O O


#3

Ive tried that… like i said, whatever button is in that spot just wont fire 100% of the time regardless of where its qdcs are from ive even move a black button to that spot but left it hooked to trigger/bumper/shoulder… it still wont fire 100% of the time

like i said, crazy wierd… think ill need to replace the board?


#4

My buttons haven’t gotten that bad, but Y sometimes gets stuck and I have to keep pressing it until it pops up again.


#5

is that it wont work in a combo or it just wont work when pressing only it?


#6

i’m saying, swap the actual pair of quick disconnects for one of your other buttons.

So, your layout might be messed up but you can configure that in game.

it’s not a hard concept, relaly.


#7

I’m having that same damn problem too. I guess we all use that button a lot or this is gods way of telling us to jump into SNK games with 4 button layouts.


#8

AND IVE SAID I’ve done that

so instead of my layout being

1 2 3 4
5 6 7 8

It’s now

1 8 3 4
5 6 7 2

in this layout my y buttin is now in the LT position and the LT in the Y position but their wires remain in the original config so i at default controls without remmapping its

LP 3xK HP 3xP
LK MK HK MP

basically when you press a button repeatedly in say practice mode with inputs turned on itll normally look something like this

PPPPPPPPPPPPPPPPP

But right now as it stands it is more like

P PPPP P P P P

God I hope my SANWA’s will fix this issue…

Regardless I went out and grabbed a TE to either way its an issue that visitors will have to deal with :stuck_out_tongue:


#9

Same button same problem, except mine doesn’t respond some 90% of the time. Sometimes flawless for 30 seconds, then random for minutes, then dead for minutes, etc.

Haven’t opened it up trying to switch buttons yet, but I suspect it’s the PCB. My warrant is voided because the sticker looks like I’ve cut it, must’ve been grinding on my… hmm… lap too much. :bgrin:

Hope you won’t run in to the same kind of issue with the TE you grabbed. But be happy you can afford and find one just like that.


#10

sucks, i was thiniking pcb too…

I was gunna dual mod it too… owell.


#11

I used to have that problem on mid kick.
I changed my switches for sanwas and it seems to have solve my problem (I did it yesterday evening, I haven’t played so much yet)


#12

Try this.


#13

Thanks! I was trying something like that but yeah… you know how springs are… so now I’m waiting for my buttons lol:rofl:


#14

Update; It works!

Thanks Socratic!

Now i just need my sanwas and everything will be alright.