Wired xbox 360 pad hack is disconnecting


#1

Hey guys hopefully you guys can help me with this issue that has been driving me a little nuts.

A while ago about a month ago I did a padhack with the madcatz 4716 pad for Xbox. Everything worked fine for about a month then it disconnected randomly and got stuck on an input for the majority of the day at a tournament lol.

I figured it was just the USB cable as there was an exposed cut on the USB cable. So I changed it. Same issue still occurred so I said okay maybe its a short or some bad wiring in the USB cable of the pad since I put this in a soul calibur te ps3 stick along side a imp so its dual moded. Same issue still occurs. It disconnects randomly and sometimes has all 4 LEDs blinking just sort of flashing. I’m gone on ideas I checked every connection so I figure its the PCB but then again it could be something else. If you have any ideas I’ll be willing to try anything.

Worst case scenario however it’s the PCB and I can easily obtain a new one. I did only buy the PCB at a local donation center for $3 so the loss of switching a PCB isn’t that much. I’m just curious about what this issue occurs as its the first time this has happened via padhacking in my expierence


#2

Blinking LEDs tells me there is an intermittent connection. Could be that power or either data line is loose or shorted somewhere.

Stuck input tells me there is a short on one of the buttons.

Check all of the buttons for continuity with a multimeter first, that should resolve your input issue. All of them should be open.

Without images this is as much as I can help.


#3

@deserada‌
I was at work when I posted I can upload a few later. The problem I was thinking was a short somewhere along the USB cable. So at least I’m thinking the right problem. As far as the input getting stuck that has only happened once so I’ll have to see what’s going on with that. The major issue is disconnecting and the blinking lights has not happened since I changed the USB wire completly. However the disconnecting thing happens at least once every so often.

It may just be a simple issue where all I have is a short somewhere but I checked all connections and everything ran properly however of doesn’t hurt to check again


#4

Did you neutralize the triggers in your padhack, invert them, or otherwise wire them for input?


#5

I only use 6 buttons so I wired only the bumpers and I didn’t do anything to the triggers this time


#6

Did you leave the potentiometers on? If so, there shouldn’t be a problem, but removing any potentiometer and failing to neutralize it can cause unpredictable input issues.


#7

This may be the problem then. As I did remove the potentiometers so that the PCB would sit better inside the stick


#8

Easy fix then (as I’m sure you know). You can either replace the potentiometers and glue them in neutral position or wire resistors in.

Remember to have two 10kOhm resistors per potentiometer, one between wiper and high (voltage), and the other between wiper and ground.

If you are confident enough in your soldering skills, using SMD resistors will make for the cleanest job.


#9

Hmmm well this sounds simple enough hopefully this solves the issue. I’m going to upload a picture of the back of the PCB as I Completely removed the entire trigger thing from the PCB in sure the same thing still applies reattach potentiometer with 10kohm resistors.

Sounds like I basically have to re neutralize the pad lol. I guess if this works I know for the future if I want only 6 buttons leave the triggers alone


#10

You only need the resistors if you do not want to reattach the potentiometer.

If you re-attach the potentiometer, go into windows > Devices and Printers, right click on your controller and go to “Game Controller Settings” and then “Properties” to see a live window where you can test input. Move the wiper on the potentiometer until it is neutral (not actuated) and glue it in place.

Hope it works out!


#11

@deserada‌
I wasn’t paying attention you are right I just need to connect the wipers to 10k ohm resistors two for each trigger. From what I remember on the pad those contacts may have came off but I’ll have to see thanks for your help I’ll post my findings and a picture of the back later in the day


#12

If it helps, I recently documented the exact same process with a 4716 (with the exception that I have also neutralized the analogs).

Here’s an image and an exhaustive (hopefully foolproof) writeup of the process.

Apologies for the messy work.


#13

@deserada‌ wow very good guide man. It certainly helped me with my question. Well since I’ve never not wired the triggers I now know what to do. Just got out of work so I’ll be doing this as soon as I get some resistors. Correct we have the same exact pad so I’ll just follow the later part about the triggers. Hopefully it solves the whole disconnect problem as this is the first time and recently the only problem that has been occuring


#14

@deserada‌
Trigger added with resistors seemed to fix the problem. I’m.not getting any crazy inputs or disconnecting I tried the stick out for 5 hours straight so hopefully its in working condition now. Thanks for the suggestion man. I totally forgot all about this. Good thing it was for me and not a customer stick haha