Wireless 360 Controller won't turn on


#1

Whenever I plug in my 360 controller with the Play N Charge, it’ll turn red for a sec, then give me the green light (the “I’m all charged up” light). Then when I unplug the play n charge, the controller turns off, then I can’t turn it back on. The green lights won’t even come on when I hold the Guide button.


#2

Sounds like your battery is gone. This exact thing happened to me, but this was with a cheap battery from hong kong that had a socket in it that you could plug into it from any usb to charge it. Have you tried using a different battery (if you have one) in there?


#3

I had the same thing happen with one of my wireless controllers. For me, it turned out to be some weird glitch with the controller itself. I tried another P&C kit and battery and same thing. I tried the pair I suspected were problematic on another good controller and all was fine.

Thing is, I tried the original combination the next day and everything was fine! The battery started charging the way it should. :wow:


#4

Remove the battery for a while? Re-sync it with the console?


#5

same thing happened to my batteries, i found a solution though. just keep unplugging and plugging the charge cable until the light stays red and let it charge. it may take a couple tries, took me 20 times for one of my batteries :shake:


#6

Try just regular old batteries too. I had a controller that was just dead, sent it into Microsoft and got a replacement covered by the warranty.


#7

Battery can’t hold a charge anymore. Had the same thing happen to me.