Wireless x360 PCB problem(s)


#1

I am currently making a custom stick using a wireless Xbox 360 and am having a few problems. I soldered and tested every button before I mounted the PCB in the controller box. I mounted the board and ran all of the wires to the buttons and the LB solder joint came off in the process. I tried soldering the wire back on but the button wouldn’t work. After a bit more testing I noticed that the controller was actually pressing LB constantly, even after I desoldered the joint. I checked all along the leads and couldnt find where it was grounded. I also noticed that the voltage on Start and Back were around 0.9 instead of 3.3 and wouldn’t work but worked fine when connected to my play and charge kit.

I guess what I’m asking is could the two problems (LB and Start/Back) be related somehow and how could detaching the one point cause all of this. Sorry for the long winded description but I have been working on this all day and am kind of frustrated. Any advice would be greatly appreciated.


#2

How are you soldering the wiring joints?
Cold solder joints (when the wire/metal isn’t properly heated when molten solder is applied) crack and break easily.


#3

Thanks for the reply. I checked the joints and resoldered them just in case and im getting the same results.
Another interesting thing I found is that when I unplug the play and charge kit and the Start and Back buttons go from 3.3 to 0.9 v, the controller thinks I pressed them at the same time so it resets training mode in marvel and calls in the first assist since LB is being pressed constantly.


#4

I fixed one problem only to find another. The start and back buttons now work and the LB button is no longer running at 0 v, but now its running at around 0.6 to 0.7 volts. I’ve searched the forum for any similar problems but I haven’t been able to find any so I could use any advice.


#5

Do you know if you are using the early or late versions of the MS Xbox 360 wireless PCB?

The solder points on both are different
Early Version PCB
Late Version PCB

The differences are the early version is not Common-ground, instead have commons, 1 for the D-pad, 1 for the 4 face buttons, 1 for Start and Guide and 1 for back.

The Late Version is common ground.


#6

I’ve got the late version


#7

I found this little guide by Phreak mods, do you think that this would solve the problem? I dont have the controller in front of me right now so I cant really test it.