WWE Brawl Stick - Impossible inputs and USB problems


#1

I just received a Madcatz Brawl Stick. I chose the 360 version, because I’ll mainly be using it on my PC. I opened the box and checked everything out, and it seemed good to go. But once I plugged it in, I noticed two strange issues, and I’m wondering if I got a bad unit.

The first thing came to my attention on the test screen of Windows’ Game Controller app. When the joystick is set to LS (left stick) and I start from any corner, I can make the stick position show as 0.5 (where 0 is Center, 1 is any direction). In the image below, I’m moving the stick along the bottom rail from Down/Right to roughly halfway back to Down/Center. The switches in the stick are digital, so obviously this shouldn’t be possible. Now, I can’t make the readout stay there, so it’s possible this is just a display bug. However, the fact that I can make it happen over and over again indicates otherwise.

http://i42.tinypic.com/fbb57k.gif

The other issue was immediately noticeable when I plugged in the stick because it didn’t work at all. Windows 7 started installing the 360 controller driver, but then it gave me a “device installation failed” message and the player LEDs started flashing:

The Rock says, the hell is that?!

http://i39.tinypic.com/egcv85.gif

I then plugged it into my netbook (running XP) and the same thing happened except that the player lights just turned off. Thankfully, the installation message in XP showed the actual device name (“MadCatz 360 BrawlStick” etc.), so I knew it was at least communicating with the stick. After much wasted time, I have figured out that on certain computers, the stick will not work if there was something plugged into a “sibling” USB port.

To clarify, my main system (running Win7 SP1 64bit) uses an Intel P45/ICH10R chipset, and each of its USB “root hubs” controls 2 USB ports. If I have another device (ex: a mouse) plugged into port 1, and I plug the Brawl Stick into port 2, the stick won’t work and will be listed in the Device Manager as “Code 10 - Device cannot start”. If I remove the mouse and then connect the stick, the stick will work. If I then plug the mouse back in, everything will continue to work as expected.

I thought this might be a power issue, as the stick wants 500mA power (which is the maximum USB2.0 supplies per port). However, that’s the same amount of power a Microsoft 360 controller requests, and my 360 pad works 100% in these same ports. Also, if I leave the stick plugged in when it’s “Code 10” and reboot the computer, the stick will work normally.

http://i43.tinypic.com/jhqaz7.gif

So I started wondering if this might be a compatibility bug with certain motherboard chipsets. I tried the stick with my netbook, which is running WinXP SP3 and uses the Intel 945GSE/ICH7M platform. It had the same problem - except in this case the LEDs would just turn off. I then did the same test on other systems, making sure the Brawl Stick was being connected to a root hub which was already in use:

-Nvidia ION / WinXP SP3 - no issues
-VIA KT400 / WinXP SP1 - no issues
-Nvidia Nforce2 / WinXP SP3 - no issues
-Intel 945GSE/ICH7M / Win7 Starter (no Service Pack) - no issues

None of these other systems exhibited the problem, but the last one in the list throws a wrench into the theory because it’s the exact same netbook as mine, just with Windows 7 on it. I did notice that unlike my desktop and my XP netbook, the Win7 netbook seems to randomly assign the ports - each time the Brawl Stick is plugged in, it can show up on a different root hub. However, this should not make any difference; it still worked fine when it landed on a root hub with existing devices on it, and my desktop is also running Win7 (though it does not randomly assign ports to root hubs).

All systems tested have the newest 360 driver installed, btw. I called Madcatz’ support and they suggested I check the quick disconnect on the cable (already done), install Xinput (already done), and then offered to RMA the stick because they had no idea what could cause this. I’ve found other reports of this blinking LED problem, but they are all regarding the Xbox 360 and there are no solutions posted (other than unplug and try again).


So to wrap up, sorry for the long post, and if you have any ideas or have seen this issue with your own equipment, please let me know. I have until the 2nd week of February to exchange the stick (and the retailer will pay the shipping), but if there’s nothing “wrong” with it, then there’s really no point, and I might end up with something worse. As far as the actual functioning of this controller, it seems to perform just fine. No problems with stick or buttons, once I get it working…


Any known wwe brawl stick problems?
What Stick/Controller Should I Buy? Read the Guide on Pg 1 Before Posting
#2

I just got a Brawl stick yesterday to mod. I had took it out of its box to test on the PC and noticed a strange problem right away.

It works fine straight away but when you suspend the session to memory and put the PC to sleep mode for a short while… the stick wont work. Buttons 10 & 11 & 13 will turn on. It will then blink the LED.

So its a power issue it seems. I always remember Madcatz as being a company that made shoddy hardware from the early 90s… somethings never change!!

I don’t know if its just my stick that has this problem or its a problem with ALL Madcatz joystick products i.e. SE & TEs.


#3

I’d personally just go for the warranty route. Any fix that I could think of trying would probably void your warranty, and the worst case of which would be replacing the 360 PCB. The warranty route is always my recommended go-to because it’s easiest, and free. Sure, you could probably fix it yourself in some way and it could be faster, but if it’s a PCB problem, then you’d have to replace with a new PCB, which is already costing more, plus if you don’t have any tools to do so, it’s only more expensive from there.


#4

Hey, thats normal, I try this too and has the same behavior!


#5

@CobraKai, I saw your thread the other day but I didn’t get a chance to test that, I’ll reply there shortly.

@Nerrage, was your reply directed at myself, or to CobraKai? The thing is, I plan on voiding the warranty anyway to add other console support. I do not however want to start off with a board that’s already damaged. If the behaviour I’m seeing is “normal” in that it will remain consistent, I will probably keep the stick as it only affects me when I unplug it (which will not be that often). But if no one can duplicate it (preferably with a P45/ICH10R system) then I should probably exchange it.

@sego, thanks for the info. I noticed it does the same thing with the stick set to RS mode, and it’s a bit more visible there because the input is shown as a bar graph instead. Toodles has mentioned a few times that he believes the LT/RT buttons are using a DAC to change on/off into 0%/100% pushed… I have a feeling that the same method may be used for the stick when it’s set to emulate the analog LS/RS inputs, and that there’s a point where the micro-switches do not pass enough current to be “on”, but pass too much current to be “off”. I’m trying to thing of a game where I can test this, preferably a racing game which shows how far you’re steering left/right, but it would have to be one that updates the HUD quickly as well as supporting analogue inputs.


#6

Have you tried on a HUB with its own power supply. My issue was a power issue, so yours might be as well.


#7

Hi CobraKai, I don’t have a powered hub, but I am 100% certain that it is not an issue related to power. Using my previous example, where a mouse is plugged into port one (of two) on the front of my case:

If I plug a passively powered USB hub (a Saitek Mini UFO) into the remaining socket, then connect the Brawl Stick to the hub, it works. Removing the hub and re-attaching the stick results in the blinking lights. Ironically, Saitek appears to be a MadCatz subsidiary. :wtf:

In addition to drawing power from the USB line for the hub functions, this particular model has a large RGB LED in its center which cannot be disabled. If the problem was related to the USB port’s supply of electricity, stealing even more current would certainly lead to the same result.

The unfortunate part is, this leaves only the data portion of the connection, which is much more complicated to debug. I’m looking into it, but if I had to bet on my odds of success I’d say they’re pretty small.


#8

Ah well thats a shame. The only other options are modding the PCB with some kind of dual mod.

I hope you fix it, good luck.


#9

Funny post for the week:

A full fifty days after opening a support ticket with MadCatz regarding the USB problem, they have posted the following reply (and permanently closed the ticket):

A “generic driver”? It’s the Microsoft 360 for Windows driver, designed for 360-certified devices, on three 360-enabled Microsoft operating systems. If I had been unable to find a work-around, my issue may have received more attention, but a one-sentence brush-off after almost two months is simply uncalled for. Even a response like “we can’t replicate/fix the issue” would have been sufficient (and far less [trollface] ).

They also sent me a customer survey on which “Overall Satisfaction” and “Promptness of Response” are the only two ratings I can enter. :rolleyes:


#10

I also had an equally bad support reply, weeks later.

Its there typical get out of jail “We only support it for PS3” response.

Madcatz are a joke!