XB1 Mini Driver users on Win10


#1

I have an XB1 Mini I was planning to use for a mod on my 360 TE w/ bad pcb. Also itll add Xb1 support.
Anyways I load it up, try in SFV, its working well. Then I remembered reading if you hold Back/Start when plugging in it will load up in a different mode to add ps3/ps4(legacy) support.
I try that, still working in SFV. Kool. No, it stops. I check, its still getting power, Device manager still sees it however game controllers says otherwise.

http://i.imgur.com/K7lzLMD.jpg

If I unplug and plug it in without holding anything it still causes this problem.
So I decide to try Update Drivers, Browse, Let me pick to locate an older one.
Sure enough if I roll it back to the 5/26/14 one it works fine. Also worth noting is it only shows 1 bar for Z, axis with these drivers as opposed to rotation as well on the others.
So I update to the newer 10/29/15 and sure enough it’s doing it again. Shows up for about 4 seconds then dies. I try plugging in and out and managed to glitch it where both controllers are cached as shown.

http://i.imgur.com/ECtXAqI.jpg

So now if I plug it in straight up, it will come up as the older driver version and work fine. If I plug in hold Back/Start then it detects as the newer and now it doesn’t show up in the joy panel at all.

http://i.imgur.com/zSRtgMM.jpg

Is this normal behavior for Windows 10? I’m not sure which driver it used prior to me plugging it in with Back/Start. I hate the idea of modding this out and if I held a button by mistake I can kill it until I fix up drivers. For now it is working however it’s not on the latest driver so I don’t know what updates/features I’ll be missing.


#2

Ok, this time the older drivers had the option to Uninstall and remove drivers.
It claims it did but I still see them in the sys32/drivers folder. Anyways, same thing, plugging controller in, it disappears after 5 seconds.
I plugged in w/ start and it created another entry, doesnt show at all in game controllers, but now plugging it normal gives the later drivers and doesn’t disconnect.
So I don’t know what the hell but at least it seems stable. I guess I’ll proceed with the padhack.


#3

I don’t get why people having issues with Xbox 360 and Xbox One controllers on PC lately.
Xbox 360 controller drivers been apart of Windows since Vista and Xbone since Win 8.

And support for 360 controllers go back as far as Win XP and Xbone since Win 7.
I would check Microsoft’s Knowledge base


#4

I used to use this same TE stick on Win7 for SF4 and SFxT and never had issues with it.
I was wondering why so inconsistent. I could understand a pad always working or never working.
This sometimes stuff is really whacking me out.
So others are reporting odd behaviors as well?
I’d rather not hook up my 360 and play something as again it could work fine for hours, after days on PC and then it’s just trash for a bit.
I have a dc stick I put a mini in a year ago for MKX. I guess I’ll try that on PC for a bit and see if any odd behavior.
Not a fan of it as sometimes some of the buttons dont pop back out when you press them.


#5
  1. Xbox one drivers on windows are garbage at the moment. Triggers don’t do shit. Or did Microsoft fix their crap yet?
    or do the triggers actually work in windows 7 but not in windows 10?

  2. Xbox 360 drivers are solid and have no problems.

  3. Madcatz controllers have a custom 360 PCB that identifies as a 360 device to a Xbox 360 and Xinput mode on a PC, and a strange PC driver with no analog support and triggers are registered as buttons under "DirectInput " mode. Madcatz controllers can crash certain games due to how they are registered under directinput, if a game sees both Dinput and Xinput devices (Dragon’s Dogma is one example).

  4. For legacy support with Xbox 360 controllers, seriously…use XINPUT PLUS. Just use it. BEST.PROGRAM.EVER.

Let’s you map the triggers as buttons so LT/RT register as buttons and can be mapped for games like Silent Hill, let’s you switch Analog LS and DP around in xinput mode and then enable DirectInput support so emulators like Callus (Street fighter 2 Hyper Fighting) can see the Dpad, when it only supports Analog joysticks, and so on.


<–HIGHLY recommended.

BTW, the author of joytokey told me about that program (after I registered Joytokey).


#6

I’ll give that a look.
I just pluged in that dc modded stick I made and windows picked it up as a different model.
This one the 11 button blinks when I press Guide whereas the other one didn’t bother. Whereas I think it did before I did the back/start method.
This behavior is definitely not consistent.

http://i.imgur.com/6DElFKH.jpg


#7

Actually they work fine for what the drivers are intended for, the MS brained Game pads.
The drivers were never intended for arcade sticks.

LOL. All Xbox 360 controller are Xinput compatible.

No.

LMAO. JoyTOKey is only realy useful for older game that want to use a keyboard or terribly made games where you are better off with the keyboard.
It was never intended for modern controllers with modern games.


#8

I think you’re missing the point here, Darksakul.
Xinput is an API.
Do you know what you see in windows “devices and printers”? that’s not Xinput.
That’s the directinput driver for the device, not Xinput. xinput is "part"of the driver, however.

Explain why the Madcatz Fightstick Pro X360 version is called a “Madcatz Fightstick Neo” on the PC?
And the “Analog” joystick axis is completely missing, as well as the “Z axis, X and Y rotation?” (X and Y rotation=RS, Analog axis=LS)
It’s all buttons now, because that’s how it’s seen to directinput.

It’s STILL there, though, just only accessible under Xinput.
Joytokey can see the missing “Z axis” of LT/RT on the madcatz, as well as the button identifier (button 11 and 12), and it can also see the nonexistent Analog Axis (LS) and RS (if you put it on RS).

But a directinput game can NOT see LT/RT on the madcatz controller unless the game is designed to handle split axis.
This same limitation applies to the real Xbox 360 controller which I have.

So this is where Xinput plus comes in.

I’ll say it again.
I’m NOT talking about fighting games on the PC here, except my example with Callus (Unless you’re referring to the Callus emulator’s inability to accept Dpad input and only see analog sticks, and won’t see LT/RT).
And my comment about joytokey was made because it was the author of Joytokey who told me about Xinput plus.

I’m just throwing it out there.
I used Xinput plus to be able to use my X360 controller’s analog trigger buttons as regular button equivalents for Silent Hill 3 (Button 11/12).
Without Xinput plus, I would HAVE to use joytokey and map triggers as key inputs.

It’s a very useful program. I guess its not useful if all you’re playing is Street fighter.

Edit again,
I think you’re confusing the purpose of “Xoutput” 0.11, which IS useful for fighting games/Street fighter 5, with Xinput plus.

  1. Xoutput does not work with any Xinput controller (for rather obvious reasons).
  2. Xoutput allows directinput devices to output as an xinput device to a game that supports xinput, without extra input lag (X360CE works also, but this adds some small amount of input lag), so your PS3 can play Street fighter 5/KI.
  3. Xinput plus allows you to remap buttons/assignments on Xinput controllers, and to output directinput mode for directinput games (e.g, to get the Triggers working in a directinput game or change how the Dpad/analog axis works).

#9

Ok, I did notice it was a bit odd when I switched the stick from dpad to the analogs it wouldn’t show anything, and nothing would let me move the dpad choice I think in bottom right.
I’m really stumped as I have too many factors here. Is it the Stick itself? Is it the PCB? Is it the drivers? Is it me, as I know Im not the best.
I was just practicing some Karin stuff on Airforce Base and jeez that stage seems laggy.


#10

So is Dinput. You got a point?

I don’t even know where to be begin how stupid you sound. Both Xinput and Dinput are API, both are parts of the drivers.

Devices and printers are all devices, not just Dinput. I highly doubt printers, monitors, speakers, my keyboard are all Dinput devices.
I think you mean joy.cpl , but I am not going to give you the satisfaction that you were sorta half right.

joy.cpl is a throw back from before Xinput was commonly found, yes but Xinput isn’t new ether.

https://msdn.microsoft.com/en-us/library/windows/desktop/ee417014(v=vs.85).aspx

Still there no reason for Joy to key unless you insist on using a Xbox 360 pad.
My work around back when I played alot of Mame was use a dual-modded controller.
Hold Select (or Start I forgot which) as you plug in the USB cable on a toodles board to get only the X/Y axis movement for setting up the controls.
Next time I plug in the cotroler I did not need to hold Select or Start the settings was saved and the game ignores the POV hat info.

I never said anything about fighting games.

This is where Xinput came in, its for MS muscle in on PC gaming and make exclusions on the market where you have to buy their controllers and buy games that gets their Seal on it.

No one cares about your Callus Emulator, your emulator that hasn’t been updated since 1998 (some sites are still hosting the Win 95 or Dos versions). I went to their webpage and the webpage hasn’t been updated since 1998. I am not surprised it having issues with the POV hat, old Dinput games only wants X and Y axis controls. It has or wants nothing to do with analog, old PC digital game pads used the X/Y axis and not the POV hat.
MAME is the same way.
http://bloodlust.zophar.net/Callus/callus.html
There are by the way plenty of Dinput games that do untilize the POV hat, mostly flight sims.

Guess what PS3/PS3 controllers do not have this issue, set the joystick to LS and you are done or use a older era controller where the D-pad is set to the X/Y axis. *see my Toodles board example.
If you have a PS360+ or Brooks UFB force PS3 mode for your old Dinput games and Force Xbox 360 (or Xbox One) for Xinput games.


#11

Haha, you amuse me. Thanks for the laughs.
I know when I’m right and I know when to not argue with an ignorant jerk.

BTW piece of advice from humanity
Try to not insult people who know what they’re talking about.
You may be a hardware modder but I’ve done FAR more work with hardware AND software than beta testing than you can even dream of.


#12

You, know what you are talking about? LMFAO!!!


#13

Yes I do. You don’t. You build joysticks. Now go back to what you’re good at and stay off my turf.
I’ll give you a little hint. I am not a coward and I don’t back down from challenges.


#14

So anyways, back from the detour and back to TheGlow’s issue.
I apologize about TheGlow, I should not get side tracked like that.

Despite the Xinput/Dinput thing your controller should of worked in the control panel (for whats to be expected for a Xbox One controller).
It sounds like an actual driver issue.

Did you PC originally came with Win 10 or did you install Win 10 via update or clean install?
I am thinking you head to your PC/Mother board manufacturers website, hit up their downloads and download the update drivers for the motherboard.


#15

YOUR turf? A challenge? LOL…WTF… you think you are pony boy from the outsiders or some crap?

you come here and honestly contribute nothing except some self serving information that you think is relevant. Please… tell us again how you are disabled and spew some more about the antiquated programs you feel you are savvy about.

Mr. @Falkentyne , what you’ve just said is one of the most insanely idiotic things I have ever heard. At no point in your rambling, incoherent response were you even close to anything that could be considered a rational thought. Everyone in this forum is now dumber for having read it. I award you no points, and may God have mercy on your soul.

And here is where you reply: “you don’t tell me what to do… you aren’t a mod MISTER!”

knob will be a knob


#16

You know what I’m going to do, asshole?
I’m going to put you and your troll cronies on ignore now. Have a nice day.
If you have a problem with me–deal with me at Evo.
I wouldn’t mind taking your evil, satanic piece of shit out.


#17

even if you ignore me you will still see this when you click to see what I said.

First time i was called evil/satanic… nice! I am ok with Teufel Hunden though.

If the keyboard tough guy can do what the insurgents couldn’t … that will be pretty amazing.

Getting stationed on the west coast in june so hope to be there.


#18

Yeah, it looks like Falkentyne needs a time out.


#19

It’s all good. Always nice to see some fights not necessarily SFV.

This is a clean Win10 install. The only hiccup which I don’t think applies is I did switch to a new mobo/cpu about 6-7 weeks back and did not do another clean install.
But I’ve moved a Windows install between mobos/systems/hdds before without issue.
I’d like to think I have an above average grasp of PC issues as I do work in IT, with A+ and CCNA R&S.
The soldering is for fun as I always had an interest in electrical engineering but never had the opportunity to follow up.

So the 2nd mini, we’ll call it the green one, worked ok, not sure the driver until I did the start/select mode which jacked it all up.
Plugging in the original I did a year ago, black usb wired, appears fine.

Regardless that TE is just behaving weird. I’ve swapped the TP-MA assembly, I have 3 available.
This has now motivated me to finish the roach/begbug VLX to bring home as that would be another 360 device which reportedly had no issues (besides dead roaches, a white spider, 2 bedbugs, cobwebs and some mice bites on the USB wire).

I wouldn’t be surprised if a Brooks PCB would solve everything but I don’t even travel around to play and only playing on PC currently, MAYBE xbone, which I havent touched in over a year for MKX.