XBox-Button of TE is broken


#1

Hi!
I am not tech savvy at all when it comes to arcade sticks and their interior, so this might be kind of a newbie question. Sorry for that.

My Madcatz TE (all stock party, no changes made at all) was working fine for quite a while. After some time the XBox-button stopped working. I didn’t care because I play on PC so I could simply access everything via keyboard.

A few days ago the XBox button started to randomly cause a command to be excuted (open the GFWL-menu) as though the button just has been pressed. As you can imagine, this is pretty annoying during a match and makes playing almost impossible since it happens every 30 seconds or even more often. It even continues to do this when I put the lock-switch on “locked”.

Do you have any suggestions what to do? I bought the stick second hand so no warranty. I could open it but I probably would not see if anything was wrong anyways. You got any advice for me?


#2

Does this happen on an actual Xbox360? Does your Turbo button work with the slider on the ‘Locked’ setting? Is anything resting on your keyboard when this happens? (Home button on keyboard does the same thing.)


#3

I think I can exclude the keyboard because when I plug out the TE it stops and when i plug it in again it starts again.
The turbo button does not work when the lock switch is activated.
I tried the TE on a buddies console yesterday and the same problem occured :frowning:


#4

Do the lights flash like it’s being replugged when this happens? On the console, is it just the normal menu (Dashboard, log out of Xbox live, etc) or the one with the Home button held down (shutdown console)? Are there periods where it doesn’t happen and the stick works normally?


#5

It behaves as if the button was repeatedly pressed, not held down. So the menu opens and closes and opens again etc.

The light is working and also behaves normally when replugged and all that. And yes at the moment it seems to work normally but I had short periods of the stick working correctly before. It probably won’t stay like this for too long.


#6

Well, my thinking is this:
-Since it happens on console and PC, the stick is telling the console that the Home button is pressed.
-Since its intermittant, it’s not a physical short. Chances of an unopened stick developing a problem with exposed wires occasionally touching is too slim to really consider.
-Turbo doesnt work with the slider on locked, so KGND is in fact disconnected from GND as it should be. So, the problem is NOT the physical part under the Xbox pushbutton.

So, it’s definitely electronic, on the main pcb of the stick. There are a few things that could be tried to resolve it or identify down the problem, such as disconnecting the ribbon with the XGUILD signal between the main PCB and the daughterboard, checking the voltage on the XGUILD line, removing the cap on the XGUILD line (come to think of it, I dont think there is one), or adding a pull up resistor. But since your stick is stock, you may want to check with MadCatz to see what they can do if anything. If they can help, go for it. If not, what to do next depends on your tech skill level.


#7

First of all, thanks a lot for taking the time to help me!
I just wrote an email to Madcatz. If they tell me, I’m screwed, I will come back here to try to figure things out.

To my nooby self your conclusions sound quite logically. So far I do not quite understand everything you said in the last post. I know the PCB is the “mainboard” of the controller. And it does have a second board for the controls in the upper left it seems (the XGUILD thing?). But I am willing to figure stuff out and go through some how-tos and FAQs etc. should it be needed.


#8

call madcatz.
they never answer their emails.


#9

Maybe the support for Germany is a bit better and I am lucky :wink: I will call them if they do not respond after a few days though. Thanks for the lead.


#10

Sorry for necroing the thread after quite a long while but I had a lot of bigger problems than fixing my TE. Now I have dealt with those, I still do not have a working arcade stick so no SF and BB for me :frowning:

So Madcatz actually answered my mail about a week later and it wasn’t even some automatically generated bullshit! They basically told me, it’s my own problem and they told me to go to some electronics store that offers a repair service.

First I opened the stick myself but since I am a total noob, I thought I might try some repair service first, before I start messing with all them wires :wink:

So I went to a store that offers a TV and remote repair service. Those people told me they could look into it and if it there was something wrong with the soldering or so, they could probably fix it. But they advised me to go to a PC repair store. So I went from one PC store to the next and they all told me that they don’t do any soldering or other work nowadays, they just test parts and exchange the broken ones. In a pure electronics store the old guy behind the counter told me he does not know about such “newfangled stuff”.

After some searching I found a PC repair store who also do chip level repairing. They will have a look at it and tell me if they got anything until next friday. I’ll post wether they got it fixed or not for future reference, if anyone else has a similar problem.


#11

You are scratching up the wrong tree

Try here

Need a Modder in Your Area? Check This Post.


#12

I don’t know about the availibility in Germany, but if you can find a Madcatz SE or WWE brawl stick, you may be able to do a PCB swap and perhaps use whatever you have in Germany that is like craigslist, or ebay to get rid of the case.


#13

I will probably try this next, if the PC guy fails. Although looking at hardedge will probably be more successful.


#14

Seeing as how you don’t even use the xbox button, Have you considered disconnecting the button all together? No button means no faulty input.


#15

I disagree with your logic. The problem still occurs when the lock switch is set to locked. Electronically, there would be no difference between locked and no button at all.


#16

That is also what I thought.
Got my stick back from the store and they told me, something was wrong with the connectors (not sure if this is the right English word) between the main PCB and the receiving end where the cables from the XBox-PCB thing are put in. That probably led to errornous signals between the two boards. They resoldered that stuff[S]. Now the XBox button is dead but at least I can play on the PC for now.[/S]
Thanks again for all your thoughts and help on the issue. SRK tech talk ftw!

EDIT: It seems it only worked for like 2h and now it does that random stuff again; I tried disconnection the xguild pcb (just to be sure) and it didn’t help. So the main PCB is broken and I will do a swap.