Xbox360 Controller Diagonal Input Workaround for PC


#1

Hi,
Some of you may have noticed that the corners are hard to hit for xbox360 controllers. Here is a temporary fix until Capcom releases an update for it.

The idea around this fix is to map the joystick input to keyboard keys and then mask the joystick inputs from SFxT so that there are no double inputs.

You will need:
[INDENT=1]Xbox 360 Controller Emulator[/INDENT]
[INDENT=2]http://code.google.com/p/x360ce/downloads/detail?name=x360ce.App-2.0.2.158.zip&can=2&q=[/INDENT]
[INDENT=2]Currently version 2.0.2.158[/INDENT]
[INDENT=1]Xpadder (or similar)[/INDENT]
[INDENT=2]Latest version 5.7 (not free)[/INDENT]
[INDENT=2]Version 5.3 is freeware[/INDENT]
[INDENT=2]http://fileforum.betanews.com/detail/Xpadder/1148671810/1[/INDENT]

x360ce will mask and Xpadder will map.

Steps:
[INDENT=1]Plug in the Xbox360 controller and run x360ce.[/INDENT]
[INDENT=2]If this is the first time running it, it will ask you to make an x360ce.ini file and an xinput1_3.dll file. Do it.[/INDENT]
[INDENT=1]Click cancel when it asks you to search for settings.[/INDENT]
[INDENT=1]Make sure the Controller tabs are green at the top, indicating that the controllers are connected.[/INDENT]
[INDENT=1]Make sure nothing is mapped on the controller.[/INDENT]
[INDENT=2]Go the bottommost drop-down box next to the Load button and select clear. Press Load and then Save. You can close x360ce.[/INDENT]
[INDENT=1] Move x360ce.ini and xinput1_3.dll into the root directory of SFxT.[/INDENT]
[INDENT=2]The two files should be in the same folder as x360ce.exe.[/INDENT]
[INDENT=2]Put them where you installed SFxT to. Same place as SFTK.exe. Such as C:\Program Files\Capcom\Street Fighter X Tekken[/INDENT]
[INDENT=1] Run Xpadder[/INDENT]
[INDENT=2]You might need to run it in compatibility mode (Vista SP2)[/INDENT]
[INDENT=2] It’s going to ask you where to install program files and such. Do as you see fit.[/INDENT]
[INDENT=1]Click on the controller icon at the top left and make a new layout.[/INDENT]
[INDENT=2] Read the instructions in the window to make your controller layout. It is self explanatory.[/INDENT]
[INDENT=2] Image isn’t important.[/INDENT]
[INDENT=1] Once you have your layout, click on the buttons to map them to keyboard keys.[/INDENT]
[INDENT=2] You can map them to the SFxT default values for keyboard input or whatever you want. Just remap them in SFxT later.[/INDENT]
[INDENT=1] Adjust the corner zones for the joystick.[/INDENT]
[INDENT=2]Click on the little wrench icon next to the joystick on the button layout and click on settings.[/INDENT]
[INDENT=2]Change the diagonal size to the SSF4 default value of 40 degrees. Or whatever you like.[/INDENT]
[INDENT=2] Close the settings window.[/INDENT]
[INDENT=1] Save the settings and leave Xpadder running whenever you play SFxT. [/INDENT]
[INDENT=2] Click the game controller on the top left and save the configuration file.[/INDENT]
[INDENT=2] You can close the Xpadder window and it will run with an icon in your system tray.[/INDENT]
[INDENT=1]Go into SFxT and map your keys[/INDENT]
[INDENT=2]All your inputs should appear as keyboard inputs. It will show that an Xbox360 controller is connected, but everything you press on the controller should be a keyboard key. Use keyboard 1 or keyboard 2 for your button configs.[/INDENT]
[INDENT=1]Play normally.[/INDENT]

Yeah.
[INDENT=2] [/INDENT]


#2

I’m not having any problems with it whatsoever using a 360 SF4 fightpad on PC.


#3

This is mainly for the problem corner zones on the joystick as mentioned in the second sentence. Dpads work perfectly.


#4

Also, default deadzone is 40% fyi.


#5

Works very well, thank you!


#6

i think i remember xpadder adds input lag doesnt it? i tried using it before the ae pc patches where it wouldnt detect my stick and it felt off.